-   Slackware (
-   -   Superblock Check error (

C-Sniper 10-19-2007 11:01 PM

Superblock Check error
I have slackware 12.0 currently set up on a dual boot with windows (using bootpart and the ntloader) Recently i shut down my slackbox and rebooted it. now though it is saying that it cannot find an ext2 filesystem on the superblock.
Here are my partitions
/dev/hda1 Windows
/dev/hda2 Swap
/dev/hda3 Slackware

i have tried running e2fsck -v -y /dev/hda3 but to no avail

any ideas?


Carpo 10-20-2007 03:12 AM

right im not the best in the world at this but try pointing it to one of the superblock backups - norm 32768 is the first think its e2sfck -cy -b 32768 /dev/hda3 - not sure on which way around it has to go but i think its something like that

duryodhan 10-20-2007 06:27 AM

what does fdisk on the HDD say?

C-Sniper 10-20-2007 09:37 AM

the cfdisk shows...

[B]/dev/hda1 Windows 35GB
/dev/hda2 Swap 500Mb
/dev/hda3 Linux 20Gb

Alien_Hominid 10-20-2007 11:22 AM

e2fsck -b 8193 /dev/hda3

duryodhan 10-20-2007 11:54 AM

also try and run badblocks ...
man badblocks

C-Sniper 10-20-2007 01:24 PM

ive tried to do the
"e2fsck -b 8193 /dev/hda3" to no avail
ive run "e2fsck -c /dev/hda3/" with no bad blocks or sectors.
i will try "man badblocks" though.

C-Sniper 10-20-2007 08:19 PM

badblocks -s -v /dev/hda3

No bad blocks.

I finally said screw it.
Windoze is gone. and now there is only linux.

Alien_Hominid 10-21-2007 01:34 AM

I had similar prob when was fixing partition order with fdisk. Boot with live cd, mount /dev/hda3 and check that you have correct entries in fstab.

All times are GMT -5. The time now is 12:19 AM.