-   Slackware (
-   -   Super slow 3D Accel. (

Zujin 11-24-2004 10:47 PM

Super slow 3D Accel.
Ok, i started my first true linux adventure w/ suse 9.1, linux 2.4.xx i think. With that, i ran UT 2004 on high at 60 fps and outloaded my windows xp and both my freind's xp machines during map changes. Now that im running Slack 10, linux 2.6.7 on the same system:
P4 2.26
512 RAM
nVidia driver 6629

i BARELY get 25fps on normal. glxgears is giving me at the most 3500 fps. i know i dont have the fastest machine but come on. Here is a short peice from my Xorg file:
Section "Device"
Identifier "NV AGP"
VendorName "nvidia"
Driver "nvidia"
Option "NvAgp" "1"
#VideoRam 4096
# Insert Clocks lines here if appropriate

and i have tried NvAgp as 0 also. Any help would greatly be appreciated.

Ps, this is the 1st problem i havent been able to sovle by reading the forums(about 5-7). Thanks Guys.

H2O-linux 11-24-2004 11:03 PM


Zujin 11-25-2004 12:08 AM

i just ran some stuff and hopefully it will help.
zujin@zujin:~$ cat /proc/driver/nvidia/agp/status
Status: Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem.

EDIT: after playing w/ some more options in BIOS and changing NvAgp to 3, i got it to work. sorry for the wasted space.

cybermonkey 11-25-2004 03:45 AM

You need to have
Load "glx"
Load "dri"


All times are GMT -5. The time now is 03:58 AM.