LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-07-2010, 05:35 AM   #1
Wed
Member
 
Registered: Sep 2005
Location: Sweden
Distribution: Slackware
Posts: 173

Rep: Reputation: 34
Stuck with 640x480


If I missed a match in my search for resolution, then I'm sorry.

I made a total reinstall of Slack 13.1 the other day and all went seemingly well. After a lot of experimenting, and deciding I wanted the disk partitioned differently, a reinstall felt about right.

But when I started X the resolution was all too low. xorg.conf was adjusted with the properties of my screen (GDM 4011P). Once upon a time, the Xorg config-tool would ask me my opinion, but now it flashes by and I have to live with what it comes up with. Highly annoying!

The nVidia driver was installed (legacy for GeForce 3). I know the config is read, because it fails parsing if I have kHz with the sync-figures. But it otherwise disregard my wish to run at 1280x1024. In XFCE I can run the nVidia configuration tool, but it offers only auto, 320x240 or 640x480.

The screen is too small for me to click "ok" on several occasions.

The machine is capable of 64bit, 2GHz. But I installed the 32bit version of 13.1, it has 1,5GB RAM.
 
Old 09-07-2010, 05:39 AM   #2
xeleema
Member
 
Registered: Aug 2005
Location: D.i.t.h.o, Texas
Distribution: Slackware 13.x, rhel3/5, Solaris 8-10(sparc), HP-UX 11.x (pa-risc)
Posts: 987
Blog Entries: 4

Rep: Reputation: 252Reputation: 252Reputation: 252
Greetingz!

First, make a backup of your xorg.conf file. Then run "Xorg -configure". It will load every driver it can and write a new xorg.conf file.

The new file will probably look like this (but with your nVida driver stuff);
Code:
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Section "Module"
EndSection
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection
Section "Device"
        Identifier  "Videocard0"
        Driver      "r500"
EndSection
Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
 
Old 09-07-2010, 06:13 AM   #3
hughetorrance
Member
 
Registered: Aug 2009
Location: London North West
Distribution: x86_64 Slack 13.37 current : +others
Posts: 459

Rep: Reputation: 59
The screen is too small for me to click "ok" on several occasions.

When in low resolution you can hold alt and then press your mouse and bring the ok button into view... !
 
1 members found this post helpful.
Old 09-07-2010, 07:48 AM   #4
Wed
Member
 
Registered: Sep 2005
Location: Sweden
Distribution: Slackware
Posts: 173

Original Poster
Rep: Reputation: 34
@ hughetorrance Thanks!

Here is my new xorg.conf. The monitor section is empty ... again. At some point I received an error in loading xgi. I ran both xorgsetup and X -configure. They were both identical as far as I recall.
Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/75dpi"
	FontPath     "/usr/share/fonts/100dpi"
	FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
	Load  "extmod"
	Load  "dri2"
	Load  "glx"
	Load  "dbe"
	Load  "dri"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
        #Option     "DualHead"           	# [<bool>]
	Identifier  "Card0"
	Driver      "nv"
	VendorName  "Unknown Vendor"
	BoardName   "Unknown Board"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
Old 09-07-2010, 09:04 AM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
I would try one of two possibilities:

1) Use the

Code:
Option "UseEdidFreqs" "FALSE"
and then add the correct HorizSync and VertRefresh options to the Monitor section.

OR

2) Use the

Code:
Option "UseEDID" "FALSE"
or a variation of

Code:
    Option "UseEDIDFreqs" "FALSE"
    Option "UseEDIDDpi" "FALSE"
    Option "ModeValidation" "NoEdidModes"
and add all the necessary info to xorg.conf


Both of these options force the driver to not use the EDID it gets from the monitor, which it seems is not correct.
 
2 members found this post helpful.
Old 09-07-2010, 09:39 AM   #6
Wed
Member
 
Registered: Sep 2005
Location: Sweden
Distribution: Slackware
Posts: 173

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by H_TeXMeX_H View Post
I would try one of two possibilities:

1) Use the

Code:
Option "UseEdidFreqs" "FALSE"
I used that one. I put it last in section "Inputdevice". If that's the correct place, I don't know, but it works! The resolution became very very high. But now at least, the resolution I want to make use of shows up in the graphical nVidia-tool.

To me the actual problem is solved, but I still don't like that the solution isn't more apparent.
 
1 members found this post helpful.
Old 09-07-2010, 09:43 AM   #7
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
Oh, do make sure to add the correct HorizSync and VertRefresh options to the Monitor section, because the monitor may not be designed to run at huge resolutions like that, check the monitor manual to be sure.
 
1 members found this post helpful.
Old 09-07-2010, 09:45 AM   #8
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,020

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Well, if you had looked at the contents of /var/log/Xorg.0.log, you would have been able to see what the monitor was reporting as its supported frequencies/resolutions. That would have led you to fixing the reporting problem or deciding to ignore what the monitor is telling you.
 
Old 09-07-2010, 10:05 AM   #9
Wed
Member
 
Registered: Sep 2005
Location: Sweden
Distribution: Slackware
Posts: 173

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by H_TeXMeX_H View Post
Oh, do make sure to add the correct HorizSync and VertRefresh options to the Monitor section, because the monitor may not be designed to run at huge resolutions like that, check the monitor manual to be sure.
That was done accordingly, sorry for not mentioning that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
stuck in 640x480 in knoppix liveCD redss Linux - Hardware 2 07-22-2007 04:59 PM
Xwindows - Stuck At 640x480 For 2 Months :( ligerdude Linux - Newbie 8 10-11-2005 08:11 PM
X.org stuck at 640x480 on Via KM400A rfarmer768 *BSD 2 12-23-2004 05:22 PM
Stuck at 640X480 :( BigDaddy Linux - Software 1 09-28-2003 04:33 PM
X stuck in 640x480 after nvidia install SeoushiSan Linux - Software 1 12-09-2002 03:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration