-   Slackware (
-   -   Strange xz error With sqlite (

business_kid 11-01-2012 12:50 PM

Strange xz error With sqlite
To prevent GE moaning, I went trying to 'explodepkg' sqlite-3.x(32 on slackware-14.0. I had a d/l of the iso, which I loop mounted

Xz barfed - "I/O Error - file format not recognized"

So I went to the nearby mirror, ( and tried there. Same error.
Never mind, I thought, I'll just use 13.37's
You guessed it - same error. Other packages work fine :-O. I've just exploded a couple. What's the deal?
Is it a dud package? April Fool's joke? BTW Did they release on April 1?

Alien Bob 11-01-2012 01:52 PM

I downloaded it and tried explodepkg on my slackware 13.37 64-bit server. No problems.
Give us the output of "uname -a" and "cat /etc/slackware-version" please. As well as the exact full commandline you are using.


business_kid 11-02-2012 07:01 AM

Bah! Something stupid here, then. Thanks for checking.

/Checks carry on here
OK. The iso I have seems to be broken for sqlite, and that only AFAICT.
Today's download works - explodes so I can grab the libs :-/.

For the record, the exact error (with cp) was

bash-4.2$ explodepkg /mnt/tmp/slackware/ap/sqlite-3.7.13-i486-1.txz
Exploding package /mnt/tmp/slackware/ap/sqlite-3.7.13-i486-1.txz in current directory:
cat: /mnt/tmp/slackware/ap/sqlite-3.7.13-i486-1.txz: Input/output error
xz: (stdin): File format not recognized
The last line also was the error on the downloads.

All times are GMT -5. The time now is 08:48 AM.