LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Strange Vim settings under Slackware 10 (https://www.linuxquestions.org/questions/slackware-14/strange-vim-settings-under-slackware-10-a-212198/)

Lars79 08-01-2004 02:59 PM

Strange Vim settings under Slackware 10
 
HI,

I have a fresh installation of Slackware 10 and problems using Vim. I'm new to Linux but used Vim on my Debian 3.0 router without any problems. When I use Vim on my Slackware system there are lots of strange things going on. For example:

- I have no -- Insert -- in the lower left corner when in Insert mode
- Cursor keys print letters when in Insert mode
- Backspace doesn't work as expected
and so on...

An echo $TERM on both system is set to xterm. There is no .vimrc in the root/user folders, even slocate can't find one. I searched the forum and google but couldn't find a solution for that. It would be nice if someone had a solution how to make Vim act the "normal" way, because I don't want to switch to another editor. Thanks a lot =).

Lars

Cedrik 08-01-2004 03:04 PM

Try to begin with a workable config :

cp /usr/share/vim/vim63/vimrc_example.vim ~/.vimrc

Then adapt it to suit your needs

Lars79 08-01-2004 03:17 PM

Thank you very much. I will try that =).

Edit: Works great.. Thanks =).

Ninaw 08-01-2004 08:15 PM

You're not experiencing anything strange. It's just the default configuration. Slackware expects its users to configure things first so that the user knows what it's all about and doesn't get confused when using another system.

Read the vim manual pages and the built-in help. Virtually any behavior can be modified to suit your needs. It's actually a lot of fun to make Vim submit to your demands.

If you're lazy try to find a config file in http://dotfiles.com/

Lars79 08-02-2004 03:52 AM

Hi Ninaw,

thanks for your reply. I use the example configuration that Cedrik suggested. I changed a few things but it is a quite good basis to work with. I really like the Slackware behavior to let the user configure everything. The problem with Vim was that is was, at least for me, nearly unusable in the default configuration. Because I never experienced that before (under Debian it ist already configured from the beginning on), I didn't know how to change that, which of course was my fault and not Slackware's. Because I never used another editor like joe or nano on the shell I also didn't want to switch. Because of that I had problems to edit configuration files before having X. Thanks to you guys, I will know what to do next time =).

dunric 08-02-2004 08:50 AM

What are you seeking for is nocompatible option, so in your ~/.vimrc you may have:

set nocompatible

I like Slackware too, because all apps & kernel are in stock/pristine form waiting to tweak them to your needs :cool:


All times are GMT -5. The time now is 03:23 PM.