-   Slackware (
-   -   Strange mouse behavior in SDL games (

qweasd 01-19-2013 02:44 PM

Strange mouse behavior in SDL games
Running Slackware 14.0 x64 with 3.6.11 kernel (Pat's config).

I am seeing an interesting bug in wesnoth and openttd, both SDL games I got from slackbuilds. When in full-screen, everything is great. But in window mode the left mouse click does nothing. Amazingly, Ctrl+LMB and LMB+RMB have the effect of LMB, as far as I can tell. Anyone else seen this?

bobzilla 01-20-2013 02:58 PM

That is a known problem with SDL 1.2.14. There is also a corresponding entry in Wesnoth bugzilla:

It points to this bug report on SDL bugzilla:

You'll find attached a patch accepted by upstream. I have tested briefly with Wesnoth, Dosbox and DosEmu and it worked with out any problems.

If you can't get around, I uploaded the modified SlackBuild with all needed files here:

If you decide not to trust me, you can fetch only sdl.SlackBuild and SDL_x11events.c.diff.gz, compare (diff) them with the original SlackBuild and patch and then get the rest of files from an official Slackware mirror like:

Whatever fits you the best. Anyway, I hope this helps. ;)

Btw, I reported the bug, so it might get resolved soon.

qweasd 01-20-2013 03:13 PM

Oodles of thanks. Marking it as solved.

bobzilla 01-20-2013 03:17 PM

You're welcome. ;)

All times are GMT -5. The time now is 02:19 AM.