-   Slackware (
-   -   strange LILO install problem (

dryhte 03-11-2005 10:02 AM

strange LILO install problem
I must be doing something wrong, because I've been having this problem for ages and it just won't go away.

I may be a newbie, but I have successfully installed Slackware and worked with it in a dual-boot configuration before... so I don't see what I'm doing wrong now.

here's the problem:

I install slack 10.1 normally (but had the problem with 10.0 too), and then when it's time to install Lilo, neither of the two options (I don't have a floppy drive, so that one's out) works... 'sorry, but the attempt to install LILO has returned an error, so LILO has not been correctly installed' etc...

I've had this problem on the following hardware:

-IBM Thinkpad 570E
-Compal cl56 (centrino notebook)

with XPsp1, sp2 or 2ksp4 installed first, on ntfs (of course)

You probably need more info, so tell me if you do :)

A hint as to how I can avoid reinstalling all of Slack again before getting the option to install LILO would be helpful as well :)

Thanks guys/girls...


Seppel 03-11-2005 11:08 AM

Hi drythe,

could you please post your /etc/lilo.conf? that might help :-)

You can configure Lilo at any time by running "liloconfig" as root.

Here's also a small howto-boot Slackware if your dual boot is not running (and you didn't already know):
Boot from Slackware CD 1, then type (at very first prompt) "bare.i root=/dev/hda1 noinitrd ro" as the above text says. This is, if you're using kernel bare.i and /dev/hda1 is your slackware partition; if you've got other values, please replace hda1 and bare.i with the correct values :-). This will boot the Slackware version installed on your hard disk.



dryhte 04-25-2005 02:58 AM

Hi guys...

I got disheartened, and quit trying that last time. Yet, yesterday I tried again (this time I tried to install Minislack on my laptop, which is essentially a slimmed down slackware). EDIT: I tried again and got the same error as before.

I don't have that pc here at work so can't write up the etc/lilo.conf, but the thing is that this also happens with the default lilo.conf (i.e. when you tell the installer to try and install lilo all by itself...)

What I can tell you about the fstab is the following:

(off the top of my head)

- hda1 is reiserfs, 10 gig, primary partition, bootable
- hda5 is swap, 1.5 gig, logical partition
- hda6 is fat32, 27 gig, logical partiton

I tried autoinstalling LILO, installing it to superblock and to MBR, but nothing worked...

Please help a long-time :newbie: ... (I started trying Slackware about 5 years ago, but hardly used it back then because of gaming addiction ;) decided to try again though...)

jonkristian 04-25-2005 06:15 AM

I think i know what your problem is, and it sucks big time...
Get a hold of a win98 bootdisk and boot it, after booting type fdisk /mbr (this will clear the master boot record) Now, reboot using slack cd as mentioned above, edit lilo.conf and remove windows boot, also check that the right root adress is in the linux boot line. save and exit, type lilo and it should say *Added Linux or something, reboot...

If that doesnt work; boot again with the cd and type liloconfig as root and you will enter the configuration screen...

dryhte 04-25-2005 01:05 PM

Ok I can try that... but can you give me the background of what you think is wrong? I tried this with several different harddisks, on at least two different computers...

detpenguin 04-25-2005 01:59 PM

i had the same problem. i just installed GRUB and it boots fine now. i've never had much luck with LILO, but GRUB has never failed me. you can grab GRUB from the extras at or from disk 3 if you have all 4 disks for slack 10.1

once you have it installed, just open a terminal, su to root and type "grubconfig" and it will launch for you.

All times are GMT -5. The time now is 06:42 PM.