-   Slackware (
-   -   strange behavior after slackware upgrade and (

swatnio 08-04-2011 01:58 AM

strange behavior after slackware upgrade and
the solution is at the end of this post (not in the replies)

Hello there!

First: I am using Slackware 13.37 64bits.
Second: perhaps my english is bad.. sorry!

Yesterday I upgraded my slackware (with slackpgk upgrade-all) (i think it was my first upgrade with the 13.37), everything upgrade ok, I think... also, when the upgrade finished, i tried to install google chrome, but i couldn't[*]
Suddenly, everything started to fail.. I couldn't execute anything (telling me that the command was not found) and KDE went crazy.., so I changed to another terminal and logged in as root, everything was ok, i could execute everything, so i tried to log in as my user and I couldn't.. with an strange error: "couldn't change to directory "/home/my_user". With the root user i checked that folder /home/myuser was there and with right permissions, and all was OK.. except because i couldn't log in with my user!, so, i rebooted and everything went back to normal, i could use my user, execute programs, etc.
as it was too late, i shuted down the computer and went to sleep...

But today... i realized i have no more internet connection! (now I am using windows..)
I am using an ADSL Huawei startax mt810 modem, it's old, but i don't understand what happened!

I know you might not have any clue, but... do you guys have any idea?

[*] about why i couldn't install google chrome... well, as i said it was late and i was a bit tired, but i needed the chrome! but the source code was too heavy to download, so I tried to download the slackware package that google recomends:
it is for slackware 32bits, but as i installed the multilibs some time ago, i thought it could work... well, it didn't, i had some missing [32bits] libraries, so I uninstalled the google-chrome package... then i thought of downloading the debian-64bits-package frome the oficial google page and convert it with "alien -t", i tried it but alien FAILED..., so in my fight against google chrome, I tried to install the debian package by my self.. it isn't hard.. it's just a tar and 7z compresed files.. so, somehow, I installed the google chrome, but, it didn't work either... i had some missing libraries [do'h]...

here is the solution!

the solution
the files /etc/ppp/pap-secrets and /etc/ppp/chap-secrets where empty (only comments) and in those files there must be the username and password, so I wrote there in both files

"username@host" * "password"
(yes, with quotes, and yes.. replace with your user and your pass)

but i don't understand what happened, this is how the problem started (in few lines)
I have an slackware 13.37 64bits and i run slackpkg update and slackpgk upgrade-all.
at the same time, i was trying to install google chrome.
suddenly the machine went crazy, and after reboot everything was normal, but my adsl usb modem huawei smartax mt810 didn't connected (so i didn't have internet).
when i run pppoe-start (to connect to the internet), the modem tried to connect but after some secconds i received a timeout.. (if the message had been "wrong pass" or something like that...)

so, here is how i came to the solution:
after markush advices about multilibs and the slackpkg upgrade, i reinstalled the multilibs (anyway, the modem doesn't need them). as it didn't resolved the problem, i tried to reinstall the modem drivers and see if everything was ok, i reinstalled libatm and br2684ctl, but i didn't touched ppp or it's config. However, it didn't helped, ultil i read this tutorial (in spanish)
where it suggests you to see the files
and see that the user-pass were there... but my files didn't have anything but comments!.. so i wrote there the user and pass as described above

thanks markush!

markush 08-04-2011 02:18 AM

Hello swatnio,

my first idea when reading your post was: if you have multilib installed, which packages did you blacklist for slackpkg? as you know the multilib-environment substitues some of the native Slackware packages and if you don't blacklist the multilib-packages they will be substituted by slackpkg with the native ones.

Looking at the changelogs for 13.37 I cannot seem to find any upgrades which can cause the problems you describe. BTW I'm running Slack-13.37 on two machines (and current on another) and I did not experience such problems within (at least) the last year.
Are you sure that you have configured for the 13.37-mirror and not the mirror for current? you may check the /etc/slackpkg/mirrors file.

Could you please provide more information about your hardware?


swatnio 08-04-2011 10:56 PM

hello there! thanks for your reply!
here is my pc:

ADM Athlon 64 x2 4400
gforce 8400 gs
ADSL Modem huawei smartax mt810, connected by USB, and it uses the nas0 and ppp0 network devices

and here is my dmesg:

don't know what else to tell you...

first, i didn't know i needed to blacklist some packages when i use multilibs... anyway, if there had been any conflics between the miltilibs and the upgrade, wouldn't I had lost the 32bits lib and keep the 64bits? I don't remember why i installed the multilibs but i *think* my modem use the 64bits libs.
thees are my blacklisted packages:

BTW: what should i blacklist?

and the last thing, my slackpgk mirror is OK, slackware64-13.37

I think that what messed all up was my crazy idea with chrome...

and of course, the modem itself is fine, it works in windows and in another slackware pc, which i am using right now.

UPDATE: i have some memories... i saw that i-dont-remember-what about gcc was updating (but my i was so n00b that i didn't realized..). so my gcc multilibs libraries would have been "updated" to the normal 64bits libs, so perhaps the glibc libraries were "updated" too! that would explain the "strange behavior", wouldn't it?. I will reinstall the multilibs and see what happen.

Bytes and thanks again!

markush 08-05-2011 01:13 AM


you could edit your /etc/slackpkg/blacklist file and delete all blacklisted packages (just commet them out with a #).
Then run

slackpkg update
slackpkg clean-system
slackpkg install-new
slackpkg upgrade-all

this should leave you with a stock Slackware64-13.37 installation without multilib.

When running "slackpkg clean-system" you can select not to remove any packages which have nothing to do with your problem.

Afterwards you should try to get your internet-connection back. And if everything is working properly you can reinstall multilib, but be sure to read the manuals for slackpkg and multilib and blacklist the multilib-files before the next time trying an upgrade with slackpkg.


swatnio 08-05-2011 11:58 PM

hello there! it's solved!
so wired... the problem was:
2 files, that contains my user-pass for my adsl modem, were "blanked", i meant, the user-pass weren't there!

i'll update the main post with the solution.

perhaps... something got upgraded-downgraded and those config files were replaced with new files, or i don't know, it was all strange! :/
anyway, thanks for your help! and i have blacklisted my multilibs as the tutorial says.

As we say in spanish:
Saludos y muchas gracias!

bonixavier 08-06-2011 12:16 AM


Originally Posted by markush (Post 4434224)
Then run

slackpkg update
slackpkg clean-system
slackpkg install-new
slackpkg upgrade-all

Shouldn't clean-system come after install-new? I mean, we had util-linux-ng replaced by util-linux and, at another time, the change of the packages formats. Couldn't that order lead to some weird problems, like missing utilities required for updating the rest?

swatnio 08-06-2011 12:30 AM

now the solution is at the main post :)


Originally Posted by bonixavier (Post 4435039)
Shouldn't clean-system come after install-new? I mean, we had util-linux-ng replaced by util-linux and, at another time, the change of the packages formats. Couldn't that order lead to some weird problems, like missing utilities required for updating the rest?

i agree with you :)
but one question..
i had slackware 13.0 64bits installed by DVD (an almost-fresh install), and when 13.37 came i upgraded following patrick's tutorial in UPGRADE.TXT, i mean, without upgrading to 13.1 in the middle. Do you think i can have any kind of problem with that?

bytes and thanks!

markush 08-06-2011 01:03 AM


Originally Posted by bonixavier (Post 4435039)
...Shouldn't clean-system come after install-new?...

I thought of the special situation here. It was clear that there are some packages which have to be removed. But you are right, this may lead to problems.

When normally updating my system I use "clean-system" at last.


All times are GMT -5. The time now is 04:34 PM.