Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-28-2013, 10:16 AM   #1
LQ Newbie
Registered: Oct 2006
Location: UK
Distribution: Slackware
Posts: 20

Rep: Reputation: 1
Question Steam - Titans Attack - Slackware 14 64bit - no sound


Does anyone have Titans Attack running with sound on Steam ? Mine gives me an error that no sound card found (java). It looks like OpenAL 32bit compat issue but i don't have that problems with other games via Steam and i got OpenAL 32bit installed.

I can't get out of Steam any error about it in the console. Any help will be appreciated.

Old 03-02-2013, 06:07 AM   #2
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,237

Rep: Reputation: Disabled
I wish I could tell you what's wrong, but I do not own the Titan Attacks game, so I have no clue as to what is happening. Perhaps you should also post this question on the Steam forums.

You say this is a Java game. You could try installing my minecraft package, which is also a Java game, which needs OpenAL for sound. If sound is broken there as well, you know that it is not Steam or the Titan Attacks game.

Contact me in private (my "" email address or by posting to if you have issues with getting Minecraft going because I think that is off-topic for this thread.

Cheers, Eric
Old 03-03-2013, 10:30 AM   #3
LQ Newbie
Registered: Oct 2006
Location: UK
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 1
Thanks Alien Bob for advice.

I checked demo version of Titan Attacks from developers website. They provide package with 32 & 64 bit environments. Forcing to run it in 32 bit, games does have a sound and do not complain at all. I guess i will go back to developers and harass them bit more
Old 03-04-2013, 11:13 AM   #4
LQ Newbie
Registered: Oct 2006
Location: UK
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 1
Thumbs up [resolved]

Happy to confirm that setting .alsoftrc in ~/



as I got to ALSA, works perfectly.

Problem solved.

To be fair i have not fixed it myself, but developer pointed me to bug in openal-soft:

I guess this resolves my problem.
1 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steam on Slackware schmatzler Slackware 291 12-27-2014 11:57 AM
No Sound on Slackware 13.1 64Bit Mobile1 Linux - Laptop and Netbook 19 03-07-2011 07:08 PM
Steam on Wine, cannot login,"Steam is having trouble connecting to the Steam servers" cantab Linux - Games 1 06-19-2010 06:32 AM
Fedora Core 4 - 64bit version installing STEAM anserq Linux - Games 1 05-03-2006 08:13 PM
Cedega 4.4.3-1 snd steam within sarge 32bit chroot on 64bit sarge linuxmandrake Linux - Games 0 12-17-2005 11:24 AM

All times are GMT -5. The time now is 09:43 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration