-   Slackware (
-   -   Steam - Titans Attack - Slackware 14 64bit - no sound (

Braqoon 02-28-2013 10:16 AM

Steam - Titans Attack - Slackware 14 64bit - no sound

Does anyone have Titans Attack running with sound on Steam ? Mine gives me an error that no sound card found (java). It looks like OpenAL 32bit compat issue but i don't have that problems with other games via Steam and i got OpenAL 32bit installed.

I can't get out of Steam any error about it in the console. Any help will be appreciated.


Alien Bob 03-02-2013 06:07 AM

I wish I could tell you what's wrong, but I do not own the Titan Attacks game, so I have no clue as to what is happening. Perhaps you should also post this question on the Steam forums.

You say this is a Java game. You could try installing my minecraft package, which is also a Java game, which needs OpenAL for sound. If sound is broken there as well, you know that it is not Steam or the Titan Attacks game.

Contact me in private (my "" email address or by posting to if you have issues with getting Minecraft going because I think that is off-topic for this thread.

Cheers, Eric

Braqoon 03-03-2013 10:30 AM

Thanks Alien Bob for advice.

I checked demo version of Titan Attacks from developers website. They provide package with 32 & 64 bit environments. Forcing to run it in 32 bit, games does have a sound and do not complain at all. I guess i will go back to developers and harass them bit more :)

Braqoon 03-04-2013 11:13 AM

Happy to confirm that setting .alsoftrc in ~/



as I got to ALSA, works perfectly.

Problem solved.

To be fair i have not fixed it myself, but developer pointed me to bug in openal-soft:

I guess this resolves my problem.

All times are GMT -5. The time now is 11:40 AM.