LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-08-2012, 07:33 AM   #106
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805

Quote:
Originally Posted by mlpa View Post
I am having a similar error. Did you solve this?
Quote:
Failed to call method: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
Start the Network Manager:
Code:
chmod +x /etc/rc.d/rc.networkmanager
/etc/rc.d/rc.networkmanager start
as root.
 
Old 12-08-2012, 08:17 AM   #107
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 467

Rep: Reputation: 33
Quote:
Originally Posted by mlpa View Post
I updated to the latest AMD drivers (beta) and it is working.
TF2 is downloading.

There only one little complaint, the horrible AMD watermark
Found a fix for the ugly AMD beta drivers watermark, the script is this link.
For Slackware64 just change the line
Code:
DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
with
Code:
DRIVER=/usr/lib64/xorg/modules/drivers/fglrx_drv.so

Last edited by mlpa; 12-08-2012 at 06:40 PM. Reason: code tags
 
Old 12-08-2012, 08:22 AM   #108
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
Quote:
Originally Posted by mlpa View Post
Found a fix for the ugly AMD beta drivers watermark, the script is this link.
For Slackware64 just change the line

with
I usually have a copy of the file /etc/ati/signature from a release version of the driver. When I install a beta version I just copy it back to that place and the watermark is gone. Now ask yourself why AMD is thinking that it is a good idea to annoy the people that volunteer to test their software with an on-screen watermark.
 
Old 12-08-2012, 12:51 PM   #109
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 467

Rep: Reputation: 33
Code:
ExecSteamURL: "steam://open/driverhelperready"
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Generating new string page texture 103: 16x256, total string texture memory is 950.27 KB
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Game update: AppID 520 "Team Fortress 2 Beta", ProcID 4990, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
SDL video target is 'x11'
SDL video target is 'x11'
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system DOES NOT support the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system supports the OpenGL extension GL_EXT_draw_buffers2.
This system supports the OpenGL extension GL_EXT_bindable_uniform.
This system DOES NOT support the OpenGL extension GL_APPLE_flush_buffer_range.
This system supports the OpenGL extension GL_ARB_map_buffer_range.
This system supports the OpenGL extension GL_ARB_vertex_buffer_object.
This system supports the OpenGL extension GL_ARB_occlusion_query.
This system DOES NOT support the OpenGL extension GL_APPLE_texture_range.
This system DOES NOT support the OpenGL extension GL_APPLE_client_storage.
This system DOES NOT support the OpenGL extension GL_ARB_uniform_buffer.
This system supports the OpenGL extension GL_ARB_vertex_array_bgra.
This system supports the OpenGL extension GL_EXT_vertex_array_bgra.
This system supports the OpenGL extension GL_ARB_framebuffer_object.
This system DOES NOT support the OpenGL extension GL_GREMEDY_string_marker.
This system DOES NOT support the OpenGL extension GL_ARB_debug_output.
This system supports the OpenGL extension GL_EXT_direct_state_access.
This system DOES NOT support the OpenGL extension GL_NV_bindless_texture.
This system supports the OpenGL extension GL_AMD_pinned_memory.
This system DOES NOT support the OpenGL extension GL_EXT_framebuffer_multisample_blit_scaled.
This system supports the OpenGL extension GL_EXT_texture_sRGB_decode.
This system DOES NOT support the OpenGL extension GL_NVX_gpu_memory_info.
This system supports the OpenGL extension GL_ATI_meminfo.
This system supports the OpenGL extension GL_EXT_texture_compression_s3tc.
This system DOES NOT support the OpenGL extension GLX_EXT_swap_control_tear.
GL_NV_bindless_texture: DISABLED
GL_AMD_pinned_memory: DISABLED
GL_EXT_texture_sRGB_decode: AVAILABLE
Installing breakpad exception handler for appid(gameoverlayui)/version(20121207153333_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
[1208/184732:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Using breakpad crash handler
Setting breakpad minidump AppID = 520
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Installing breakpad exception handler for appid(520)/version(5140_client)
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198064006530 [API loaded yes]
Steam_SetMinidumpSteamID:  Setting Steam ID:  76561198064006530
ConVarRef m_rawinput doesn't point to an existing ConVar
GL_NVX_gpu_memory_info: UNAVAILABLE
GL_ATI_meminfo: AVAILABLE
GL_ATI_meminfo: GL_TEXTURE_FREE_MEMORY_ATI: Total Free: 927887, Largest Avail: 732704, Total Aux: 1663120, Largest Aux Avail: 3236
GL_MAX_SAMPLES_EXT: 8
[1208/184734:ERROR:resource_bundle.cc(411)] Failed to load /home/mantunes/.local/share/Steam/SteamApps/mariolpantunes/Team Fortress 2 Beta/cef_gtk.pak
Some features may not be available.
[1208/184734:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
CShaderDeviceMgrBase::GetRecommendedConfigurationInfo: CPU speed: 1600 MHz, Processor: GenuineIntel
GlobalMemoryStatus: 4064280576
CShaderDeviceMgrBase::GetRecommendedConfigurationInfo: CPU speed: 1600 MHz, Processor: GenuineIntel
GlobalMemoryStatus: 4064280576
IDirect3DDevice9::Create: BackBufWidth: 1366, BackBufHeight: 768, D3DFMT: 3, BackBufCount: 1, MultisampleType: 0, MultisampleQuality: 0
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
Loaded program cache file "glbaseshaders.cfg", total keyvalues: 266, total successfully linked: 266
Could not load program cache file glshaders.cfg
Could not find user GL shader cache file
Precache: Took 20847 ms, Vertex 864, Pixel 1367
Game.so loaded for "Team Fortress"
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20121208184828_1.dmp
success = yes
response:  CrashID=bp-ce94564f-eca8-4560-9871-e93a72121208
/home/mantunes/.local/share/Steam/SteamApps/mariolpantunes/Team Fortress 2 Beta/hl2.sh: line 72:  4996 Segmentation fault      ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 520 "Team Fortress 2 Beta", ProcID 4996 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
This is the output of my steam when I try to run TF2 Beta.
It breaks at the loading screen.

I start steam with
Code:
#!/bin/bash

export SDL_AUDIODRIVER=alsa
export LD_LIBRARY_PATH="/home/mantunes/.local/share/Steam/SteamApps/mariolpantunes/Team Fortress 2 Beta/bin:/usr/lib/seamonkey:$LD_LIBRARY_PATH"
exec steam steam://store
as recommend in a previous post.

Any ideas?

Last edited by mlpa; 12-08-2012 at 06:39 PM. Reason: code tags
 
Old 12-08-2012, 01:04 PM   #110
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
Please use code-tags, not quote tags.
Anyways, which video-driver are you using?
Also, I did not have to extent the library-path like that, it worked out of the box, so try with removing the TF2 path from the export.
 
Old 12-08-2012, 01:52 PM   #111
NyteOwl
Member
 
Registered: Aug 2008
Location: Nova Scotia, Canada
Distribution: Slackware, OpenBSD, others periodically
Posts: 512

Rep: Reputation: 138Reputation: 138
Sadly Steam has also abandoned anyone with a marginal connection, regardless of their investment in games that use Valve's systems.
 
Old 12-08-2012, 06:38 PM   #112
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 467

Rep: Reputation: 33
Quote:
Originally Posted by TobiSGD View Post
Please use code-tags, not quote tags.
Anyways, which video-driver are you using?
Also, I did not have to extent the library-path like that, it worked out of the box, so try with removing the TF2 path from the export.
First sorry for the quote tags.
Second, I manage to play TF2.
It didn't load with may usb mouse connected.
 
Old 12-08-2012, 06:40 PM   #113
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 467

Rep: Reputation: 33
Quote:
Originally Posted by NyteOwl View Post
Sadly Steam has also abandoned anyone with a marginal connection, regardless of their investment in games that use Valve's systems.
I did not understand you point ?
 
Old 12-09-2012, 12:42 PM   #114
NyteOwl
Member
 
Registered: Aug 2008
Location: Nova Scotia, Canada
Distribution: Slackware, OpenBSD, others periodically
Posts: 512

Rep: Reputation: 138Reputation: 138
Basically just another annoyance (albeit a potentially expensive one). When Steam "updated" their client/server about a year ago their changes made the system far more sensitive to network speed and many with less than ideal connection quality or significant high speed connections were left out in the cold because they could no longer connect to Steam's servers. This means they could no longer play games they had already purchased, and new ones purchased retail could not be installed. Steam however takes no responsibility in this issue whatsoever, despite the fact that these folks had no problems prior to the Valve "update".
 
Old 12-09-2012, 01:05 PM   #115
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 691

Rep: Reputation: 276Reputation: 276Reputation: 276
You never purchased any Steam game. Steam is a subscription-based online service, you have acknowledged an "Subscriber Agreement".
 
Old 12-09-2012, 03:56 PM   #116
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 249

Rep: Reputation: 32
I did not have to add that separate LD_LIBRARY_PATH entry to get TF2 to run. I just have:
export LD_LIBRARY_PATH="/usr/lib/seamonkey:$LD_LIBRARY_PATH"

Works fine for me. I am, however, using an NVIDIA card with the latest binary driver. Maybe something ATi specific?

I checked the Steam Linux beta forums and some people who have encountered a crash there have fixed it by launching the game with the "-nojoy" (without the quotes) parameter. Right click on the the game in your Library, choose "Properties," then click on the "Set Launch Options..." button. Type -nojoy in there.

In another thread, someone suggested updating to the Catalyst 12.11 beta 11 drivers. The start-up problems looked very similar to yours. Might be worth a shot.

Last edited by marnold; 12-09-2012 at 03:59 PM.
 
Old 12-09-2012, 03:59 PM   #117
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
Quote:
Originally Posted by marnold View Post
I did not have to add that separate LD_LIBRARY_PATH entry to get TF2 to run. I just have:
export LD_LIBRARY_PATH="/usr/lib/seamonkey:$LD_LIBRARY_PATH"

Works fine for me. I am, however, using an NVIDIA card with the latest binary driver. Maybe something ATi specific?
Nope, works fine here on a HD6870 with Catalyst 12.11 beta.
 
Old 12-09-2012, 06:37 PM   #118
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 498

Rep: Reputation: 136Reputation: 136
For those with segmenation faults, I get them unless I
  • put the correct TF2 export path in LD_LIBRARY_PATH
  • run Steam via "SDL_AUDIODRIVER=alsa steam steam://store"
Also I only have pulseaudio-compat32 and not the full pulseaudio-compat32 x86_64 package installed. No doubt some of this would be easier if just ran pure 32-bit!

Also, for Nvidia GPUs, I highly recommend the proprietary 310.xx series. This is the version Nvidia s tweaking for the Source engine.
 
Old 12-10-2012, 02:57 AM   #119
414N
Member
 
Registered: Sep 2011
Location: Italy
Distribution: Slackware
Posts: 607

Rep: Reputation: 179Reputation: 179
Quote:
Originally Posted by kingbeowulf View Post
For those with segmenation faults, I get them unless I
  • put the correct TF2 export path in LD_LIBRARY_PATH
  • run Steam via "SDL_AUDIODRIVER=alsa steam steam://store"
Also I only have pulseaudio-compat32 and not the full pulseaudio-compat32 x86_64 package installed. No doubt some of this would be easier if just ran pure 32-bit!
Thanks for the hints, but they don't work in my setup.
I cannot even get to the login screen, so the TF2 path is still non-existent on my system
About pulseaudio: if you install only the compat32 package then you won't have the daemon running at startup and steam will complain about not having access to the Mic control, but it doesn't seem like a critical error which causes the SEGFAULT.
I've put here a log created with
Code:
LD_DEBUG=libs steam
There are some errors (starting at line 1988) regarding GTK and some OpenGL4 calls (I'm using mesa, so they will fail miserably...) but apart these errors I can't see nothing of significance.
I hope that the SEGFAULT isn't caused by the lack of an OpenGL4 implementation on my system, because that would be a kinda ridiculous requirement...
 
Old 12-11-2012, 09:14 AM   #120
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 114

Original Poster
Rep: Reputation: 40
I have the same problem line 414N.

I installed all compat-32 packages from AlienBob and packaged the latest .deb from the steam website (1.0.0.16).

After that I compiled pulseaudio for 64bit and started it with the rc.pulseaudio.

No pulseaudio errors anymore in terminal, but steam is always crashing with

Code:
steam.sh: line 287:  3617 Segmentation fault  $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Steam Linux Beta Build Surfaces In Steamís Database LXer Syndicated Linux News 0 09-06-2012 04:00 PM
Steam jrduffis Ubuntu 6 08-08-2012 07:01 PM
Steam on Wine, cannot login,"Steam is having trouble connecting to the Steam servers" cantab Linux - Games 1 06-19-2010 06:32 AM
Steam. meisbob Linux - Games 8 08-19-2006 08:28 PM
Slackware 10 and WineX/Cedega + Steam php Linux - Games 4 07-24-2004 05:23 PM


All times are GMT -5. The time now is 01:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration