LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-15-2019, 06:44 PM   #1
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 749
Blog Entries: 3

Rep: Reputation: 234Reputation: 234Reputation: 234
Steam client on -current "glXChooseVisual Failed"


Just upgraded to the latest kernel, and nvidia 430.14.

Everything works fine, except for the steam client; results in this error (see attached image).

I have tried to reinstall the drivers:

Code:
# nvidia-uninstall
# slackpkg reinstall mesa
# ./NVIDIA-Linux-x86_64-430.14.run
But no success. Has anyone had this issue? I am about to downgrade my nvidia driver, but wondering what is actually causing this problem.
Attached Thumbnails
Click image for larger version

Name:	2019-05-16-003845_1920x1080_scrot.jpg
Views:	43
Size:	157.4 KB
ID:	30570  
 
Old 05-15-2019, 06:52 PM   #2
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 749

Original Poster
Blog Entries: 3

Rep: Reputation: 234Reputation: 234Reputation: 234
I've just tried downgrading nvidia drivers to both 430.09 and even 418.74; but i get the same issue.

Here's the log in the screenshot:

Code:
Running Steam on slackware 14.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1557957375)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Installing breakpad exception handler for appid(steam)/version(1557957375)
Installing breakpad exception handler for appid(steam)/version(1557957375)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Installing breakpad exception handler for appid(steam)/version(1557957375)
STEAM_RUNTIME_HEAVY: ./steam-runtime-heavy
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[2019-05-16 00:51:02] Startup - updater built May 15 2019 21:16:47
[2019-05-16 00:51:02] Opted in to client beta 'publicbeta' via beta file
You are in the 'publicbeta' client beta.
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2019-05-16 00:51:02] Checking for update on startup
[2019-05-16 00:51:02] Checking for available updates...
[2019-05-16 00:51:02] Downloading manifest: client-download.steampowered.com/client/steam_client_publicbeta_ubuntu12
[2019-05-16 00:51:02] Download skipped by HTTP 304 Not Modified
[2019-05-16 00:51:02] Nothing to do
[2019-05-16 00:51:02] Verifying installation...
[2019-05-16 00:51:02] Performing checksum verification of executable files
[2019-05-16 00:51:03] Verification complete
glXChooseVisual failed
glXChooseVisual failedMain.cpp (332) : Assertion Failed: Fatal Error: glXChooseVisual failed
Main.cpp (332) : Assertion Failed: Fatal Error: glXChooseVisual failed
Installing breakpad exception handler for appid(steam)/version(1557957375)
assert_20190516005103_6.dmp[60582]: Uploading dump (out-of-process)
/tmp/dumps/assert_20190516005103_6.dmp
[0516/005104.173836:INFO:crash_reporting.cc(242)] Crash reporting enabled for process: browser
[0516/005104.196523:WARNING:crash_reporting.cc(281)] Failed to set crash key: UserID with value: 0
[0516/005104.196593:WARNING:crash_reporting.cc(281)] Failed to set crash key: BuildID with value: 1557952663
[0516/005104.196601:WARNING:crash_reporting.cc(281)] Failed to set crash key: SteamUniverse with value: Public
[0516/005104.196610:WARNING:crash_reporting.cc(281)] Failed to set crash key: Vendor with value: Valve
assert_20190516005103_6.dmp[60582]: Finished uploading minidump (out-of-process): success = yes
assert_20190516005103_6.dmp[60582]: response: CrashID=bp-29894968-0a35-481b-afcd-aa2932190515
assert_20190516005103_6.dmp[60582]: file ''/tmp/dumps/assert_20190516005103_6.dmp'', upload yes: ''CrashID=bp-29894968-0a35-481b-afcd-aa2932190515''
I noticed the output mentions; several times:
Code:
libGL error: failed to load driver: swrast
Although, i am indeed running the nvidia driver;

Code:
$ lsmod | grep nvidia
nvidia_drm             49152  3
nvidia_modeset       1097728  5 nvidia_drm
nvidia              17936384  183 nvidia_modeset
drm_kms_helper        196608  1 nvidia_drm
drm                   475136  6 drm_kms_helper,nvidia_drm
ipmi_msghandler        61440  2 ipmi_devintf,nvidia
i2c_core               77824  4 drm_kms_helper,nvidia,i2c_piix4,drm
glxgears reports nothing wrong either with -info;

Code:
GL_RENDERER   = GeForce GTX 1060 3GB/PCIe/SSE2
GL_VERSION    = 4.6.0 NVIDIA 418.74
GL_VENDOR     = NVIDIA Corporation

Last edited by coralfang; 05-15-2019 at 06:56 PM.
 
Old 05-15-2019, 07:21 PM   #3
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 749

Original Poster
Blog Entries: 3

Rep: Reputation: 234Reputation: 234Reputation: 234
Alright... rolling back to nvidia 418.56 -- allows steam to work. So i guess there must be some incompatibility with later nvidia drivers on slackware -current as for now.
 
Old 05-16-2019, 05:09 AM   #4
Labinnah
Member
 
Registered: May 2014
Location: Łódź, Poland
Distribution: Slackware-current
Posts: 54

Rep: Reputation: 14
Quote:
Originally Posted by coralfang View Post
I am about to downgrade my nvidia driver, but wondering what is actually causing this problem.
Code:
Sat May 11 00:24:01 UTC 2019
...
x/libglvnd-1.1.1-i586-1.txz: Added.
       This is the GL Vendor-Neutral Dispatch library, which allows multiple
       drivers from different vendors to coexist on the same machine. When
       libglvnd is present, the NVIDIA driver will not overwrite any system
       files. Note that this is known to work when installing the NVIDIA driver
       using the .run installer. Other methods may require adjustment.
       This library is now a dependency of Mesa.
       Thanks to Heinz Wiesinger.
Probably this thing. There are already thread about problems with this library.
 
Old 05-16-2019, 11:30 AM   #5
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 749

Original Poster
Blog Entries: 3

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally Posted by Labinnah View Post
Code:
Sat May 11 00:24:01 UTC 2019
...
x/libglvnd-1.1.1-i586-1.txz: Added.
       This is the GL Vendor-Neutral Dispatch library, which allows multiple
       drivers from different vendors to coexist on the same machine. When
       libglvnd is present, the NVIDIA driver will not overwrite any system
       files. Note that this is known to work when installing the NVIDIA driver
       using the .run installer. Other methods may require adjustment.
       This library is now a dependency of Mesa.
       Thanks to Heinz Wiesinger.
Probably this thing. There are already thread about problems with this library.
Yes i think that is why now that you mention it.

When i reverted to 418.56, a dialog box on the installer mentioned about asking to overwrite something related to libglvnd, i chose yes and the driver worked. However i don't seem to get that prompt with later versions of the nvidia driver. I'll try read up some threads involving libglvnd, thanks.
 
Old 05-16-2019, 11:38 AM   #6
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 749

Original Poster
Blog Entries: 3

Rep: Reputation: 234Reputation: 234Reputation: 234
It just occurred to me, that the steam client is still a 32bit program. Obviously requiring a compat32 package of libglvnd.

Went ahead and installed libglvnd-compat32-1.1.1-x86_64-1compat3

Now works fine with nvidia 430.14.

Obviously that was causing the problem with 32bit compatibility.

Solved. The solution is to install that package.
 
3 members found this post helpful.
Old 05-23-2019, 05:37 PM   #7
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 728
Blog Entries: 1

Rep: Reputation: 474Reputation: 474Reputation: 474Reputation: 474Reputation: 474
I found a similar solution, although I took a slightly different route; I updated the multilib packages supplied by AlienBOB, and as part of that update, the above-mentioned package was installed. I presume that updating the multilib packages was what did the trick. I got DOOM running again, and that's all that matters.
 
1 members found this post helpful.
Old 05-23-2019, 05:52 PM   #8
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 2,216

Rep: Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236Reputation: 2236
Just an anecdote you may find helpful or at least allay some worries but I'm running kernel 5.0.3 and nVidia 418.74 with no problems in 14.2 Multilib mildly upgraded to allow ALSA-only operation. Steam with the Proton Beta and Wine-Staging w/ Vulkan libraries both run just fine.
 
Old 05-27-2019, 09:19 AM   #9
Fat_Elvis
Member
 
Registered: Oct 2016
Distribution: FreeDOS 1.2
Posts: 252

Rep: Reputation: 70
Quote:
Originally Posted by coralfang View Post
It just occurred to me, that the steam client is still a 32bit program. Obviously requiring a compat32 package of libglvnd.

Went ahead and installed libglvnd-compat32-1.1.1-x86_64-1compat3

Now works fine with nvidia 430.14.

Obviously that was causing the problem with 32bit compatibility.

Solved. The solution is to install that package.
Hah! From my piecemeal understanding, your launcher was trying to load the software OpenGL driver, and failed.

Actually - and surprisingly - on a modern, high-ish clocked CPU, it isn't as slow as you'd expect. But, yeah, it's not ideal.

EDIT:
Also, what's up with the unbelievable attachment of the Windows crowd to 32-bit binaries? As far as I know, Windows only runs on i386 or amd64 processors. Can you even buy a 32-bit x86 off the floor at a store today?

Last edited by Fat_Elvis; 05-27-2019 at 09:24 AM.
 
  


Reply

Tags
current, glxchoosevisual, steam


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[fc-30] primusrun steam -> glxchoosevisual failed schneidz Linux - Games 1 05-08-2019 11:01 PM
LXer: New Steam Beta Client Updates ALSA, Adds Multiple Steam Controller Improvements LXer Syndicated Linux News 0 02-24-2016 11:18 PM
LXer: Steam Controller Responsiveness Further Improved with New Steam Beta Client Update LXer Syndicated Linux News 0 12-21-2015 07:42 PM
[SOLVED] Slackware 14.1 64 Steam launch error "Failed to extract /usr/lib/steam/bootstraplinux rockinroyle Slackware 4 11-30-2014 09:07 PM
Steam on Wine, cannot login,"Steam is having trouble connecting to the Steam servers" cantab Linux - Games 1 06-19-2010 06:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration