LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-14-2013, 03:30 PM   #1
scorpion77
Member
 
Registered: Sep 2003
Distribution: Slackware64 14.1
Posts: 63

Rep: Reputation: 15
Steam client not working


Hi,

since I installed Slackware64 14.1 Steam does not work anymore. Obviously with Slackware64 14.0 all worked perfectly. I also installed AlienBOB multilib packages, as I did with previous Slackware release. Particularly I installed the following packages with upgradepkg --reinstall --install-new:
Code:
gcc-4.8.2_multilib-x86_64-1alien.txz*
gcc-g++-4.8.2_multilib-x86_64-1alien.txz*
gcc-gfortran-4.8.2_multilib-x86_64-1alien.txz*
gcc-gnat-4.8.2_multilib-x86_64-1alien.txz*
gcc-go-4.8.2_multilib-x86_64-1alien.txz*
gcc-java-4.8.2_multilib-x86_64-1alien.txz*
gcc-objc-4.8.2_multilib-x86_64-1alien.txz*
glibc-2.17_multilib-x86_64-7alien.txz*
glibc-i18n-2.17_multilib-x86_64-7alien.txz*
glibc-profile-2.17_multilib-x86_64-7alien.txz*
glibc-solibs-2.17_multilib-x86_64-7alien.txz*
glibc-zoneinfo-2013d_multilib-noarch-7alien.txz*
Remaining packages I installed with installkpkg:

Code:
aaa_elflibs-compat32-14.1-x86_64-3compat32.txz*
alsa-lib-compat32-1.0.27.2-x86_64-1compat32.txz*
alsa-oss-compat32-1.0.25-x86_64-1compat32.txz*
atk-compat32-2.8.0-x86_64-1compat32.txz*
attr-compat32-2.4.46-x86_64-1compat32.txz*
audiofile-compat32-0.3.6-x86_64-1compat32.txz*
bzip2-compat32-1.0.6-x86_64-1compat32.txz*
cairo-compat32-1.12.14-x86_64-1compat32.txz*
cups-compat32-1.5.4-x86_64-3compat32.txz*
curl-compat32-7.31.0-x86_64-1compat32.txz*
cxxlibs-compat32-6.0.18-x86_64-1compat32.txz*
cyrus-sasl-compat32-2.1.23-x86_64-5compat32.txz*
dbus-compat32-1.6.12-x86_64-1compat32.txz*
dbus-glib-compat32-0.100.2-x86_64-1compat32.txz*
e2fsprogs-compat32-1.42.8-x86_64-2compat32.txz*
esound-compat32-0.2.41-x86_64-2compat32.txz*
expat-compat32-2.1.0-x86_64-1compat32.txz*
flac-compat32-1.2.1-x86_64-3compat32.txz*
fontconfig-compat32-2.10.93-x86_64-1compat32.txz*
freetype-compat32-2.5.0.1-x86_64-1compat32.txz*
fribidi-compat32-0.19.2-x86_64-3compat32.txz*
gamin-compat32-0.1.10-x86_64-5compat32.txz*
gdk-pixbuf2-compat32-2.28.2-x86_64-1compat32.txz*
giflib-compat32-4.1.6-x86_64-1compat32.txz*
glew-compat32-1.9.0-x86_64-1compat32.txz*
glib2-compat32-2.36.4-x86_64-1compat32.txz*
glu-compat32-9.0.0-x86_64-1compat32.txz*
gmp-compat32-5.1.3-x86_64-1compat32.txz*
gnutls-compat32-3.1.16-x86_64-1compat32.txz*
gst-plugins-base-compat32-0.10.36-x86_64-2compat32.txz*
gst-plugins-good-compat32-0.10.31-x86_64-5compat32.txz*
gstreamer-compat32-0.10.36-x86_64-2compat32.txz*
gtk+2-compat32-2.24.20-x86_64-1compat32.txz*                                                                                                                                                                                                 
harfbuzz-compat32-0.9.16-x86_64-1compat32.txz*                                                                                                                                                                                               
icu4c-compat32-51.2-x86_64-1compat32.txz*                                                                                                                                                                                                    
jasper-compat32-1.900.1-x86_64-3compat32.txz*                                                                                                                                                                                                
lcms2-compat32-2.4-x86_64-1compat32.txz*                                                                                                                                                                                                     
lcms-compat32-1.19-x86_64-2compat32.txz*                                                                                                                                                                                                     
lesstif-compat32-0.95.2-x86_64-1compat32.txz*                                                                                                                                                                                                
libart_lgpl-compat32-2.3.21-x86_64-1compat32.txz*                                                                                                                                                                                            
libdmx-compat32-1.1.3-x86_64-1compat32.txz*                                                                                                                                                                                                  
libdrm-compat32-2.4.46-x86_64-1compat32.txz*                                                                                                                                                                                                 
libelf-compat32-0.8.13-x86_64-2compat32.txz*                                                                                                                                                                                                 
libexif-compat32-0.6.21-x86_64-1compat32.txz*                                                                                                                                                                                                
libffi-compat32-3.0.13-x86_64-2compat32.txz*                                                                                                                                                                                                 
libfontenc-compat32-1.1.2-x86_64-1compat32.txz*                                                                                                                                                                                              
libFS-compat32-1.0.5-x86_64-1compat32.txz*                                                                                                                                                                                                   
libgcrypt-compat32-1.5.3-x86_64-1compat32.txz*                                                                                                                                                                                               
libglade-compat32-2.6.4-x86_64-4compat32.txz*                                                                                                                                                                                                
libgpg-error-compat32-1.11-x86_64-1compat32.txz*                                                                                                                                                                                             
libgphoto2-compat32-2.5.2-x86_64-1compat32.txz*                                                                                                                                                                                              
libICE-compat32-1.0.8-x86_64-1compat32.txz*                                                                                                                                                                                                  
libidn-compat32-1.25-x86_64-2compat32.txz*                                                                                                                                                                                                   
libieee1284-compat32-0.2.11-x86_64-3compat32.txz*                                                                                                                                                                                            
libjpeg-compat32-v8a-x86_64-1compat32.txz*                                                                                                                                                                                                   
libmng-compat32-1.0.10-x86_64-2compat32.txz*                                                                                                                                                                                                 
libmpc-compat32-0.8.2-x86_64-2compat32.txz*                                                                                                                                                                                                  
libogg-compat32-1.3.0-x86_64-1compat32.txz*
libpcap-compat32-1.4.0-x86_64-1compat32.txz*
libpciaccess-compat32-0.13.2-x86_64-1compat32.txz*
libpng-compat32-1.4.12-x86_64-1compat32.txz*
libsamplerate-compat32-0.1.8-x86_64-1compat32.txz*
libSM-compat32-1.2.2-x86_64-1compat32.txz*
libsndfile-compat32-1.0.25-x86_64-1compat32.txz*
libtermcap-compat32-1.2.3-x86_64-7compat32.txz*
libtiff-compat32-3.9.7-x86_64-1compat32.txz*
libtool-compat32-2.4.2-x86_64-2compat32.txz*
libusb-compat32-1.0.9-x86_64-1compat32.txz*
libvorbis-compat32-1.3.3-x86_64-1compat32.txz*
libX11-compat32-1.6.2-x86_64-1compat32.txz*
libXau-compat32-1.0.8-x86_64-1compat32.txz*
libXaw-compat32-1.0.12-x86_64-1compat32.txz*
libxcb-compat32-1.9.1-x86_64-1compat32.txz*
libXcomposite-compat32-0.4.4-x86_64-1compat32.txz*
libXcursor-compat32-1.1.14-x86_64-1compat32.txz*
libXdamage-compat32-1.1.4-x86_64-1compat32.txz*
libXdmcp-compat32-1.1.1-x86_64-1compat32.txz*
libXevie-compat32-1.0.3-x86_64-1compat32.txz*
libXext-compat32-1.3.2-x86_64-1compat32.txz*
libXfixes-compat32-5.0.1-x86_64-1compat32.txz*
libXfontcache-compat32-1.0.5-x86_64-1compat32.txz*
libXfont-compat32-1.4.6-x86_64-1compat32.txz*
libXft-compat32-2.3.1-x86_64-1compat32.txz*
libXi-compat32-1.7.2-x86_64-1compat32.txz*
libXinerama-compat32-1.1.3-x86_64-1compat32.txz*
libxml2-compat32-2.9.1-x86_64-1compat32.txz*
libXmu-compat32-1.1.2-x86_64-1compat32.txz*
libXp-compat32-1.0.2-x86_64-1compat32.txz*
libXpm-compat32-3.5.11-x86_64-1compat32.txz*
libXrandr-compat32-1.4.2-x86_64-1compat32.txz*
libXrender-compat32-0.9.8-x86_64-1compat32.txz*
libXres-compat32-1.0.7-x86_64-1compat32.txz*
libXScrnSaver-compat32-1.2.2-x86_64-1compat32.txz*
libxslt-compat32-1.1.28-x86_64-1compat32.txz*
libXt-compat32-1.1.4-x86_64-1compat32.txz*
libXtst-compat32-1.2.2-x86_64-1compat32.txz*
libXv-compat32-1.0.10-x86_64-1compat32.txz*
libXvMC-compat32-1.0.8-x86_64-1compat32.txz*
libXxf86dga-compat32-1.1.4-x86_64-1compat32.txz*
libXxf86misc-compat32-1.0.3-x86_64-1compat32.txz*
libXxf86vm-compat32-1.1.3-x86_64-1compat32.txz*
mariadb-compat32-5.5.32-x86_64-1compat32.txz*
mesa-compat32-9.1.7-x86_64-1compat32.txz*
mpg123-compat32-1.15.4-x86_64-1compat32.txz*
ncurses-compat32-5.9-x86_64-2compat32.txz*
nettle-compat32-2.7.1-x86_64-1compat32.txz*
openldap-client-compat32-2.4.31-x86_64-2compat32.txz*
openssl-compat32-1.0.1e-x86_64-1compat32.txz*
openssl-solibs-compat32-1.0.1e-x86_64-1compat32.txz*
p11-kit-compat32-0.16.4-x86_64-1compat32.txz*
pango-compat32-1.34.1-x86_64-1compat32.txz*
pixman-compat32-0.30.2-x86_64-1compat32.txz*
popt-compat32-1.16-x86_64-2compat32.txz*
qt-compat32-4.8.5-x86_64-2compat32.txz*
readline-compat32-5.2-x86_64-4compat32.txz*
sane-compat32-1.0.24-x86_64-1compat32.txz*
sdl-compat32-1.2.15-x86_64-1compat32.txz*
seamonkey-solibs-compat32-2.21-x86_64-1compat32.txz*
sqlite-compat32-3.7.17-x86_64-1compat32.txz*
startup-notification-compat32-0.12-x86_64-2compat32.txz*
svgalib-compat32-1.9.25-x86_64-2compat32.txz*
util-linux-compat32-2.21.2-x86_64-6compat32.txz*
v4l-utils-compat32-0.9.5-x86_64-1compat32.txz*
xcb-util-compat32-0.3.9-x86_64-1compat32.txz*
xsane-compat32-0.998-x86_64-3compat32.txz*
zlib-compat32-1.2.8-x86_64-1compat32.txz*
When I run steam command, I get this output:

Code:
Slackware 32-bit: Check the 'deps/<slackwareversion>' directory where you downloaded this package and install/upgrade the packages you find there.
Slackware 64-bit multilib: Install/upgrade the packages in the 'deps/<slackwareversion>/multilib' subdirectory instead.

Running Steam on slackware 14.1 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20131114184630_1.dmp
/home/andrea/.local/share/Steam/steam.sh: line 704: 27909 Segmentation fault      $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/andrea/.local/share/Steam/bootstrap.tar.xz                                                                                                                                                                        
Slackware 32-bit: Check the 'deps/<slackwareversion>' directory where you downloaded this package and install/upgrade the packages you find there.                                                                                           
Slackware 64-bit multilib: Install/upgrade the packages in the 'deps/<slackwareversion>/multilib' subdirectory instead.                                                                                                                      
                                                                                                                                                                                                                                             
Running Steam on slackware 14.1 64-bit                                                                                                                                                                                                       
STEAM_RUNTIME has been set by the user to: /home/andrea/.local/share/Steam/ubuntu12_32/steam-runtime                                                                                                                                         
Installing breakpad exception handler for appid(steam)/version(0_client)                                                                                                                                                                     
No minidump written, nothing to upload.                                                                                                                                                                                                      
/home/andrea/.local/share/Steam/steam.sh: line 704: 27992 Segmentation fault      $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"                                                                                                      
Finished uploading minidump (out-of-process): success = no                                                                                                                                                                                   
error: Couldn't connect to server
Maybe I forgot some package?

Thanks for help,

Scorpion77
 
Old 11-14-2013, 03:46 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,680

Rep: Reputation: Disabled
You installed the 'compat32' packages for Slackware 14.1 using "installpkg". What happened with all the 'compat32' packages which you had already installed for Slackware 14.0?

Also, you installed a 'compat32' version of mesa. If you are using a binary graphics driver (Nvidia, Ati) then the installation of mesa-compat32 will have overwritten at least one library required for Steam games to run. After updating multilib packages, you must re-install your proprietary graphics driver (64-bits as well as 32-bits versions).

Eric
 
2 members found this post helpful.
Old 11-15-2013, 12:28 AM   #3
scorpion77
Member
 
Registered: Sep 2003
Distribution: Slackware64 14.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
You installed the 'compat32' packages for Slackware 14.1 using "installpkg". What happened with all the 'compat32' packages which you had already installed for Slackware 14.0?

Also, you installed a 'compat32' version of mesa. If you are using a binary graphics driver (Nvidia, Ati) then the installation of mesa-compat32 will have overwritten at least one library required for Steam games to run. After updating multilib packages, you must re-install your proprietary graphics driver (64-bits as well as 32-bits versions).

Eric
Thank you very much!!!
I reinstalled Nvidia drivers and now it works!

Scorpion77
 
Old 11-16-2013, 12:11 AM   #4
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Slackware
Posts: 105

Rep: Reputation: 10
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Steam Linux Client Is Now Available To Everyone LXer Syndicated Linux News 0 12-20-2012 05:11 AM
linux gaming pc with steam client? jason41987 Linux - General 4 08-31-2012 09:57 AM
Can't install steam client Alaina Dowdy Ubuntu 3 05-01-2012 06:12 PM
Where do i get the linux steam client??? dmitree Linux - Games 1 02-16-2004 03:53 PM
Steam client Comarez Linux - Games 29 01-13-2004 08:48 AM


All times are GMT -5. The time now is 12:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration