LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-17-2019, 10:14 AM   #16
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205

This issue is back - this time in -current. There was a big update a couple of days ago and now I have a black screen like in the OP. I'm not in the beta, so I can't deselect that to fix it. I'm currently using the 5.4-rc7, I don't know if that's got anything to do with it, but I doubt it.

Last edited by Lysander666; 11-17-2019 at 10:49 AM.
 
Old 11-17-2019, 10:20 AM   #17
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
there was a recent bug in mesa that 'broke' opengl
they rushed out a point release

https://lists.freedesktop.org/archiv...er/223773.html

check version numbers against that announcement
 
1 members found this post helpful.
Old 11-17-2019, 10:53 AM   #18
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Thanks Firerat, I have the latest version though:

Code:
lysander@lysultra-vi:~$ ls /var/log/packages | grep mesa
mesa-19.2.4-x86_64-1
mesa-compat32-19.2.3-x86_64-1compat32
Hmm unless Eric needs to update his too?
 
Old 11-17-2019, 10:56 AM   #19
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
mesa-compat32-19.2.3-x86_64-1compat32

is the buggy version

Quote:
Hi list,

I'd like to announce mesa-19.2.4, which is available immediately. This is an
emergency release, to fix a critical bug found in the 19.2.3 release which
causes incomplete rendering on all mesa drivers. This release contains a single
patch to fix that bug, anyone using 19.2.3 should immediately upgrade to 19.2.4
or downgrade to 19.2.2.
it may not be the actual cause, but "incomplete rendering" certainly fits

Last edited by Firerat; 11-17-2019 at 11:02 AM.
 
Old 11-17-2019, 11:08 AM   #20
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 445

Rep: Reputation: 215Reputation: 215Reputation: 215
Huh. Working for me, here. Same versions of mesa that you do. which build of Steam are you using? (Built: Nov 14 2019, package versions 1573780595) I'm on 4.19.84, though.

ETA: is this it? https://github.com/ValveSoftware/ste...ux/issues/6631

Last edited by garpu; 11-17-2019 at 11:11 AM.
 
Old 11-18-2019, 04:35 AM   #21
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 990

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Slackware64-current, kernel 5.4.0-rc7, mesa-compat32-19.2.4-x86_64-1compat32, mesa-19.2.4-x86_64-1, Steam built Nov 14 2019, at 18:30:46, package versions 1573780595, Steam Play Proton 4.11-8

Working okay here.
 
Old 11-18-2019, 05:18 AM   #22
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Quote:
Originally Posted by garpu View Post
Huh. Working for me, here. Same versions of mesa that you do. which build of Steam are you using? (Built: Nov 14 2019, package versions 1573780595) I'm on 4.19.84, though.

ETA: is this it? https://github.com/ValveSoftware/ste...ux/issues/6631
Yes that seems to be the issue, or a very similar version of it.

Build is the same as you and chrisretusn, with the up-to-date mesas as released by Eric too.

I'm using this to launch

Code:
sh -c 'STEAM_FRAME_FORCE_CLOSE=1 STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam' %U
changing the value to 1 means it doesn't launch at all.
 
Old 11-18-2019, 05:33 AM   #23
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
Quote:
Originally Posted by Lysander666 View Post
Yes that seems to be the issue, or a very similar version of it.

Build is the same as you and chrisretusn, with the up-to-date mesas as released by Eric too.

I'm using this to launch

Code:
sh -c 'STEAM_FRAME_FORCE_CLOSE=1 STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam' %U
changing the value to 1 means it doesn't launch at all.
post #18
https://www.linuxquestions.org/quest...8/#post6058875

you list mesa-compat32-19.2.3-x86_64-1compat32
@chrisretusn lists mesa-compat32-19.2.4-x86_64-1compat32

has yours been updated now?
 
Old 11-18-2019, 05:39 AM   #24
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Quote:
Originally Posted by Firerat View Post
post #18
https://www.linuxquestions.org/quest...8/#post6058875

you list mesa-compat32-19.2.3-x86_64-1compat32
@chrisretusn lists mesa-compat32-19.2.4-x86_64-1compat32

has yours been updated now?
Yes, now updated to

Code:
lysander@lysultra-vi:~$ ls /var/log/packages | grep mesa
mesa-19.2.4-x86_64-1
mesa-compat32-19.2.4-x86_64-1compat32
lysander@lysultra-vi:~$
So I don't know what could be causing this, unless it's a setting inside Steam.
 
Old 11-18-2019, 05:49 AM   #25
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,279

Rep: Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028Reputation: 4028
Quote:
Originally Posted by Lysander666 View Post
So I don't know what could be causing this, unless it's a setting inside Steam.
You could try with a different user.
 
Old 11-18-2019, 06:27 AM   #26
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Quote:
Originally Posted by bassmadrigal View Post
You could try with a different user.
I created a different user and Steam wouldn't launch. I think it's one of those things whereby I'll just have to wait and hope that a future update fixes it.
 
Old 11-18-2019, 10:05 AM   #27
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 445

Rep: Reputation: 215Reputation: 215Reputation: 215
Maybe just coincidence, but when I opened Steam this morning, I got a 502 Bad Gateway error on the store page, but refreshed and it loaded fine. (Our internet gets weird when it rains. Yes, we've called them about it.) The steam client is essentially a glorified chrome browser. Maybe some routing between you and Steam causing issues?

ETA: I'm starting steam with whatever the default is from Alien Bob's package.
 
Old 11-30-2019, 08:28 AM   #28
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
There's been a big update to the Steam client and it now works now on 14.2 for me with Eric's compat32 packages. Current still not working though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alien Bob's USB Installer & 64-bit Slack Biggen Slackware 29 07-17-2009 11:30 PM
Alien Bob's VLC Build + Slamd64 Question Daedra Slackware 10 02-22-2009 04:40 PM
Alien Bob GCC 3.4 Package Woodsman Slackware 2 03-01-2008 03:52 PM
attn: mr. alien bob your wiki, rss info Old_Fogie Slackware 2 08-18-2006 07:17 AM
One for Alien Bob cwwilson721 Slackware 28 08-15-2006 05:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration