LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-28-2019, 05:56 AM   #1
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Steam client [Alien Bob] - black screen


I've been using Eric's Steam client for a few months now with no issue on 14.2. However, after the last couple of updates I just get a black screen. This is no major issue since I can play other games by using the Big Picture feature, but I can't access my library in the normal way.

I've Googled around and it seems this may be just an issue with Valve and their latest updates, but I'm not sure. Is anyone else having this issue and if so, do you have any idea what could rectify it?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-09-28_10-53-44.png
Views:	51
Size:	63.1 KB
ID:	31408  
 
Old 09-28-2019, 06:42 AM   #2
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 990

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
I am using Steam client with Slackware64-current. My Library shows up just fine. That said, they recently changed the format of the Library and somehow I became a Steam Client Beta participant, I do not recall opting in for that.

I have Steam Play enabled also, I did decide to do that. Currently have Proton 4.11-6 selected.
 
1 members found this post helpful.
Old 09-28-2019, 06:55 AM   #3
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Quote:
Originally Posted by chrisretusn View Post
I am using Steam client with Slackware64-current. My Library shows up just fine. That said, they recently changed the format of the Library and somehow I became a Steam Client Beta participant, I do not recall opting in for that.

I have Steam Play enabled also, I did decide to do that. Currently have Proton 4.11-6 selected.
With -current it's fine, the issue I have is in my 14.2 install.

I noticed that I too was registered for beta on my 14.2 install, so I went back to the full version of Steam. The issue has gone now, thanks Chris.
 
Old 09-28-2019, 12:38 PM   #4
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 445

Rep: Reputation: 215Reputation: 215Reputation: 215
Quote:
Originally Posted by Lysander666 View Post
With -current it's fine, the issue I have is in my 14.2 install.

I noticed that I too was registered for beta on my 14.2 install, so I went back to the full version of Steam. The issue has gone now, thanks Chris.
Nevermind. Saw chrisretusn's comment about current being fine. I am a bit curious as to why 14.2 isn't working with Steam's new library.

Last edited by garpu; 09-28-2019 at 12:45 PM. Reason: because I didn't read for content.
 
Old 09-28-2019, 05:29 PM   #5
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
Quote:
Originally Posted by Lysander666 View Post
With -current it's fine, the issue I have is in my 14.2 install.

I noticed that I too was registered for beta on my 14.2 install, so I went back to the full version of Steam. The issue has gone now, thanks Chris.
"you went back to the full version of steam."

you mean, you downgrade from the beta to the standard and it works fine.

so, can we conclude that steam client beta has some feature which is supported on current but not in 14.2

Now,, the obvious question.
Do you still have Proton ?

I believe to get proton you had to turn beta on.
 
Old 09-28-2019, 05:32 PM   #6
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
Quote:
Originally Posted by garpu View Post
Nevermind. Saw chrisretusn's comment about current being fine. I am a bit curious as to why 14.2 isn't working with Steam's new library.
the correct statement is that Steam Beta is not working on 14.2

14.2 is old even by Slackware standards
why do you assume the latest shiny thing will work with it?
 
Old 09-28-2019, 05:40 PM   #7
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 2,032

Original Poster
Blog Entries: 5

Rep: Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205Reputation: 2205
Quote:
Originally Posted by Firerat View Post
I believe to get proton you had to turn beta on.
If that were the case, it's not anymore.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-09-28_22-38-501111.png
Views:	44
Size:	132.7 KB
ID:	31413  
 
1 members found this post helpful.
Old 09-28-2019, 06:05 PM   #8
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
Quote:
Originally Posted by Lysander666 View Post
If that were the case, it's not anymore.
it was

https://itsfoss.com/steam-play/

might explain how you ended up with beta being turned on
 
1 members found this post helpful.
Old 09-28-2019, 06:52 PM   #9
OldHolborn
Member
 
Registered: Jul 2012
Distribution: Slackware
Posts: 189

Rep: Reputation: 156Reputation: 156
14.2 64bit with a 4.19 kernel and Nvidia 390.116 working here with the Beta client on normal view ( don't use Big View )

I don't have a big library, just one game, Stellaris but it's a very big game
 
Old 09-28-2019, 07:04 PM   #10
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
Quote:
Originally Posted by OldHolborn View Post
14.2 64bit with a 4.19 kernel and Nvidia 390.116 working here with the Beta client on normal view ( don't use Big View )

I don't have a big library, just one game, Stellaris but it's a very big game
do you have beta auto updates on?
 
Old 09-28-2019, 07:24 PM   #11
OldHolborn
Member
 
Registered: Jul 2012
Distribution: Slackware
Posts: 189

Rep: Reputation: 156Reputation: 156
I've just switched to Beta to test so it's only tried the 26 Sept 17:32:29 build date v20 client.

Maybe it will break in time, but for now, it works.

edit - Why do I have a Windows10 thingy there <<--- Only use the cursed POS at work!!!

Last edited by OldHolborn; 09-28-2019 at 07:27 PM.
 
Old 09-28-2019, 07:35 PM   #12
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
Quote:
Originally Posted by OldHolborn View Post
I've just switched to Beta to test so it's only tried the 26 Sept 17:32:29 build date v20 client.

Maybe it will break in time, but for now, it works.
but it is interesting that yours is fine

keeping track of everyone's spins of slackware is quite a task

what do you have that is not base lackware?
 
Old 09-28-2019, 07:53 PM   #13
OldHolborn
Member
 
Registered: Jul 2012
Distribution: Slackware
Posts: 189

Rep: Reputation: 156Reputation: 156
4.19.69 Kernel
Nvidia drivers 390.116
All the goodstuff that AlienBob does - vlc, libreoffice, handbrake, compat32 / wine and steam.
*thank you Alien Bob*

SBo's cdemu

Stuff not installed - emac or KDE

WM = fluxbox

Hope you find a clue there
 
Old 09-29-2019, 08:18 AM   #14
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 990

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Quote:
Originally Posted by garpu View Post
Nevermind. Saw chrisretusn's comment about current being fine. I am a bit curious as to why 14.2 isn't working with Steam's new library.
I suspect it has to do with upgrades to mesa and/or xorg-server as to why it works on slackware64-current vice slackware64 14.2. There have been some real improvements with mesa, a big one was addition of s3tc after it's patent expired.
 
2 members found this post helpful.
Old 09-29-2019, 08:50 AM   #15
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781Reputation: 781
@chrisretusn idea fits well

@OldHolborn's nvidia won't be using mesa


I did have a quick look for change logs
I only found a "bloggy" one which cited Library UI "improvements" around Sep 19 (ish)
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alien Bob's USB Installer & 64-bit Slack Biggen Slackware 29 07-17-2009 11:30 PM
Alien Bob's VLC Build + Slamd64 Question Daedra Slackware 10 02-22-2009 04:40 PM
Alien Bob GCC 3.4 Package Woodsman Slackware 2 03-01-2008 03:52 PM
attn: mr. alien bob your wiki, rss info Old_Fogie Slackware 2 08-18-2006 07:17 AM
One for Alien Bob cwwilson721 Slackware 28 08-15-2006 05:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration