-   Slackware (
-   -   Startx freezes system completely, mysterious white dots (

Dymitry 02-08-2007 01:11 AM

Startx freezes system completely, mysterious white dots
Around an hour ago, my computer needed a complete reboot while X was running. As soon as the computer was restarted, bizarre white dots appeared all over the screen, roughly in horizontal rows of threebooting, and remained there both during the bios menus and in the OS ( during boot, login, running both Midnight Commander and Mplayer from the command line ). Using the startx command immediately made the screen go completely blank and ctrl-alt-backspace did absolutely nothing.

I suspected a problem with the monitor at first ( though why that would happen at the exact same time as a system crash was puzzling ), but then I booted from a Kanotix Live CD ( 2006, RC4 ) and the white dots disappeared, and X worked normally. Now, what could have caused this?

As ugly and distracting as the dots are, the command line is still readable, so I could try to fix it from there if I could identify the problem. I am running Slamd64 11.0 ( well, right now I am typing from within Kanotix ) and neither the xorg.conf nor the Nvidia drivers have been changed since the day I installed the OS last December; as well, fsck reported no errors with the filesystem. The motherboard is an Asus A8N-SLI board with two 6800GT graphics cards connected; neither were ever close to overheating.

duryodhan 02-08-2007 01:22 AM

You are seeing this a lot before startx so I dont think this is a problem with X server.

Try and keep a better topic name.

try resetting your bios to the factory settings (remove CMOS Battery and insert it after 30 secs).
I think the BIOS isn't giving the monitor info correctly to the kernel. Install the 915resolution tool and show the output of "915resolution -l".

I am too lazy to give you all the links , google them all. :D

rkrishna 02-09-2007 12:02 AM


As soon as the computer was restarted, bizarre white dots appeared all over the screen,
this happens when there is a ram problem, just unplug and plug it again!!(switch the power off, completely before unplugging ram, if you have 2 rams try single first)

but then I booted from a Kanotix Live CD ( 2006, RC4 ) and the white dots disappeared, and X worked normally. Now, what could have caused this?
seems to be interesting because, live cd dont ahve any problem

what about the bios screen?
first screen, a8nsli screen,? tht doesnt make any sense. if you are not getting any prom there, then we dont expect any error for the rest of the processes. if so it is a software problem.

please copy the xorg.conf of live, that will be helpful later.

dont panic,!!
mount slack partition and do an "ls -al " to /boot of slack

Dymitry 02-09-2007 02:37 AM

It gets stranger: a few minutes after typing that message, I turned off the computer and ( some time later ) turned it back on. No dots, and X in Slamd64 started normally. However, the next time I turned the computer back on, the dots reappeared and X froze the entire computer again. I turned the computer off, reset the BIOS, and restarted; same problem. Then I ran Kanotix once again, which still runs X perfectly well and the dots disappear when it begins booting.

For clarification, the dots appear at the A8N-SLI screen, remain during Slamd64 booting/running, but disappear once Kanotix is booted.

The only xorg.conf on the live CD is a very simple one in /usr/share/xresprobe:


# bare-bones XFree86 config to start the server in probe-only mode
Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        RgbPath                "/etc/X11/rgb.txt"
Section "ServerFlags"
        Option "AllowMouseOpenFail"
Section "Module"
        Load        "bitmap"
        Load        "dbe"
        Load        "ddc"
        Load        "extmod"
        Load        "freetype"
        Load        "int10"
        Load        "record"
        Load        "type1"
        Load        "vbe"
Section "InputDevice"
        Identifier        "Generic Keyboard"
        Driver                "keyboard"
        Option                "CoreKeyboard"
        Option                "XkbRules"        "xorg"
        Option                "XkbModel"        "pc104"
        Option                "XkbLayout"        "us"
Section "InputDevice"
        Identifier        "Generic Mouse"
        Driver                "mouse"
        Option                "CorePointer"
        Option                "Device"                "/dev/input/mice"
        Option                "Protocol"                "ImPS/2"
Section "Device"
        Identifier        "Generic Device"
        Driver                "::DRIVER::"
Section "Monitor"
        Identifier        "Generic Monitor"
        Option                "DPMS"
Section "Screen"
        Identifier        "Default Screen"
        Device                "Generic Device"
        Monitor                "Generic Monitor"
        DefaultDepth        24
        SubSection "Display"
                Depth                1
                Modes                "1024x768"
        SubSection "Display"
                Depth                4
                Modes                "1024x768"
        SubSection "Display"
                Depth                8
                Modes                "1024x768"
        SubSection "Display"
                Depth                15
                Modes                "1024x768"
        SubSection "Display"
                Depth                16
                Modes                "1024x768"
        SubSection "Display"
                Depth                24
                Modes                "1024x768"
Section "ServerLayout"
        Identifier        "Default Layout"
        Screen                "Default Screen"
        InputDevice        "Generic Keyboard"
        InputDevice        "Generic Mouse"

The memory seems like the most likely problem, I will look into that next.

Edit: ls -al seems to show nothing out of the ordinary:


total 8288
drwxr-xr-x  2 root root    4096 Dec  3 01:09 .
drwxr-xr-x 19 root root    4096 Jan 16 01:44 ..
lrwxrwxrwx  1 root root      37 Dec  3 00:58 README.initrd -> /usr/doc/mkinitrd-1.0.1/README.initrd
-rw-r--r--  1 root root 1122219 Dec  3 01:08
-rw-r--r--  1 root root 1122219 Sep 30 09:48
-rw-r--r--  1 root root    512 Dec  3 01:09 boot.0800
-rw-r--r--  1 root root  52358 Dec  3 01:08 config
-rw-r--r--  1 root root  52358 Sep 30 09:48 config-generic-
-rw-r--r--  1 root root    5032 Aug  3  2006 diag1.img
-rw-------  1 root root  44032 Dec  3 01:09 map
-r--------  1 root root 3028097 Dec  3 01:08 vmlinuz
-rw-r--r--  1 root root 3028097 Sep 30 09:48 vmlinuz-generic-

rkrishna 02-09-2007 03:53 AM

hi Dymitry

the xorg.conf of live!!!, i asked u to have a copy of tht so that if you want to make changes in the future, this will be helpful.

ls -al one!!!! simply to check everything is fine. since you can boot into slamd these are not relevant


sse007 02-19-2007 04:41 PM

Have u tried start X with generic driver (vesa) instead of using nvidia driver ???

All times are GMT -5. The time now is 03:58 AM.