-   Slackware (
-   -   startx crashes computer (

artificialGekko 03-11-2005 07:55 AM

startx crashes computer
I just finished installing Slack and booted the whole thing, logged in as root and created a user-account. Now when I try to start X the screen turns black with only a few lines of distorted white pixels at the top border - nothing working anymore. I already tried switching back to textmode with ctrl+alt+number, but that doesn't work. It crashes both when I'm logged in as root or as user.


- very latest slackware, downloaded from the website just 2 days ago
- bareapci.i kernel
- fluxbox window manager


- Sony Vaio FX-401 notebook

I know this is a very basic description of the problem, but I don't have the slightest clue about what that may be or what I could do to test or check anything, I don't even know if I can start some kind of "safe mode" or anything...

bigearsbilly 03-11-2005 09:47 AM

try :
gzip /etc/X11/xorg.conf (save it in case)

xorgcfg -textmode

kriton12 03-11-2005 10:25 PM

Sounds like there is a problem with your X configuration file. You should be able to boot into text mode so I would suggest doing this:

login to tty1 (the normal text login terminal)
press Alt+F2 which will switch you to the second text terminal where you can log in again (this time as root)
check /var/log/messages noting the last entry and time as well as /var/log/Xorg.*.log

switch back to terminal 1 (Alt + F1) and type startx which produces the crash. Now you can flip back to terminal 2 and recheck the logs. This should give you an idea of what failed. Most likely it is either your video adapter or some type of input device. If you can find out what is making your system crash and give some more info we can go from there. It may be as simple as setting a new driver name. If you still can't switch back to a terminal try killing X with Ctrl+Alt+Backspace

Oh and 2 questions, did you try upgrading slack? Are you using a kernel you compiled yourself?

artificialGekko 03-12-2005 07:43 AM

I just tried configuring my xorg.conf for a while now, with the following results:

- run "xorgconfigure" but couldn't tell most of the things I needed to enter there. At this point I'd like to thank Sony for not stating things like the refresh-rates of their screens *any*where, and I googled a lot for it. ;)

- put my backup of the xorg.conf back in place after X wouldn't want to start anymore at all only giving error-messages
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

I logged in to tty1 and tty2, started X in one of them to produce the crash but could not switch back nor kill anything. Alt+F2 did not work, Ctrl+Alt+Del, Ctrl+Alt+Backspace and stuff didn't either.

I didn't upgrade Slackware but installed it completely new and for the first time.
I'm using the unmodified bareapci.i that came along with the package... (10.1)

masand 03-12-2005 07:55 AM

post ur xorg.conf file and the specs of ur system
video card and monitor etc etc


chbin 03-12-2005 08:41 AM

Um, did you ever try Xorg -configure as root? xf86config thing is obsolete now and has been for a long time.

$Xorg -configure

then copy the file in /root/ to /etc/X11/xorg.conf

then startx

chbin 03-12-2005 08:55 AM

then after that works, and you have verified that startx works. you can then edit the /etc/X11/xorg.conf to you liking, resolution, refresh, scrolling mouse, whatever.

also since you seem new, don't be running around your machine as root. It's a security and safety issue. just bad practice that a lot of people get caught up in. make an account with:

$ adduser

and only use root for system maintenance. there should never be a reason to log into X as root, never, never.

artificialGekko 03-12-2005 09:23 AM

Thanks for the advice so far, I don't plan on running around as root if unneccesary - actually that's the reason why I left Win ;)

Kay, I tried Xorg -configure, but still when I test it it comes up with a black screen (this time without the distorted pixels at the upper border of the screen I meantioned in previous posts on this thread) and won't do anything anymore, no chance to switch back to console.

However, it gives me this message after generating the file:

Xorg is not able to detect your mouse.
Edit the file and correct the Device.

I don't know the specs for the touchpad of this computer or any of it's specs at all. Sony's pretty reclusive with the information too, the technical details in the 20 page (!) "user's manual" are ridiculous and remind me of the "what you bought is a computer. fin" kind of information you get in a supermarket. I googled for hours now but basic things like the refresh rates and stuff are nowhere to be found... :confused:

Can you tell me *how* to configure that file? Embarrassingly I don't even know how to edit a file in console. I'm using "less" to display it and I'll google and take a look at all kinds of man-pages to see how I can edit files now I guess...



Section "ServerLayout"
  Identifier " Configured"
  Screen 0 "Screen0" 0 0
  InputDevice "Mouse0" "CorePointer"
  InputDevice "Keyboard0" "CoreKeyboard"
End Section

Section "Files"
  RgbPath "/usr/X11R6/lib/X11/rgb"
  ModulePath "/usr/X11R6/lib/modules"
  FontPath "/usr/X11R6/lib/X11/fonts/misc/"
  FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
  FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
  FontPath "/usr/X11R6/lib/X11/fonts/CID/"
  FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
  FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

Section "Module"
  Load "record"
  Load "extmod"
  Load "dbe"
  Load "glx"
  Load "xtrap"
  Load "freetype"
  Load "type1"

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "kbd"

Section "InputDevice"
  Identifier "Mouse0"
  Driver "mouse"
  Option "Protocol" "auto"
  Option "Device" "/dev/mouse"

Section "Monitor"
  Identifier "Monitor0"
  VendorName "Monitor Vendor"
  ModelName "Monitor Model"

Section "Device"
  ### Available Driver options are:-
  ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
  ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
  ### [arg]: arg optional
  #Option "accel" # [<bool>]
  #Option "crt_display" # [<bool>]
  #Option "composite-sync" # [<bool>]
  #Option "hw_cursor" # [<bool>]
  #Option "linear" # [<bool>]
  #Option "mmio_cache" # [<bool>]
  #Option "test_mmio_cache" # [<bool>]
  #Option "panel_display" # [<bool>]
  #Option "probe_clocks" # [<bool>]
  #Option "reference_clock" # <freq>
  #Option "shadow_fb" # [<bool>]
  #Option "sw_cursor" # [<bool>]
  Identifier "Card0"
  Driver "ati"
  VendorName "ATI"
  BoardName "Rage Mobility P/M AGP 2x"
  ChipSet "ati"
  ChipID 0x4c4d
  ChipRev 0x64
  BusID "PCI :1 :0 :0"

Section "Screen"
  Identifier "Screen0"
  Device "Card0"
  Monitor "Monitor0"
  SubSection "Display"
    Viewport 0 0
    Depth 1
  SubSection "Display"
    Viewport 0 0
    Depth 4
  SubSection "Display"
    Viewport 0 0
    Depth 8
  SubSection "Display"
    Viewport 0 0
    Depth 15
  SubSection "Display"
    Viewport 0 0
    Depth 16
SubSection "Display"
    Viewport 0 0
    Depth 24

artificialGekko 03-12-2005 09:29 AM

One more thing I just found:

The touchpad of my laptop seems to be the "ALPS GlidePoint"

The website says:

XFree86 provides support for the ALPS GlidePoint and it works. I have defined the touchpad as the "CorePointer" and my USB mouse as "SendCoreEvents". So, I can use the touchpad and the mouse at the same time.

What does this translate to concerning my xorg.conf ? :)

chbin 03-12-2005 09:47 AM

So you have a mouse and a touchpad? sorry i don't have a touchpad, so i'm not sure. However, I believe it is built as a module in slack and has to be loaded before you run Xorg -configure for X to pick it up.

All the char mods are in /lib/modules/2.4.29/kernel/drivers/char so you will have to find which one is for your touchpad and load. But first you have to find it.

$ cd /lib/modules/2.4.29/kernel/drivers/char

$ ls

$ modinfo guess | less

$ modprobe whatever_looks_good


$Xorg -configure


$ startx

chbin 03-12-2005 09:51 AM

wait a minute is the "ALPS GlidePoint" a usb device becuase then its going to be in the usb section not char.

chbin 03-12-2005 09:54 AM

anyway you will have to find out what module supports your touchpad and load it. google would be the easiest way.

artificialGekko 03-12-2005 09:54 AM

nonono, there's a touchpad because the computer is a notebook. :p

I don't have a regular mouse at all so far, though I eventually wanna use an USB logitech mouse sometime.

Do you know that that "XFree86" is? :confused:

artificialGekko 03-12-2005 10:01 AM

Oooh okay, forget about that "what is" :p
Now I just need to find it in my system... ;)

chbin 03-12-2005 10:05 AM

XFree86 is obsolete now. no one uses it anymore. Xorg started their own tree from XFree86 because people were unhappy with XFree86's progress.

google for you device and see what module covers it then load it and you shouldn't have any problems, the module for the device has to be loaded otherwise X can't see it of course.

All times are GMT -5. The time now is 12:11 AM.