Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 11-24-2005, 04:57 PM   #1
LQ Newbie
Registered: Nov 2005
Posts: 15

Rep: Reputation: 0
startx command not found

I'm new to linux. I installed slackware, after the installation i logged in root and added a new user. after adding the new user I try to logon the desktop with startx which is not working. Can someone tell me where to edit the path where startx is? I have no bootdisk / floppydisk drive.
Old 11-24-2005, 05:00 PM   #2
Registered: Dec 2003
Distribution: Desktop: Slackware 13.1 &13.37 | Server: Debian 6.0
Posts: 270

Rep: Reputation: 32
root@x31:/etc/rc.d# locate startx

Old 11-24-2005, 05:03 PM   #3
LQ Newbie
Registered: Nov 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Im getting no such file or directory
Old 11-24-2005, 05:19 PM   #4
Registered: Apr 2002
Location: earth
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927
Not much installed, huh?

Have you got "find"? "df" "du"?

Old 11-24-2005, 08:41 PM   #5
Senior Member
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,467

Rep: Reputation: Disabled
Did you try to startx as root, or did you 'su <username' and then startx?
If the 2nd, use 'su - <username'. Always put a '-' or you will lose the users path.

Alternatively logout with ctrl-d, then login with your username

Last edited by dive; 11-24-2005 at 08:42 PM.
Old 11-24-2005, 09:44 PM   #6
Registered: Aug 2005
Location: Vancouver, BC
Distribution: Ubuntu 6.06
Posts: 154

Rep: Reputation: 30
This advice from egag worked for me:

i always make a symlink to a xinitrc.<windowmanager> in my home-dir called .xinitrc

just as user you can do :

ls /etc/X11/xinit/*

you'll get a list of choices.

then , in your home dir., do :

ln -s /etc/X11/xinit/xinitrc.<yourwm> .xinitrc

( mind the dot before " xinitrc " )

and startx will give you the wm you want.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
startX 'command not found' ? phil81 Debian 20 01-05-2005 09:59 AM
Startx command is not found. What do I do? Alram Linux - Newbie 11 12-20-2004 11:25 AM
startx command not found suresheva31 Linux - General 1 10-15-2004 04:12 AM
startx command not found brian183 Debian 6 10-07-2004 07:37 PM
startx command not found desluscious Linux - Newbie 6 08-25-2003 07:57 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration