LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-18-2003, 04:46 PM   #1
kiley_rodgers
Member
 
Registered: May 2003
Location: Chicago
Distribution: Slackware 9
Posts: 34

Rep: Reputation: 15
Starting X


OK, not sure what I did, but.... I HAD Slack 9 up and running fine. On boot up, I modified the inittab to start fvwm95. Evrything worked fine for a few weeks, NOW..... when I boot up, the system stops a the "starting X" line. I can still however, open another character cell screen "alt+F7?" and login. Once logged in I can use the 'startx' cmd and everything starts up fine. I looked in the /var/adm/XF86****.log file and the last line being processed is for the mouse. I even reverted back to an old XF86Config file and the same thing happens. Not sure what I screwed up, but can't remember changing anything for the life of me that would effect this. Also, I use xf86config to create an entirely new XF86Config file with no success. Can someone point me in the right direction as to which files are looked and and in what order they are executed to start X. Again, no errors in the X log.
 
Old 06-18-2003, 04:53 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 253Reputation: 253Reputation: 253
You don't modify the inittab to specify your default window manager. Run xwmconfig to setup your default window manager. Whatever you added to your inittab file, remove it.
 
Old 06-18-2003, 08:40 PM   #3
kiley_rodgers
Member
 
Registered: May 2003
Location: Chicago
Distribution: Slackware 9
Posts: 34

Original Poster
Rep: Reputation: 15
Sorry, I think I did not explain the 'inittab edit' in my request for help. I edited my initab when I originally installed Slack to change the default run level (to automatically start X). Any other suggestion?
 
Old 06-19-2003, 02:56 AM   #4
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Rep: Reputation: 30
when using the command startx, the commands in the script
/etc/X11/xinit/xinitrc are run.
 
Old 06-19-2003, 01:35 PM   #5
Pres
Member
 
Registered: Jun 2002
Location: Australia
Distribution: Slack 9.1
Posts: 232

Rep: Reputation: 30
Quote:
Originally posted by neenee
when using the command startx, the commands in the script
/etc/X11/xinit/xinitrc are run.
This is not always true; an over-ride can be in the user's home directory ~/.xinitrc

startx is a script not a binary too, just in case you didn't know, easy to check it out and see what's happening
 
Old 06-19-2003, 05:35 PM   #6
Astro
Member
 
Registered: Jan 2003
Location: Ballston Lake, NY
Distribution: Slackware, Debian
Posts: 662

Rep: Reputation: 30
You could make a /home/user/.xinitrc file to specify the startup of your default wm for that specific user....
 
Old 06-19-2003, 06:03 PM   #7
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 765

Rep: Reputation: 55
Your inittab should point to runlevel 4:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

this then looks at /etc/rc.d/rc.4

what happens next depends on this file, but if you were to put

# Not there? OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
exec /opt/kde/bin/kdm -nodaemon
fi

as the first choice, you can then go to

/opt/kde/share/config/kdm/Xsession

and check this file, but you should find

fvwm95)
xsetroot -solid SteelBlue
exec fvwm95
;;

in there, if so, then restart, and select fvwm95 from the kdm boot menu, and all should be well.

if rc.4 is using the gnome option I cant help, but you should be able to search around until you find the relevant conf file, I would guess gdm.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
starting xprogram without starting X server. bruse Linux - Newbie 9 04-26-2005 07:05 PM
Terminal cmd for starting Matlab M-file editor without starting matlab fubzot Linux - Software 2 02-15-2005 06:49 AM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 06:39 PM
Starting apps after starting xfce?? gtgoku Slackware 2 08-21-2004 01:49 PM
starting kpppd w/ ximian or starting ximian w/ kde ergo_sum Linux - Newbie 8 12-02-2003 05:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration