LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-04-2003, 11:17 PM   #1
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Rep: Reputation: 15
ssi and cgi not working...


ok well when i try to execute a cgi file it trys to dl and my ssi isnt even working. this is my conf file

http://www.perfectflaw.net/httpd

does anyone konw the problem......i have went through 2 people with it and they cant see the problem
 
Old 03-05-2003, 07:06 AM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
I noticed that the error log is set to /var/log/apache/error_log. I would look there first to see if anything might be reported.

Check the permissions on all the directories and files.

I see where the DocumentRoot and the Directory are not the same. It might present some alias problems with the files not being found.

I see where ExecCGI was added but it has a plus mark in front. I do not know if that is proper. I just have never seen it that way before. You might want to check on it though or try removing the plus mark.

Remember, any changes to the httpd.conf file and the daemon needs to be sent a SIGHUP signal to reload it. Also, make sure Apache is loading the right conf file.

Perhaps it will help in some way.
 
Old 03-05-2003, 04:54 PM   #3
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Original Poster
Rep: Reputation: 15
how do i make suer its pointing to the right .conf file? what would i edit to see that
 
Old 03-05-2003, 05:01 PM   #4
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
The default would be the conf/httpd.conf referenced from the ServerRoot. Or use the -f and specify the filename with the location. If you would like to see more info on this you can use the man page. (man httpd)
 
Old 03-05-2003, 10:40 PM   #5
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Original Poster
Rep: Reputation: 15
ok that is the right one..... /etc/apache/httpd.conf and i moved the folder inside /var/www and it still isnt working.
 
Old 03-06-2003, 08:02 AM   #6
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
I would suggest moving it back, I don't think you would really want your conf files under the www document tree. Then try starting it with the -f flag.

httpd -f /etc/apache/httpd.conf

If httpd is running, then you have to kill it first before you try to run it again.
 
Old 03-06-2003, 04:35 PM   #7
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Original Poster
Rep: Reputation: 15
it came up and said
"syntax error on line 205 of /etc/apache/httpd.conf:
cannot load /usr/libexec/mod_vhost_alias.so into server: /usr/libexec/mod?vhost?alias.so: cannot open shared object file: no such file or directory"
 
Old 03-06-2003, 06:08 PM   #8
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
OK, well I checked my system and those files do exists in that location. Check your system and see if they are there.

If you look into the httpd.conf, they the DSO modules that are being loaded. The one you specified is the first one in the list.
 
Old 03-07-2003, 03:16 PM   #9
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Original Poster
Rep: Reputation: 15
ok well i checked mine...its on there also. I stll cant find the reason why it isnt working. I have worked on it for 4 days straight
 
Old 03-07-2003, 08:22 PM   #10
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
Did you rebuild Apache from source and install it?

The reason I ask is because if Apache was running before, then why the problem now? Unless it was using a different httpd.conf file located in another location. The Slack defaults for building Apache and the author's defaults are not the same. And your new build might not support the DSO modules, hence the error message you are receiving trying to use the Slack default conf file. You could even have two different copies installed of Apache (httpd) and the apachectl file as well. If you did rebuild and are now using the new system, then see if /usr/conf/httpd.conf exists. If it does, then review it and see if it loads any of the DSO modules. From a quick review of the apachectl script, that is called by the /etc/rc.d/rc.httpd script, the only real setting in it would be the location of the httpd executable. It does not appear to have a provision for passing any parameters to the program, like the -f flag. You could also try "whereis httpd" and "whereis apachectl" to see what locations it responds with.

If you did rebuild, and Apache is loading one conf file and you are editing another conf file, that would explain why the changes are not working as well. You might consider uninstalling the Slack built package and then reinstalling your custom built package. Then work with the conf file for the new build.

I had to do an update recently on a server and I recall runing into this problem as well with Slack 8.1 and custom built Apache. I think I just replaced the rc.httpd script with my own command to start Apache with the options that I needed. All of the server administrators are used to the conf files being in a single location from way back in time, and I needed to specify the location with the -f option.

Perhaps it will help.
 
Old 03-09-2003, 07:44 PM   #11
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Original Poster
Rep: Reputation: 15
ok....well im moving up....i know the problem. its trying to load /etc/apache/httpd.cong how to do i change it to /etc/apache/httpd.conf
 
Old 03-09-2003, 08:37 PM   #12
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
What kind of file name is that?

Does the file /etc/apache/httpd.cong actually exist? If you really want to attempt a patch; then make the filename a link to the actual httpd.conf. (ln -s)

To correct the problem, if custom build then correct problem in the source, rebuild, and reinstall. If the Slack package, then I would think reinstall the package from the install CD. If the later doesn't correct the problem, then download it again and install.

Last edited by Excalibur; 03-09-2003 at 08:44 PM.
 
Old 03-09-2003, 10:38 PM   #13
Flawless
Member
 
Registered: Feb 2003
Location: alabama
Posts: 45

Original Poster
Rep: Reputation: 15
ok i fixed the http problem and the cgi problem. But still ssi dosent work....do i need to upgrade ssi??? or what?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CGI works from SSI exec, but not from include. SkipHuffman Linux - Software 2 08-25-2005 11:15 PM
SSI stopped working after upgrade to FC3 jeffreybluml Linux - Newbie 3 06-02-2005 12:59 PM
SSI is not working... help! dbeatle123 Linux - General 20 03-23-2005 03:23 PM
Apache: SSI stopped working Nic-MDKman Linux - Software 0 02-14-2004 10:07 AM
Apache and SSI/CGI PROBLEMS morbo Linux - Networking 2 01-18-2003 05:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration