LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-17-2008, 04:47 PM   #1
dhupke
LQ Newbie
 
Registered: Jun 2007
Posts: 19

Rep: Reputation: 0
SSH access problems: Can only allow users SSH access by adding to root group


Running Slackware 11.0.

I'm trying to allow a user ssh access to their home directory, but something is configured so that only users in the root group are allowed ssh access. I've looked through the sshd_config file, and nothing sticks out to me. I've tried adding the line AllowUsers user1 user2 etc... but that has no affect on ssh access. Beyond that, I really have no idea where to look...

I've tried googling the issue but haven't been able to find any answers...

I would appreciate any help.

Thanks
 
Old 12-17-2008, 05:24 PM   #2
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
Can you post the relevant lines from your sshd_config file (meaning, no comments)? Remember to use the [code] tags to make it more readable for everyone else.

Maybe another pair of eyes will find something.
 
Old 12-18-2008, 08:52 AM   #3
dhupke
LQ Newbie
 
Registered: Jun 2007
Posts: 19

Original Poster
Rep: Reputation: 0
SSH access problem

Here are the uncommented lines from sshd_config:

[PermitRootLogin no]

[AllowUsers user1 user2 user3]

[Subsystem sftp /usr/libexec/sftp-server]


*Note: whether I had the AllowUsers line in or not, made no difference.

Thanks
 
Old 12-18-2008, 12:54 PM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by dhupke
I'm trying to allow a user ssh access to their home directory, but something is configured so that only users in the root group are allowed ssh access.
What does that mean, exactly? If a user who is not in the root group tries to ssh to the server, can he authenticate at all?
 
Old 12-19-2008, 08:33 AM   #5
dhupke
LQ Newbie
 
Registered: Jun 2007
Posts: 19

Original Poster
Rep: Reputation: 0
SSH access

If a user is not in the root group and I try to ssh in via Putty. The putty session window just closes. It doesn't give any warnings, just kills putty...

Thanks

Last edited by dhupke; 12-19-2008 at 08:37 AM.
 
Old 12-19-2008, 08:35 AM   #6
dhupke
LQ Newbie
 
Registered: Jun 2007
Posts: 19

Original Poster
Rep: Reputation: 0
SSH access

Quote:
Originally Posted by anomie View Post
What does that mean, exactly? If a user who is not in the root group tries to ssh to the server, can he authenticate at all?

If a user is not in the root group and I try to ssh in via Putty. The putty session window just closes. It doesn't give any warnings, just kills putty...

Thanks

Last edited by dhupke; 12-19-2008 at 08:37 AM.
 
Old 12-19-2008, 10:36 AM   #7
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,639

Rep: Reputation: Disabled
Try to ssh from the command line the first time. The first time that you ssh to a particular host it will ask you to confirm that you want to add the host to your list and exchange keys.

Brian
 
Old 12-19-2008, 11:00 AM   #8
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by dhupke
The putty session window just closes. It doesn't give any warnings, just kills putty...
You're going to need to check the server logs for clues then. I don't know how Slackware does it, but on a RHEL/CentOS box, in sshd_config the directive SyslogFacility AUTHPRIV is set by default. Then, in /etc/syslog.conf, authpriv.* logs to /var/log/secure.

Determine where sshd is logging to on your Slackware system and tail that log during your next login attempt.

Last edited by anomie; 12-19-2008 at 11:01 AM.
 
Old 12-19-2008, 06:55 PM   #9
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
By default ssh logins are logged to /var/log/messages -- you should be able to see quite a bit of information regarding the login attempts there.
 
Old 12-19-2008, 07:36 PM   #10
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_12{.0|.1}
Posts: 5,346
Blog Entries: 11

Rep: Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310Reputation: 3310
Fresh perspective maybe?

Pardon me if I have completely missed something, but maybe a fresh perspective, even a confused one, will help.

First, since you are using Putty I assume you are attempting to login from an M$ machine to the Slackware box. Is that correct? If so, you should first look at the logs or messages or whatever such there is on the M$ machine - it is not at all obvious that the shutdown results from something wrong on the Slackware box.

As BCarey said, can the user login from the command line, like from the same box or from another *nix box? That would be the first big clue - get Putty out of the picture and troubleshoot the basic SSH config. So if you have access to the Slackware box, what happens if you simply try to ssh as one of those normal users on the same box? That will at least give you a clean, single event type log record.
 
Old 12-21-2008, 10:48 AM   #11
rob.rice
Senior Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 1,075

Rep: Reputation: 203Reputation: 203Reputation: 203
Quote:
Originally Posted by dhupke View Post
Running Slackware 11.0.

I'm trying to allow a user ssh access to their home directory, but something is configured so that only users in the root group are allowed ssh access. I've looked through the sshd_config file, and nothing sticks out to me. I've tried adding the line AllowUsers user1 user2 etc... but that has no affect on ssh access. Beyond that, I really have no idea where to look...

I've tried googling the issue but haven't been able to find any answers...

I would appreciate any help.

Thanks
unless your running really old hardware there is no reason to be running such an old version of slackware
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh root restrictions access newbie_adm Linux - General 2 11-12-2007 11:52 AM
root access using SSH atrac Linux - Security 2 10-29-2007 11:05 PM
Unknown users are trying to access via ssh gattumarrudu Linux - Security 12 12-22-2005 08:25 AM
SSH Root Access DediPlace Linux - Security 6 05-29-2005 12:05 PM
Prevent Root access with SSH rshooper Linux - Security 4 11-18-2004 02:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration