-   Slackware (
-   -   SSD + HDD error on boot (

t35t 03-30-2012 03:21 AM

SSD + HDD error on boot
Hi all!

I am currently running Slackware64 13.37 on a SSD. I had also plugged a HDD for future use (Os is on SSD) but LILO setup generated an error because it wasn't able to write to MBR. I suppose boot code 0x80 is being used by both of these drives. When I take of HDD and tried to install to SSD that way, installed without problems, wrote LILO to MBR. System is perfectly healthy right now but when I plug the HDD as an additional storage I get the good old kernel panic VFS error unable to mount ; while booting. I know there is a workaround for this but do not want to alter the system because I might end up installing everything from scratch.

Anybody experienced such a problem ?


samac 03-30-2012 07:08 AM


Welcome to the Slackware forum.

Sounds like a cable/bios/fstab problem.

Check which sata port each drive is connected to, check your boot order in the bios and then boot from the install cd and check that /etc/fstab is mounting the drives in the correct place so that /etc/lilo.conf can find them.

You may have to re-run /sbin/lilo


t35t 03-30-2012 09:20 AM

1-made mkfs.ext4 for the malfunctioning drive
2-edited /etc/fstab and /etc/mtab
3-mounted to a directory and gave necessary permission

now it works like a charm!

thank you.

All times are GMT -5. The time now is 10:22 AM.