LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-15-2010, 03:03 PM   #1
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1 64 bits
Posts: 238

Rep: Reputation: 15
Unhappy Squid


Hello,

I went on the adventure to install squid. And I didnt even configure anything, I just uninstalled it, feeling as if I should at least know what I'm gona do to configure it. So its uninstalled. Weird thing is that now, I cant even ssh to my computer from work, nor can I access my computer with tightvnc. Everything seems blocked. Can anyone help me fix this? Local access seems ok, I can ssh to it with my other computer, but from an exterior source, nothing.

Cheers,
Dumdadum
 
Old 04-15-2010, 03:32 PM   #2
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1 64 bits
Posts: 238

Original Poster
Rep: Reputation: 15
Unhappy Reinstall

I've got only one solution for now: reinstall Slackware...

The service isnt running, its still there somehow, wasnt deleted with the uninstall, but its not running.

I also tried reinstalling squid, hoping to get to configure it. Damn this isnt a small task. If I could at least have it installed and know how to enable port 22 and 5901 I wouldnt complain. Any help would be much appreciated.

Cheers,
Dumdadum
 
Old 04-15-2010, 04:18 PM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
I've got only one solution for now: reinstall Slackware...
Hmm - that seems a bit drastic! How did you install squid - did you make or get a Slackware package and installallpkg/removepkg or install directly so other way?
 
Old 04-15-2010, 05:02 PM   #4
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1 64 bits
Posts: 238

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by bgeddy View Post
Hmm - that seems a bit drastic! How did you install squid - did you make or get a Slackware package and installallpkg/removepkg or install directly so other way?
I installed it with installpkg and removed it with removepkg. I built the package from slackbuilds.org. Why?
 
Old 04-15-2010, 05:14 PM   #5
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
Why?
Because from your description of the problem it sounded like part of the installation was left in place as can happen when installing stringht from source rather than a package.

Are there anyone changes (perhaps made by you) - like iptables rules or something. Have you made sure the /etc/rc.d/rc.squid script is gone and all the package files gone too? It just seems odd that just installing then removing the package has made such a difference.
 
Old 04-15-2010, 05:27 PM   #6
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1 64 bits
Posts: 238

Original Poster
Rep: Reputation: 15
Unhappy

Quote:
Originally Posted by bgeddy View Post
Because from your description of the problem it sounded like part of the installation was left in place as can happen when installing stringht from source rather than a package.

Are there anyone changes (perhaps made by you) - like iptables rules or something. Have you made sure the /etc/rc.d/rc.squid script is gone and all the package files gone too? It just seems odd that just installing then removing the package has made such a difference.
I did no changes to the ip tables. Unless squid did them for me. I just hit installpkg thesquidpackage, then removepkg thesquidpackage, and I cant connect anymore. It was fine until I did this. And the rc.squid file is still there, but I set the chmod -x on it and also did ./rc.squid stop and after all this rebooted inetd, sshd and vncservers, I restarted the vncservers for each user, like I usually do, I did nothing different than I usually do other than install squid. And I also rebooted my machine.

Help please, pretty pretty please, or else I'm reformatting, no choice. Ah yes and I also checked hosts.allow and hosts.deny,these were untouched.

I'm presently looking into the configuration of squid. I added these lines in the /etc/squid/squid.conf file:

acl Safe_ports port 80 # http
acl Safe_ports port 22 # ssh
acl Safe_ports port 5901 # guest-vnc-1

Then restarted squid. Still nothing.

Cheers,
Dumdadum
 
Old 04-15-2010, 05:56 PM   #7
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Try going to Shields Up and selecting "All Service Ports" to see what's open to the world. You could also try "nmap localhost" to get similar information locally.
So you have not changed any hosts.allow/deny rules, iptables rules or altered any router settings - hmm. This is strange. I ran squid for some time on my gateway machine and, as a test, have just built and installed it here to remind me of it's settings. It hasn't made any changes though although I haven't enabled the startup script yet.

Sorry I can't think of an instant fix for this - it just looks like a step by step fault finding process so far.

First - just make sure sshd is running and try ssh localhost - then check that port 22 is forwarded on your router and check the above Shields Up link. This should show port 22, at least, open.
 
Old 04-15-2010, 08:27 PM   #8
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
squid does not block anything it just sits there waiting for input on it's listen port (3128 in the default configuration). It does not do anything at all with iptables. In short installing and removing squid should not cause any problems at all. So is there anything else you have done that you forgot to mention?
 
Old 04-16-2010, 07:22 AM   #9
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1 64 bits
Posts: 238

Original Poster
Rep: Reputation: 15
Lightbulb Found it

I found my error. Its kinds sily. I use no-ip.org to post my ip. For a reason the ip that was there wasnt the right one, the problem was there. I went on the shieldup site and saw my ip and it clicked, it wasnt the same I was using. So I found the problem. And I fixed it. Used the correct ip, and it connected.

Sorry people. My bad.

Cheers,
Dumdadum
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Redirect specific domain to an Secondary (External) Squid Proxy Zxarr Linux - Server 2 04-20-2010 12:50 PM
My squid server is running slow i have 40 fedora 11 in my squid proxy ashraflinux1@gmail.com Linux - Server 4 09-15-2009 12:17 AM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard laxmantsharma Linux - Software 1 02-24-2009 06:02 AM
Squid 2.6 Reverse Proxy from Squid(3128) to OrginServer(80) Not working rraj Linux - Server 0 06-06-2008 02:29 PM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 02:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration