-   Slackware (
-   -   Sporadic boot to blank screen - Slack 14 (

ctag 07-12-2013 11:32 PM

Sporadic boot to blank screen - Slack 14

I'm excited to join the Slacking community. After several years of migrating from Windows to Ubuntu (and finding myself totally reliant on apt-get), I've decided to complete the commitment to better operating systems and delve into Slackware.

That said, I've successfully installed Slackware on an old HP laptop. Had some trouble with LILO and (an existing copy of) GRUB fighting, so I ended up nuking the drive with dd and then reinstalling. Everything went smoothly after that and I'm left with a surprisingly crisp and snappy system.

Onward, to the problem:
I chose Fluxbox as my default window manager, and it worked swell. Then I decided that I really wanted Openbox instead. So I got it from slackbuilds, compiled, and installed it. I then updated my .xinitrc file to reflect the change.
Now, I have what feels like a 50/50 chance of the laptop booting up to a login prompt. The other half of the time, it begins booting, and then right when it would normally flicker, and come back with smaller, cleaner text, it goes blank. The backlight is on, but the screen is black. Furthermore, I can still log in after waiting a reasonable amount of time and blindly entering my name and pass, then I can execute 'startx' and openbox successfully launches.

Once in openbox, I can use ctrl-alt-bkspc to close the window manager, and end up with a working shell, what I expect to get on initial boot.

I'm willing to upload any configuration files that may be pertinent, or even a video of it booting, please let me know what I should include.

All in all, it would be pretty straightforward to re-install, but I'd like to at least try fixing the problem first, otherwise I won't learn anything.

It seems weird to mention .xinitrc and then not include it, so I've copied off the computer. Here it is.


# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $


# merge in defaults and keymaps
[ -f $sysresources ] && /usr/bin/xrdb -merge $sysresources
[ -f $sysmodmap ] && /usr/bin/xmodmap $sysmodmap
[ -f $userresources ] && /usr/bin/xrdb -merge $userresources
[ -f $usermodmap ] && /usr/bin/xmodmap $usermodmap

# Create default user directory & populate it if not already existent
if [ ! -d $HOME/.config/openbox ]; then
  mkdir -p $HOME/.config/openbox
  cat /etc/xdg/openbox/menu.xml > $HOME/.config/openbox/menu.xml
  cat /etc/xdg/openbox/rc.xml > $HOME/.config/openbox/rc.xml

# Not sure what I'm doing, going to open xcompmgr
xcompmgr &

# Desktop background
feh --bg-center /home/ctag/wallpaper/space-ship.jpg

if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session openbox
  exec openbox

And .xprofile:


# xcompmgr
# xcompmgr &

Thanks for reading,

tronayne 07-13-2013 09:03 AM

This sounds like it may be a different problem (X is not running during boot). The symptoms you describe have cropped up not too long ago and were fixed in the 3.2.45 kernel.

Have you installed all the patches?

Have you installed the kernel update to version 3.2.45? Do this:

uname -a
Linux your_system_name 3.2.45 #2 SMP (and other stuff)

Does your system use Intel graphics (lspci will show you, your version may differ)?

lspci | grep -i graphic
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

If you haven't done all the patches, the easy way is to create a directory in /usr/local

su -
<root password>
mkdir -p /usr/local/patches
cd /usr/local/patches
# use this one for 32-bit
# use this one for 64-bt
<wait a while>
upgradepkg *.t?z

That will bring system software up to the current stable level (be sure to use either the 32-bit or the 64-bit line above, don't do both).

Now the kernel. The kernel should be at 3.2.45. You're still in /usr/local/patches, so

mkdir linux-3.2.45
cd linux-3.2.45
# use this for 32-bit
# use this for 64-bit
<wait a while>
upgradepkg --reinstall *.t?z

You must run lilo. Look at /etc/lilo.conf, down at the bottom it should look like this:

tail /etc/lilo.conf
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
# Linux bootable partition config ends

Yours may vary a little, perhaps the root partition, but if you installed the default system, that's pretty much what it's going to look like.

Execute lilo:

Then you can reboot -- all the above brings your system to the current stable level.

Note that when you upgrade the kernel it's going to take while (well, all the above upgrades are going to take a while truth be known) -- minutes, not hours, but maybe quite a few minutes, don't worry about that.

All the above assumes that you installed default Slackware and have not done a custom kernel (where you compiled the kernel yourself). There are other ways to get the patches and apply them but the above is easy and fast (depending on your Internet connection speed, of course) and gets you up to date quickly.

Hope this helps some.

adelabarra 07-13-2013 09:04 AM

May be it is a video prblem.
Did you check any log or message files?
There should be something there...
May be i am a little newbie but donīt understand exactly if you enter fluxbox directly from booting.



so I ended up nuking the drive
Excellent! Iīd never heard that expression before.

ctag 07-13-2013 09:26 AM


I'm not sure where to check for an error or message log. I have Slack set to boot to a terminal (it's default, I believe) from which I can log into either root or my regular account and then load openbox if I want a desktop.

;D Yeah, it's an expression I picked up from Darik's Boot and Nuke project to securely erase HDs.


I heard about patches while going through the new user install guides, but to my knowledge have not installed any of them.

Output of uname:

root@BBX-oldtop:~# uname -a
Linux BBX-oldtop 3.2.45-smp #2 SMP Fri May 31 16:57:40 CDT 2013 i686 Genuine Intel(R) CPU          T2300  @ 1.66GHz GenuineIntel GNU/Linux

It says 3.2.45, but I didn't specifically update the kernel, I believe it came with the DVD iso.

Output of lspci:

root@BBX-oldtop:~# lspci | grep -i graphic
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Looks like Intel.

Installing patches; then kernel; then update lilo. Will either update this post or reply back when finished.

The updating went much faster than expected, but I didn't see any glaring error output.

updated lilo:

root@BBX-oldtop:/usr/local/patches/linux-3.2.45# lilo
Warning: LBA32 addressing assumed
Added slax  *
One warning was issued.


Thank you!,

tronayne 07-13-2013 09:52 AM

There was a glitch in one or two copies of the 3.2.45 kernel (having to do with black screen with Intel graphics); the version at is the current, working, one and it won't hurt to do the upgradepkg --reinstall *.t?z just to make sure. The symptoms were when the switch is made during boot, the screen goes black.

It could also be a hardware problem but I'd do the software first then dig into the hardware (might be as simple as a pinched cable or loose connector, but then...).

ctag 07-13-2013 10:05 AM

Ah, good to know.

Finished updating and reloading lilo. Rebooted about six or seven times successfully, I think that squashed it.

Next on my list will be sorting out the difference between slackpkg, installpkg, and updatepkg.

Thanks again for the help,

tronayne 07-13-2013 10:19 AM

Hey, glad to know you got going.

r.vaillancourt 07-13-2013 10:38 AM

I have this same problem, except I'm using Radeon HD 6480G Graphics.
When it hits the framebuffer during boot I get the black screen or sometimes I get a bar code screen, when (if) it come back in it come in around DRM or bluetooth. I am up to date with 64-14 stable. So...
Would like to see more feedback on this subject.

ctag 07-14-2013 10:34 AM

r.vaillancourt, your post looks like it got cut off, mind editing it?


Well, I must have rebooted and shutdown the laptop about thirty times yesterday, and right before I went to bed, it booted to a blank screen again. Seems to have the same problem today :-[

I'm going to leave the thread open to suggestions, but I'll likely reformat and reinstall to see if the problem stems from me messing around or something hardware/software with Slack.

WilliamS 11-10-2013 02:00 PM

I've set my slack so that I do username, password then startx.
After doing slackpg upgrade-all, I got a black screen after doing startx.

Installed (again) a saved

it worked. Did aticonfig --initial --input/etc/X11/etc/xorg.conf
and all is well.

ctag 11-10-2013 02:04 PM

Thanks WilliamS, I'll give that workaround a shot next time I have issues like this!

All times are GMT -5. The time now is 08:15 PM.