LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-31-2016, 03:34 PM   #1
The Sego Sago Kid
Member
 
Registered: Feb 2015
Location: PA USA
Distribution: Slackware
Posts: 46

Rep: Reputation: Disabled
Sounds issues - Realtek HDA - 14.2


Hi everyone, I'm having some sound issues with 14.2 on a Panasonic Cf-C1 laptop. I can get audio out through the headphone jack with no issues, but nothing plays through the internal laptop speaker. I confirmed the speaker itself is functional in Windows 7. The Windows drivers on Panasonic's webpage for this model are for a Realtek HDA device, so I assume Slackware is loading the right module on boot. But in my dmesg, it says "speaker_outs=0". I take it that's the issue? Anything I can do to fix that?

dmesg | grep hda
Code:
bash-4.3# dmesg | grep hda
[    6.846137] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VB: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    6.846147] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.846153] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    6.846158] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    6.846162] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    6.846166] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[    6.846170] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
Here's aplay -l, in case that helps.

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Other info: alsamixer shows nothing muted. The pulseaudio mixer shows speaker and headphones as audio devices, and nothing is muted there, either.

Thanks!
 
Old 01-01-2017, 10:20 AM   #2
bbuske
Member
 
Registered: Dec 2016
Location: Caracas, DC, Venezuela
Distribution: openSUSE Leap 42.2
Posts: 109

Rep: Reputation: 15
Hello,

please check this thread

http://askubuntu.com/questions/51113...eadphones-fine

and also this one:

http://askubuntu.com/questions/46438...to-windows-8-1

for more information.

It looks like the sound card is similar to yours and is also a dual boot machine. The issue was resolved, by disabling fast boot in Windows and then turning the machine off completely (a simple restart is apparently not enough.

Hope this helps, please let me know how it goes.

Happy new Year!
 
Old 01-01-2017, 12:51 PM   #3
The Sego Sago Kid
Member
 
Registered: Feb 2015
Location: PA USA
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: Disabled
I'm not really dual-booting. After I discovered my sound didn't work after my fresh Slackware install, I switched out the hdd with another and did a test W7 install to rule out hardware failure. Also, fast boot is disabled in my BIOS. Thanks for the suggestion, though.
 
Old 01-01-2017, 01:28 PM   #4
The Sego Sago Kid
Member
 
Registered: Feb 2015
Location: PA USA
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: Disabled
Sooo.. I ran:

Code:
alsactl init
and the speakers kicked on. Yay!

But shouldn't that be a thing that happens automatically? I never had to run that manually for any other hardware.
 
Old 01-02-2017, 08:58 AM   #5
bbuske
Member
 
Registered: Dec 2016
Location: Caracas, DC, Venezuela
Distribution: openSUSE Leap 42.2
Posts: 109

Rep: Reputation: 15
Hello,

ah ok, thanks for the clarification. It wasn't clear from your initial post, if you were dual-booting or not, since you just mentioned you tried on Windows.

Either way, I am glad it worked now. And yes - Alsa does usually start automatically. However, it might happen at times, that it does not for whatever reason. I had that like once out of 100 boots, that on my openSUSE sound would not be enabled. Simply restarting it does the trick.
 
Old 01-02-2017, 03:02 PM   #6
The Sego Sago Kid
Member
 
Registered: Feb 2015
Location: PA USA
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: Disabled
It's cool; thanks for taking a stab at the issue. As for alsa not initializing my card, I suppose a command in my .initrc will be the easiest workaround.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone does not work with Realtek ALC883 HDA fakie_flip Linux - Hardware 47 03-26-2012 07:25 PM
[SOLVED] HDA Nvidia, Realtek ALC1200 Amdx2_x64 Linux - Hardware 12 05-01-2010 02:51 PM
2.6.27 kernel problem with HDA NVidia Realtek ALC888 stunix Linux - Kernel 6 11-12-2008 05:10 PM
Pbsound realtek hda intel alc 883 stefe Linux - Hardware 2 08-16-2007 05:04 AM
HDA Intel/Realtek microphone/line in very quiet format C: Linux - Hardware 1 02-20-2007 01:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration