-   Slackware (
-   -   Sound, RealPlayer, Alsamixer (

BashTin 06-04-2007 08:56 PM

Sound, RealPlayer, Alsamixer
Hi all.

So here I am again seeking some expert help for a couple of irritating issues I have on my Slack 11.0 install on my Panasonic CF-T1 laptop.

First off. I want to store the mixer setting as an ORDINARY user when I log off. I can do this as root, no problem, using Alsamixer. But when I run Alsamixer as none root the settings are not stored and on start up the sound is fully on and fear for the safty of my speakers!!
So how do I get sensible volumes as a none root user?

And lastly. I like to listen to the radio using the RealPlayer plugin in FireFox. However sometimes I get no sound. The player shows 'contacting', buffering & then 'playing' but I have no sound. I can run alsaconf again and the result is the same. But KDE sounds work and I can use 'play' to play a sample sound. Other times it just works fine. Any idea how I can sort this?

Thanks in advance and all advise very much appreciated.


Hern_28 06-05-2007 08:59 AM

Are you running KDE and do you have kmix running. Or does it also not store the sound options?

Nem 06-05-2007 05:09 PM

After adjusting the volume with alsamixer,
run command

alsactl store
as root
and that will save your current volume settings.

BashTin 06-06-2007 09:18 PM

Thanks, 'alsactl store' works a treat.

Now if only I could sort Real Player:scratch:


All times are GMT -5. The time now is 01:44 PM.