Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 10-11-2006, 07:22 PM   #1
LQ Newbie
Registered: Nov 2004
Location: Texas
Distribution: slackware
Posts: 7

Rep: Reputation: 0
Sound problem with Slackware 11.0

I would appreciate a little advice on getting my sound card working with my new Slack 11 installation. It was a clean install with kernel, and I am trying to use my C-Media 8738/C3DX card. My machine also has onboard sound which seems to be the problem. Here is the output of lsmod | grep > snd:
snd-seq-oss 23104 0 (unused)
snd-seq-midi-event 3208 0 [snd-seq-oss]
snd-seq 33552 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 28928 0
snd-mixer-oss 11928 0 [snd-pcm-oss]
snd-cmipci 18208 0
snd-opl3-lib 5636 0 [snd-cmipci]
snd-hwdep 4156 0 [snd-opl3-lib]
snd-via82xx 13580 0
gameport 1388 0 [snd-cmipci snd-via82xx]
snd-ac97-codec 68160 0 [snd-via82xx]
snd-pcm 52804 0 [snd-pcm-oss snd-cmipci snd-via82xx snd-ac97-codec]
snd-timer 13168 0 [snd-seq snd-opl3-lib snd-pcm]
snd-mpu401-uart 3120 0 [snd-cmipci snd-via82xx]
snd-rawmidi 12224 0 [snd-mpu401-uart]
snd-seq-device 3716 0 [snd-seq-oss snd-seq snd-opl3-lib snd-rawmidi]
snd 34304 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-cmipci snd-opl3-lib snd-hwdep snd-via82xx snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3300 11 [snd]
snd-page-alloc 4980 0 [snd-seq-oss snd-seq snd-mixer-oss snd-hwdep snd-via82xx snd-pcm snd-timer snd-rawmidi snd-seq-device snd]

alsaconf configures the c-media card but sees the onboard via chip. alsamixer sets volumes only for the via chip. Any ideas?

Old 10-11-2006, 09:04 PM   #2
Registered: Oct 2006
Posts: 40

Rep: Reputation: 16
When you boot up, see if you get an error? I have the same card, and I get an error saying I need to load the alsa module, or something like that. I have not got it fixed yet, because I am working on other things first. But you may not have the modules loaded.
Old 10-11-2006, 09:32 PM   #3
Senior Member
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,235

Rep: Reputation: 302Reputation: 302Reputation: 302Reputation: 302
It might be easiest to disable the onboard sound via cmos setup. Otherwise you will need to specify whcih card is which card number. I do this because I currently have 2 sound cards and made a /etc/modprobe.d/sound file for this purpose:

alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
alias snd-card-1 snd-ens1371
alias sound-slot-1 snd-ens1371
options snd-emu10k1 index=0
options snd-ens1371 index=1
Old 10-11-2006, 11:00 PM   #4
LQ Newbie
Registered: Nov 2004
Location: Texas
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
many thanks

Disabling the on-board sound in BIOS worked like a charm. The output is still a bit quirky, but I'll check the book on the card for that. Thanks!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problem on Slackware trainee Slackware 8 02-07-2006 12:34 AM
Slackware sound problem, HELP! fiddle Slackware 4 08-08-2005 03:06 PM
Problem with sound in Slackware 10 infornography Slackware 4 11-30-2004 05:44 AM
Slackware 10 Sound Problem Jeffmrg Slackware 12 08-09-2004 06:07 AM
Sound problem Slackware 10 arubin Slackware 3 07-01-2004 08:54 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:51 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration