-   Slackware (
-   -   sound problem when booting in run level 4 (

gty 11-10-2012 11:13 PM

sound problem when booting in run level 4
Hi Everyone,

I followed the tutorial in slackware, section 6.5 xdm, so I can boot straight to X. It worked fine and I logged in using XDM, but I lost the sound.

I'm not sure if this is a known issue, or I'm just a clueless newbie, but for some reason, when I edited my /etc/inittab and changed "id:3:initdefault:" to "id:4:initdefault:", I noticed my sound is not working anymore. And when I returned it to "3", the sound works fine again.

For your reference, here's my Slackware version and sound card.

Slackware 14.0
Card: HDA Intel
Chip: Conexant CX20549 (Venice)

Thank you in advance.


T3slider 11-11-2012 12:04 AM

Is your user a member of the audio group? When you login in runlevel 3, /etc/login.defs temporarily adds your user to the audio group, and that gets inherited by the X session when you run startx. In runlevel 4, login.defs does not apply and unless you are explicitly a member of the audio group you may lose access. The following command should work:

# usermod -a -G audio username
If you're not a member of the audio group then you are likely also missing some other important group permissions. The following command would add your user to the recommended groups:

# usermod -a -G audio,cdrom,floppy,plugdev,video,power,netdev,lp,scanner username

tony0605 11-11-2012 04:32 AM

I thought that I would add my experience to this post which may help others in the same position my KDE kept asking (pop-up after login):

'KDE detected that one or more internal devices were removed.
Do you want KDE to permanently forget about these devices?
This is the list of devices KDE thinks can be removed:
Capture: HDA Intel (ALC269 Analog)
Output: HDA Intel (ALC269 Analog)
Output: HDA Intel, ALC269 Analog (Default Audio Device)'

After some research I realised that I had not added the additional groups to the user that I had created - which is simply a matter of using the 'up key' when asked 'do you want the user added to any other groups' during the adduser process.

Thanks to T3slider for the info about the way permissions are inherited by the X session between the different runlevels.

Thanks also to Patrick and the Slackware development team for a great distro (Slackware 14 - 64bit) which has worked straight out of the box.

gty 11-11-2012 09:12 AM

That makes a lot of sense.

Thanks T3slider for a very good explanation.

All times are GMT -5. The time now is 11:12 PM.