LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-10-2018, 11:54 AM   #1
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Rep: Reputation: Disabled
Sound problem in Slackware 14.2, sometimes


Have read the threads and tried many things but am still stumped: I get sound out of some applications, but not others.

Seems to work:
Firefox 60.x
/usr/bin/play (SoX 14.4.2, Slack 14.2 out of the box)

Runs, but no sound:
/usr/bin/cdda-player (Slack 14.2 out of the box)
grip2 2.96 (built from source, thank you SlackBuilds.org!)

One notes a pattern... Could there be some setup thing specific to the CD device that I need to attend to? BTW both cdda-player and grip2 read data from the CDROM and are able to get the (correct) track data from the CDDB. So "something's" working. Just not the sound.

I did run alsamixer as both root and user and unmuted everything.

Thanks for any tips!

M
 
Old 06-10-2018, 12:13 PM   #2
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 970

Rep: Reputation: 159Reputation: 159
Have you run
Code:
pavucontrol
? I spent some time trying to get Firefox to make sound (everything else did) and discovered that Firefox stopped supporting any audio other than pulse; I just ran
Code:
ldd /usr/bin/play
and see, to my surprise, that it has dependencies on pulse but none on alsa! I don't have cdda-player or grip2: do they use alsa or pulse? If they use pulse, have you run
Code:
pavucontrol
? What does
Code:
grep snd /var/log/messages
return?
Code:
grep snd /var/log/syslog
?
 
Old 06-10-2018, 12:47 PM   #3
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
pavucontrol - thanks, wasn't aware of this. Not sure what I'm seeing but definitely no references to an internal CD reader. Input devices are mic and line in, both unplugged (correct). And that's it. Should there be an entry corresponding to the CD device?

cdda-player (came with the full Slack 14.2 install):

Code:
~: ldd /usr/bin/cdda-player 
        linux-vdso.so.1 (0x00007ffe4e9da000)
        libcdio.so.16 => /usr/lib64/libcdio.so.16 (0x00007fb557910000)
        libcddb.so.2 => /usr/lib64/libcddb.so.2 (0x00007fb5576ff000)
        libncurses.so.5 => /lib64/libncurses.so.5 (0x00007fb5574a7000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fb55719e000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fb556dd5000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fb556bd0000)
        /lib64/ld-linux-x86-64.so.2 (0x000055afbfd46000)
So I can't figure out if it uses alsa or pulse.

And grip2, similar:

Code:
~: ldd /usr/bin/grip2      
        linux-vdso.so.1 (0x00007fff90ffa000)
        libgtk-1.2.so.0 => /usr/lib64/libgtk-1.2.so.0 (0x00007fe6a057c000)
        libgdk-1.2.so.0 => /usr/lib64/libgdk-1.2.so.0 (0x00007fe6a0340000)
        libgmodule-1.2.so.0 => /usr/lib64/libgmodule-1.2.so.0 (0x00007fe6a013d000)
        libgthread-1.2.so.0 => /usr/lib64/libgthread-1.2.so.0 (0x00007fe69ff3b000)
        libglib-1.2.so.0 => /usr/lib64/libglib-1.2.so.0 (0x00007fe69fd11000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe69faf3000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fe69f8ef000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fe69f6dd000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fe69f3a1000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fe69f098000)
        libcdda_interface.so.0 => /usr/lib64/libcdda_interface.so.0 (0x00007fe69ee89000)
        libcdda_paranoia.so.0 => /usr/lib64/libcdda_paranoia.so.0 (0x00007fe69ec80000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fe69e8b7000)
        /lib64/ld-linux-x86-64.so.2 (0x00005635a7575000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fe69e697000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fe69e494000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fe69e28f000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fe69e086000)
Only showing the messages from the most recent boot:

Code:
~: grep snd /var/log/messages
Jun 10 12:25:34 tcraft kernel: [    3.688571] snd_hda_codec_analog hdaudioC0D0: autoconfig for AD1884A: line_outs=1 (0x12/0x0/0x0/0x0/0x0) type:line
Jun 10 12:25:34 tcraft kernel: [    3.688614] snd_hda_codec_analog hdaudioC0D0:    speaker_outs=1 (0x13/0x0/0x0/0x0/0x0)
Jun 10 12:25:34 tcraft kernel: [    3.688645] snd_hda_codec_analog hdaudioC0D0:    hp_outs=1 (0x11/0x0/0x0/0x0/0x0)
Jun 10 12:25:34 tcraft kernel: [    3.688674] snd_hda_codec_analog hdaudioC0D0:    mono: mono_out=0x0
Jun 10 12:25:34 tcraft kernel: [    3.688699] snd_hda_codec_analog hdaudioC0D0:    inputs:
Jun 10 12:25:34 tcraft kernel: [    3.688722] snd_hda_codec_analog hdaudioC0D0:      Mic=0x14
Jun 10 12:25:34 tcraft kernel: [    3.688744] snd_hda_codec_analog hdaudioC0D0:      Line=0x15
and

Code:
~: grep snd /var/log/syslog
yielded no output.

The machine is probably ca. 2010 - surely not old enough to require a physical patch line from CD analog output to the sound card ... ?

thanks

M.
 
Old 06-10-2018, 12:52 PM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,422

Rep: Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348Reputation: 2348
Quote:
Originally Posted by modim View Post
The machine is probably ca. 2010 - surely not old enough to require a physical patch line from CD analog output to the sound card ... ?
you definitely need that, no matter the age of the machine.
 
Old 06-10-2018, 01:11 PM   #5
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,945

Rep: Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843
If the optical drive is SATA there is no need for the analog cable connection.
 
Old 06-10-2018, 01:18 PM   #6
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
I opened the case up. Looks like a SATA drive and also no unused connectors so it would seem this isn't the issue.

(Date of mfr: Dec 2008 ... worth the time, just to get the dust out!)
 
Old 06-10-2018, 07:03 PM   #7
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 702

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
@modim
I'd try to reset the pulse audio profile of the root & your user's home directory /root/.config/pulse/ & /home/user/.config/pulse/ from the console (no X running) by:
- killing all pulseaudio sessions - run: pulseaudio -k both as root & user
- creating a backup of the content of /root/.config/pulse/ & /home/user/.config/pulse/
- cleaning all the content of /root/.config/pulse/ & /home/user/.config/pulse/ - deleting all files

Then, as root, start pulseaudio, run: pulseaudio -D
Take a look in the /root/.config/pulse/ and check if it's getting populated.
Run alsamixer, press F5 and set all volumes at the maximum.
Kill pulseaudio, run: pulseaudio -k

Switch to your user and run: pulseaudio -D
Take a look in the /home/user/.config/pulse/ and check if it's getting populated.
You can check the volume level of the audio adapters in console mode by issuing: pacmd list-sinks
Kill pulseaudio, run: pulseaudio -k

Finally start X and check if your audio applications are running OK, as mentioned by RandomTroll in a previous post, use pavucontrol to tune the volume:
https://freedesktop.org/software/pul...screenshot.png

As for the CD-ROM audio analogue line, that's something you can usually find in older systems - 15-20 years ago, by that time the audio adapters also had a specific audio input line.
https://encyclopedia2.thefreediction...OM+audio+cable
 
Old 06-10-2018, 07:36 PM   #8
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 970

Rep: Reputation: 159Reputation: 159
I have a 2011 machine and no separate output for the CD.

I didn't know what grip was. Now I know that your problem may not be audio but reading the CD, which is an audio CD right? (I have cdda-player but it lacks a man page, why I didn't know) Does it spin? Can you read a non-audio CD? Can you use other CD tools on it?
 
Old 06-13-2018, 10:14 PM   #9
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
abga:

Thanks for the suggestions. First, a BTW: the whole system is Slack 14.2, very much out of the box w/r/t audio.

Here's what happened:

Code:
pulseaudio -k both as root & user

In both cases gave me an error: "Failed to kill daemon: No such
process" but I don't think this is necessarily a problem. NB I
leave /etc/rc.d/rc.pulseaudio without execute permissions, per
advice in that file, so no daemons started at boot, I guess.

as root:
~: mv /root/.config/pulse/ /root/.config/pulse.bak

as user:
~: mv ~/.config/pulse ~/.config/pulse.bak

as root:
~: pulseaudio -D
~: ls -l /root/.config/pulse
7282699ba83555405b8e43b0593f5ff8-card-database.tdb
7282699ba83555405b8e43b0593f5ff8-default-sink
7282699ba83555405b8e43b0593f5ff8-default-source
7282699ba83555405b8e43b0593f5ff8-device-volumes.tdb
7282699ba83555405b8e43b0593f5ff8-runtime
7282699ba83555405b8e43b0593f5ff8-stream-volumes.tdb
cookie

... all timestamped "now"

as root:
~: alsamixer

... and set all volumes to max, everything unmuted, disabled Auto-Mute

as root:

~: pulseaudio -k

as user:
~: ls  ~/.config/pulse
ls: cannot access ...: No such file or directory
I figured I should I try to resolve this before continuing. When something works as root but not user, I usually suspect a permissions problem on a device or something ... just not sure where to look. Any ideas?

thanks!
M.
 
Old 06-13-2018, 10:32 PM   #10
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
RandomTroll,

sorry, wasn't clear about it being a problem specific to playing audio CDs.

I can indeed mount and read a data CD out of that drive - that has always worked as expected.

When I play an audio CD with grip or cdda-player, the software seems to read enough of the tracks to do the CDDB lookup and acts as though it were playing - the seconds count by, it advances to the next track... even the green LED on the CD drive blinks in an irregular fashion as though it were reading the audio data. So I think the CD player is working properly.

PS yes, odd that cdda-player comes with no man page!

r/
M.
 
Old 06-13-2018, 10:41 PM   #11
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 14,047
Blog Entries: 24

Rep: Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794
If you haven't done so, check the pavucontrol settings with the audio CD mounted and playing.
 
Old 06-13-2018, 11:05 PM   #12
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 702

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
Quote:
Originally Posted by modim View Post
abga:

Thanks for the suggestions. First, a BTW: the whole system is Slack 14.2, very much out of the box w/r/t audio.

Here's what happened:
......
I figured I should I try to resolve this before continuing. When something works as root but not user, I usually suspect a permissions problem on a device or something ... just not sure where to look. Any ideas?

thanks!
M.
Don't bother about:
Quote:
"Failed to kill daemon: No such process"
it's just stating that no pulseaudio process was running, which is OK. I just instructed you to run pulseaudio -k in order to kill any potentially running pulseaudio process before moving/backing up the configuration profile.

On the other issue:
Quote:
as user:
~: ls ~/.config/pulse
ls: cannot access ...: No such file or directory
I'd suggest to use absolute paths instead of "~", just for the sake of consistency.
- do you have a /home/user/.config/ parent folder to accommodate pulse/ in the first place, maybe even a /home/user/ to start with?
- how did you create the user? Have you used the /usr/sbin/adduser script? (I advise you to! - instead of the useradd, which doesn't do the complete job if the necessary details (options) are not provided)

Now, to put the user's home folder in order, regardless of how you created it, first you should get some details about your user by using some commands (easier than putting you to parse the files in /etc):
Code:
# check if the home directory is defined for your user - should be: "Directory: /home/user"
finger user
#check what group the user belongs to - should be: groups=xxx(users)
id user
Then create the /home/user/ plus /home/user/.config/ if they don't exist and get the right ownership on them:
Code:
#as root - change the "user:group" to match your setup
/bin/chown -R user:group /home/user
Finally switch to the user and run pulseaudio -D, the /home/user/.config/pulse/ should be created and populated.
For pulseaudio related issues always check /var/log/syslog and ignore the annoying:
Code:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

P.S.
Since you're up for some multimedia stuff on your system, it's advisable to add your user to the relevant groups (change "user" at the end of the line to reflect your actual username):
Code:
/usr/sbin/usermod -a -G cdrom,audio,video,plugdev,input,pulse,messagebus user

Last edited by abga; 06-13-2018 at 11:18 PM. Reason: P.S.
 
Old 06-13-2018, 11:27 PM   #13
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 970

Rep: Reputation: 159Reputation: 159
What happens if you try to play an audio file while trying to play a CD? Are there /tmp/pulse* directories? I notice cdda-player doesn't link to pulse.
 
Old 06-13-2018, 11:49 PM   #14
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
abga,

thanks. /root/.config and /home/user/.config both appear to be OK:

Code:
~: sudo ls -ld /root/.config /home/user/.config
drwxr-xr-x 18 user users 4096 Jun 10 13:35 /home/user/.config
drwxr-xr-x  6 root root  4096 Jun 13 22:57 /root/.config
also, while we're at it:

Code:
~: groups user root
user : users sudo lp audio cdrom smmsp plugdev scanner
root : root bin daemon sys adm disk wheel audio
(where "user" anonymized here.)

The permissions thing I was suspecting was about accessing devices, not writing to the user or root .config directories.
 
Old 06-14-2018, 12:12 AM   #15
modim
LQ Newbie
 
Registered: May 2016
Posts: 11

Original Poster
Rep: Reputation: Disabled
abga:

I added user to the pulse group and rebooted ... no change:

Code:
~: groups user
user : users sudo lp audio cdrom smmsp pulse plugdev scanner
~: pulseaudio -D
... as user still doesn't create a pulse directory in /home/user/.config

For completeness I could try adding user to video, input, and messagebus, but haven't so far.

Grasping at straws, I tried make the pulse directory myself but it went unpopulated. As user:
Code:
~: pulseaudio -k
~: mkdir /home/user/.config/pulse
~: ls -ld /home/user/.config/pulse
drwxr-xr-x 2 user users 4096 Jun 14 01:16 pulse
~: pulseaudio -D
~: ls -l /home/user/.config/pulse
total 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14 sound problem donallen Slackware 10 02-26-2013 12:36 AM
Sound Problem in Slackware 12.1 leo-v Linux - Newbie 1 11-26-2008 02:44 AM
Slackware sound problem, HELP! fiddle Slackware 4 08-08-2005 03:06 PM
Problem with sound in Slackware 10 infornography Slackware 4 11-30-2004 05:44 AM
Sound problem Slackware 10 arubin Slackware 3 07-01-2004 08:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration