-   Slackware (
-   -   Sound Problem: ESS (ES1869F-Chipset) No Sound (

computer_kid 09-24-2004 02:49 PM

Sound Problem: ESS (ES1869F-Chipset) No Sound
Computer Kid: Joe


TYPE: Compaq Deskpro EN P450+/P500 SFF (SFF - Small Form Factor - Workstation BIOS)
BIOS: 686T3 ROM (upgraded to the latest: 99.08.22)
CPU: Intel 500MHz PIII (Old Cart-style)
VIDEO: AGP 2X 64MB Parcher 3D FX ATI Rage Pro Turbo
SOUND: ESS Audio Drive (ES1869F - Chipset) (Sound In/Out, Mic., Headphone)
MEMORY: 198MB 3xDIMM PCI100-322-620 (Guessing SDRAM)
NET: Ethernet 100MBits
CARD SLOT: 4 PIC (1 for Net) and 2 ANSI
KM: PS/2 Mouse and keyboard.
USB: 2 back.
IOIOI: (Serial) 2 A & B
IDE - E-IDE 1 Floppy, 1 Primary, 1 Sencondary
- 1 Floppy 1.44M (COMPAQ)
- 1 Master (Primary) 6GB Hard Drive (FUJITSU)
- 1 Master (Sencondary - Single) CD-ROM 4-32x Read Only (REVEAL)
PC SPEAKER: 1 Front, also acts like your Main Audio output if none are attached
Ext. SPEAKER: 1 (Left/Right) LABTEC
Slackware 10 Running KDE XWindows Interface.
-Software (Besides Slackware FULL INSTALL)
BOCHS (DOS emulator: Latest)
XINE (VIDEO: Latest)
TuxNES (NES emulator: Latest)
SNES9Linux (SNES emulator: Latest)
QNetWalk (a network puzzle game)

I just reinstall Slackware 10 and the software I use. I was thinking I might have missed something and didn't install the sound. Thats why I went with full install. It did not work, so I'm asking all of you to help me, please.

Sound does not output any sound other then Beeps.
ALSA says
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.
I have no idea what to do, it's a chipset. I don't know what IO, DMA, IRQ, CHANNELS or anything. I can get to another computer like mine (only PIII 450MHz) and that one is running Windows XP, so I should be able to look that info up. That computer is over at my grandma's right now. I never knew my grandparents would ever be Gaming People. So I don't know when I could look that info up.
From that computer I know the PC Speaker works like the main speakers if they are not plugged in.
The Motherboard also has the spot for CD Audio and I have a cable that runs from the CD to the motherboard.
The Computer beeps if I do something wrong, or tap the tab key twice in KDE, but other then sound.

I would love help on this one, I have looked into even using the PC speaker but I am not able to get a compiled version or a source that will compile.

I hope someone out there has a idea.

I would like to thank you for reading this and helping me. Please, also forgive my bad spelling and grammar.

computer_kid 09-24-2004 03:47 PM

Work around
I found a old sound card, I slaped it in and ran alsaconf and it's up and running. I ran alsa before I put this card in and it didn't find the ship set atall. If you have a idea, please give me one. Othere wise I'll just use the card I put in there. Thanks!

nickhill 05-24-2005 09:32 PM

I had some problems getting sound to work with the same machine, a Compaq EN series deskpro 6350.

I grepped the linux source code for 1869. This showed the necessary info

cd kernel-source-2.6.11
grep -R 1869 *
I could see several references in sound/oss/sb_ess.c which appears to be included in the sb module (as there is no sb_ess module).

The source says:
* ESS detection isn't full proof (yet). If it fails an additional module
* parameter esstype can be specified to be one of the following:
* -1, 0, 688, 1688, 1868, 1869, 1788, 1887, 1888
* -1 means: mimic 2.0 behaviour,
* 0 means: auto detect.
* others: explicitly specify chip
* -1 is default, cause auto detect still doesn't work.

So I tried
modprobe sb esstype=1869 io=0x220 irq=5 dma=1

This didn't appear to work with KDE sound test at forst. So I disabled Full Duplex. It now works.

To make changes permanent and enable the sound card on boot in most distributions (eg Debian, Mandrake, Mepis, Fedora, RedHat) add the following line to the file /etc/modules
sb esstype=1869 io=0x220 irq=5 dma=1

This will cause the module to be inserted into the running kernel at boot time with the given parameters.

Even though I checked the source for 2.6.11 it should be the same for earlier kernels. The code seems to have been there since 1998 so is probably in your 2.2 or 2.4 series kernel as well.

nickhill 05-25-2005 10:48 AM

Investigating and experimenting further, the option dma16=x (where x is 0, 1, 3 or 5) should enable duplex operation. dma16 issupposed to enable a second DMA channel which is necessary for duplex (record and play back simaultaneously) operation.

I have tried all sensible combinations of DMA settings. Each time checking /proc/dma and trying duplex in KDE sound system. The dma16 channel has never shown up in /proc/dma and at no point has KDE sound system started sucessfully with duplex enabled.

In summary, the dma16= setting has no effect with this chip. You will need to ensure your sound server/system has duplex disabled else it may not work at all.

If you fancy modifying the kernel source code, you may find a way to fix this bug and return the improvement back to the kernel programmers.

tram 11-10-2005 11:23 PM

I've been wrestling with this issue for weeks now and the most success I've had was found on this site where I tried:

modprobe sb esstype=1869 io=0x220 irq=5 dma=1

This didn't do anything until I logged out and logged back in again. My sound was working perfectly and the volume control was present. I rebooted, but then I was back to square one. No sound card.

I can't add the following line to the file /etc/modules
sb esstype=1869 io=0x220 irq=5 dma=1
because this file does not exist.

I'm using Suse 10

Any help would be appreciated

sanskritter 11-30-2005 09:54 PM

I had a similar problem getting realplayer to work on a debian distro.
Try this, silly as it sounds

cd /dev
./MAKEDEV audio

worked for me!

tram 12-01-2005 12:39 PM

well, i finally got it working... Kinda. I can play music in the player and my sound control now shows up, but the system sounds from the OS (like the magical soothing sound you hear on boot) does not work. I can live with this though... I guess. :rolleyes:

popcornisgood 07-26-2006 09:59 PM

Stupid question but did you make sure they're turned on in the sound options?

Old_Fogie 07-27-2006 02:59 AM

FWIW althought this is a different sound card I have, I found that for my specific card I had to

(a) get all these settings from my bios
(b) add the following values as one complete string into my slackware 10.2's /etc/rc.d/rc.modules file


/sbin/modprobe snd-opl3sa2 index=0 id=CARD_0 port=0x370 sb_port=0x220 wss_port=0x530 midi_port=-1 fm_port=-1 irq=5 dma1=0 dma2=1 isapnp=0
Then the computer really new everything that was going on.

Also, as root running in console 'alsamixer' then using the arrow keys to turn stuff up, down, move left and right to set the default volumes, then escape key exits alsamixer, then in console as root 'alsactl' store saved my settings as the defaults for every reboot, and default volume levels for all users.


drakebasher 08-02-2006 09:41 PM

Very cool that well thought-out postings can be useful even 18 months after first written. Just minutes after deciding to get sound on my dual PIII Compaq ap400/Debian Sarge 2.6 kernel, I had it up thanks to this thread.


/make an effort
/make a difference

All times are GMT -5. The time now is 09:25 PM.