-   Slackware (
-   -   Sound on Slack 13.37 - solved (

bobaye 09-08-2012 02:40 PM

Sound on Slack 13.37 - solved
I have had schizophrenic sound on my Slack install since I upgraded to 13.37.
Reading a ton of forum posts and tutorials (and getting nowhere really) finally led me to blacklist a HDMI module at boot.
It was a simple issue, but because so many users seem to have trouble it was easy to get lost in finding what the trouble actually was.
In my case I blacklisted snd-hda-intel, I'm not going to pretend I can help you find your offending module, but if you have this issue at least you can expend your effort in a useful direction. You would have to find the name of the chip you don't want and which driver it uses.
I would get sound every 3rd or 4th boot, and when it worked it was great - everything worked.
I just didn't know which boot was going to give me working sound.
Frustrating for me when I was trying to effect module loading order with option tags in /modprobe.d/sound.conf and getting nowhere.
I had installed a ATI 3D video card which had an HDMI sound chip and it was apparently being detected much earlier on boot than the onboard Nvidia CK804 chip I wanted to use.
Kmix showed both cards, but I wasn't able to choose between them if the HDMI card was detected first. (I don't have any sound device connected to the HDMI output).
Finding the module that was being loaded for the HDMI chip and blacklisting it in /etc/modprobe.d/blacklist.conf
finally stopped it from loading at boot and now I have just the one Nvidia card showing in Kmix and it works system wide for everything.
I found this page quite helpfull -
Maybe that will help somebody else who is fighting the same issue.

All times are GMT -5. The time now is 10:46 AM.