-   Slackware (
-   -   Sound don't work (

X11 07-07-2002 05:09 AM

Sound don't work
I have a strange problem with one of my 'slack-boxes', the laptop machine seem to work with sound a OK. But the desktop machine which has a very popular Sound Card in it (a Sound Blaster Live!) doesn't seem to work.

I've tried:
1. modprobe emu10k1
2. insmod emu10k1
3. I've looked at the permissions for: mixer, dsp, audio under the dev directory.

I'm out of ideas on what the problem might be.

Config 07-08-2002 10:13 AM

I know about the permissions problem - the easiest way to check is running xmms as root and play a file - this will work if you have a permission problem. If this doesn't work try the following:
-recompile emu10k1 from source
-look whether you can specify some parameters with modprobe. May be it you have to tell which irq and so on.

rootman147 07-08-2002 11:07 PM

I am having a problem too, My (old, but reliable) dell inspiron 3000 has a crystal audio 4232 or something similar. Trying to use the module with all the irq dma and such loads successfully and it will beep and such, but xsmms won't play, says it can't load /dev/dsp, even as root, but the instructions I read said to give two dma values and it would take it so I tried both one at a time (1 and 0). Any ideas?

eggs 07-09-2002 02:29 AM

Perhaps this is unnessesary but did you put

alias sound emu10k1

in /etc/modules.conf ?

Config 07-09-2002 08:58 AM

Hmmm... i suddenly had problems too, but I got a workaround. Well, on my system, sound won't play from xmms if /dev/dsp doesnt belong to group sys. I changed it and suddenly, xmms hung when trying to play

ksandre 07-09-2002 12:36 PM

>>sound won't play from xmms if /dev/dsp doesnt belong to group sys. I >>changed it and suddenly, xmms hung when trying to play

You want to join your sound *user* to group "sys" in /etc/group/ - or create an entirely separate audio group and change everything related accordingly (then you can use minimal permissions on files, executables, and devices).
(See also /dev/MAKEDEV file.)

almacabio 07-10-2002 08:48 AM

sound troubles
I am not sure if it is a risky procedure, but in my Slackware 8.0
I have solved the problem putting users also in the SYS group

All times are GMT -5. The time now is 12:44 PM.