LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-03-2019, 04:12 AM   #1
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 53

Rep: Reputation: Disabled
Some websites are barely readable


Hi all.

Some Websites which I open in Firefox are barely readable, e.g.:

https://www.switch.ch/aai/guides/sp/...cate-rollover/

Click image for larger version

Name:	fonts_ff.png
Views:	189
Size:	90.2 KB
ID:	31452

I have also tried in other browsers like Chrome, but it results the same. For testing purposes I have set up a Debian VM and within that, the website is displayed correctly.

Is there any way to improve the situation?

Greetings

Lioh
 
Old 10-03-2019, 04:44 AM   #2
Slackovado
Member
 
Registered: Mar 2005
Location: BC, Canada
Distribution: Slackware 14.2 x64
Posts: 298

Rep: Reputation: 62
You need to "tune-up" your fonts config.
Have a look at these pages
https://www.linuxquestions.org/quest...68/page19.html
http://duganchen.ca/writings/slackware/fonts/
But in a nutshell you want to end up with Infinality font setup.
You can probably find compiled packages or roll your own.
The final result is a display that's really easy on the eyes.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-10-03_02-34-19.png
Views:	68
Size:	223.3 KB
ID:	31453   Click image for larger version

Name:	Screenshot_2019-10-03_02-35-09.png
Views:	86
Size:	124.4 KB
ID:	31454  
 
1 members found this post helpful.
Old 10-03-2019, 04:54 AM   #3
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 53

Original Poster
Rep: Reputation: Disabled
Hmm, I was not planning to use Infinality. I have set up : export FREETYPE_PROPERTIES="truetype:interpreter-version=35" which works the best for me and have defined DejaVu as my preferred font. When I look at this page, it makes use of a strange commercial font like:

font-family: "FrutigerNextW01-Regular",Helvetica,Verdana,sans-serif;

When I remove the "FrutigerNextW01-Regular" part the fonts are somehow displayed correctly. So there must be a font configuration around which replaces unknown fonts with 'not-so-good-looking' ones. This is what I would like to find out.

Greetings

Lioh
 
1 members found this post helpful.
Old 10-03-2019, 06:47 AM   #4
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 53

Original Poster
Rep: Reputation: Disabled
What is a bit difficult for me to understand is that normally, if the given font is not detected on the system, the browser should fall to the next available in the list. In this case it would be sans-serif which is available on Slackware.
 
Old 10-03-2019, 07:36 AM   #5
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 168

Rep: Reputation: 68
You can set font preferences in the browser and tell it to not use other
fonts. Just go for the standard options and see if you like it.

I tried the page in your first post (with page chosen fonts) and the fonts
look somewhat ok on a 4k monitor in seamonkey. Perhaps that is what the
webdeveloper imagined everyone has.
 
1 members found this post helpful.
Old 10-03-2019, 09:03 AM   #6
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,158

Rep: Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992Reputation: 3992
Install this if you haven't already.

http://slackbuilds.org/repository/14...webcore-fonts/

Also, try -current (in a VM is fine) if you're not already running that. It has changes to the default font rendering settings.
 
2 members found this post helpful.
Old 10-03-2019, 09:46 AM   #7
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,282

Rep: Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924Reputation: 1924
To me, it looks like a hinting issue.
I suggest that the OP tries in turn each of the possible slight, medium and full hinting configurations by creating the symlink for each configuration in /etc/fonts/conf.d
e.g. (as root, from within the /etc/fonts/conf.d directory)
Code:
ln -s ../conf.avail/10-hinting-medium.conf 10-hinting-medium.conf
Also, check that the subpixel layout for your monitor is correct, as detailed under "Font Configuration" in the excellent webpage from @dugan linked by @Slackovado in post #2.
 
2 members found this post helpful.
Old 10-03-2019, 05:11 PM   #8
Geist
Member
 
Registered: Jul 2013
Distribution: Slackware 14 / current
Posts: 107

Rep: Reputation: Disabled
Is infinality still a thing? I haven't touched it in years and my fonts are all good...
I don't even think I've got it installed anymore.
I don't yeah.
 
Old 10-03-2019, 07:19 PM   #9
TheRealGrogan
Member
 
Registered: Oct 2010
Location: Ontario, Canada
Distribution: Slackware, Manjaro (for gaming)
Posts: 170

Rep: Reputation: 132Reputation: 132
Yes, it's still a thing. The infinality mode is built into freetype now... controllable by editing/uncommenting a variable in /etc/profile.d/freetype.sh (and/or freetype.csh for appropriate shells). Not enabled by default.

Code:
#!/bin/sh
# Configure Freetype properties. Here this is used to set the default mode
# for font hinting. Other controllable properties are listed in the section
# 'Controlling FreeType Modules' in the reference's table of contents.
#
# Three hinting settings are available:

# This is the classic hinting mode used in Freetype 2.6.x:
#export FREETYPE_PROPERTIES="truetype:interpreter-version=35"

# This is Infinality mode, which was never enabled by default. It is slower
# than the new subpixel hinting mode, but said to be more accurate:
#export FREETYPE_PROPERTIES="truetype:interpreter-version=38"

# This is the new default subpixel hinting mode used in Freetype 2.7.x. It is
# derived from the Infinality code base stripped to the bare minimum with all
# configurability removed in the name of speed and simplicity:
#export FREETYPE_PROPERTIES="truetype:interpreter-version=40"
 
1 members found this post helpful.
Old 10-04-2019, 06:16 AM   #10
Slackovado
Member
 
Registered: Mar 2005
Location: BC, Canada
Distribution: Slackware 14.2 x64
Posts: 298

Rep: Reputation: 62
Quote:
Originally Posted by TheRealGrogan View Post
Yes, it's still a thing. The infinality mode is built into freetype now... controllable by editing/uncommenting a variable in /etc/profile.d/freetype.sh (and/or freetype.csh for appropriate shells). Not enabled by default.

Code:
#!/bin/sh
# Configure Freetype properties. Here this is used to set the default mode
# for font hinting. Other controllable properties are listed in the section
# 'Controlling FreeType Modules' in the reference's table of contents.
#
# Three hinting settings are available:

# This is the classic hinting mode used in Freetype 2.6.x:
#export FREETYPE_PROPERTIES="truetype:interpreter-version=35"

# This is Infinality mode, which was never enabled by default. It is slower
# than the new subpixel hinting mode, but said to be more accurate:
#export FREETYPE_PROPERTIES="truetype:interpreter-version=38"

# This is the new default subpixel hinting mode used in Freetype 2.7.x. It is
# derived from the Infinality code base stripped to the bare minimum with all
# configurability removed in the name of speed and simplicity:
#export FREETYPE_PROPERTIES="truetype:interpreter-version=40"
That's right, Infinality with the Microsoft core fonts results in excellent font rendering.
Sadly, it takes a bit of time and effort investment to achieve understanding of all the components that come into play and to configure them correctly.
It's kind of a "right of passage" for Linux users, sort of what configuring Xserver used to be back in the day.
 
Old 10-04-2019, 04:22 PM   #11
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 470

Rep: Reputation: 246Reputation: 246Reputation: 246
Yes. It's too bad that 15+ years after decent font rendering has come to Linux, that manual intervention is still required.

For me, installing the corefonts, including Tahoma, Calibri and Cambria, and deleting the symlink /etc/fonts/conf.d/60-liberation.conf is an absolute must to ensure that those dreadful Liberation fonts are neither seen nor heard.
 
Old 10-04-2019, 07:07 PM   #12
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,270

Rep: Reputation: 606Reputation: 606Reputation: 606Reputation: 606Reputation: 606Reputation: 606
Quote:
Originally Posted by Poprocks View Post
Yes. It's too bad that 15+ years after decent font rendering has come to Linux, that manual intervention is still required.
Is it? I've not manually tweaked anything font related for quite some time.
Quote:
Originally Posted by Poprocks View Post
For me, installing the corefonts, including Tahoma, Calibri and Cambria, and deleting the symlink /etc/fonts/conf.d/60-liberation.conf is an absolute must to ensure that those dreadful Liberation fonts are neither seen nor heard.
!

They look pretty good on my systems.

The fonts you mentioned are not licensed for use under Linux. They're not able to be packaged or distributed.
 
Old 10-15-2019, 02:07 AM   #13
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 53

Original Poster
Rep: Reputation: Disabled
My goal is not really to switch to the propitiatory corefonts. As mentioned in my initial posting other distributions like Debian do not seem to have this issue, so it must be related to the fontconfig settings in Slackware. I still have not understood in which moment the rendering falls to such a strange mode. It must be related to the fact that the font cannot be found on the system.

@rogan setting the fonts manually in FF for all websites, now allowing web pages to set their own fonts, is not an option to me.

Another example is the website of my hoster: https://my.green.ch which forces 'HelveticaNeueW02-45Ligh' !important' and does not offer alternative fallback fonts. Still in such a case, the system should fall back to a default font imho (which is DejaVu in my case, not Liberation) but this process does not seem to work.

@allend The files 10-hinting-medium.conf etc are not available on my 14.2 box. I am going to check on -current as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Make websites more readable with a shell script LXer Syndicated Linux News 0 02-16-2019 12:32 AM
Slow loading / barely working websites after moving to a different server AdultFoundry Linux - Newbie 6 06-13-2016 08:04 AM
Vista & Ext 3 HD Readable/Non-Readable HCour Linux - Newbie 1 01-19-2009 02:18 PM
Mandrake 9.1 on laptop plays CDs but can barely hear it gervin Linux - Newbie 3 01-08-2004 02:58 PM
Sound is barely above normal voice leves...RH9 Q cbjhawks Linux - Hardware 2 08-28-2003 06:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration