LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-26-2004, 06:31 PM   #1
onelung02
Member
 
Registered: Oct 2003
Location: utah
Distribution: Slackware 10.0, Gentoo 2006.0
Posts: 289

Rep: Reputation: 30
Some serious bootloader help please


Alright here it goes. I have Windows, Suse 9.1, and just as of now Slackware 10.0 installed on my machine. The first time that I installed Slackware I chose not to install Lilo because I thought that I could get Grub to work with loading Slackware. I couldn't quite fiugre it out, so I just reinstalled Slackware and this time I installed Lilo. Now when I boot up, I get Lilo, but it only has Windows and Linux as boot options. I have booted into Slackware and opened the /etc/lilo.conf and here is the jist of what it says:
(keep in mind that this is straight from memory, so if I forgot one word or so, please don't post just to tell me that I messed up!!! )
---------------------------------------------------------------
# Windows bootable partition config begins
other = /dev/hdc1
label = Windows
# Windows bootable partition config ends.

#Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hd4/
label = Linux
read-only
#Linux bootable partition config ends

---------------------------------------------------------------
now here is a rough idea of what my HD layout looks like

/dev/hdc1 <========== Windows partition
/dev/hdc2 <========== Swap partition
/dev/hdc3 <========== Suse partition
/dev/hdc4 <========== Slackware partition

What my goal here is I want to either have Lilo show my Suse partition, or get Grub back and going and have that show my Slackware partition.
What I have tried so far:
#pico /etc/lilo.conf
and this is what I added to the config:
# Linux bootable partition config begins
image: (here I have tried /boot/vmlinux/, and I have also tried it without this line at all.)
root = /dev/hdc3
label = Suse
read-only (I have also tried it without this read-only line also)
#Linux bootable partition config ends

I am completely out of ideas, if ANYONE has anything that can help, it would be very appreciated!!!!!!!!!.

__________________
Linux: The great uncle who is always there to help you out.
Windoze:The bad uncle who steals from your wallet while you are sleeping.
 
Old 10-26-2004, 06:43 PM   #2
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
I have no experiende using grub, but basicly to make things work in LILO your SuSE partition where the SuSE kernel is has to be mounted to make it work.

The /etc/lilo.conf addition (assuming your SuSE kernel is named vmlinuz as well)
Code:
image: /mnt/suse/boot/vmlinuz
root = /dev/hdc3
label = Suse
read-only
To mount your SuSE partition :
1. create a mountpoint (directory) , in this example:
Code:
mkdir /mnt/suse
2. mount the partition assuming it is reiserfs
Code:
 
mount -t reiserfs  /dev/hdc3 /mnt/suse
Rerun lilo
Code:
lilo
umount the suse partition:
Code:
umount /mnt/suse
That's it I think
 
Old 10-27-2004, 02:02 AM   #3
onelung02
Member
 
Registered: Oct 2003
Location: utah
Distribution: Slackware 10.0, Gentoo 2006.0
Posts: 289

Original Poster
Rep: Reputation: 30
Worked like a charm. The only problem now became that slackware and suse did not want to share the same swap, so, sadly enough, I have taken off slackware. But don't worry, I am buying a new Hard Drive soon and dedicating it to learning Slackware in and out. But thanks for all the help with the bootloader, that part was solved, thanks!!!
 
Old 10-27-2004, 04:58 AM   #4
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Quote:
Originally posted by onelung02
Worked like a charm. The only problem now became that slackware and suse did not want to share the same swap, so, sadly enough, I have taken off slackware. But don't worry, I am buying a new Hard Drive soon and dedicating it to learning Slackware in and out. But thanks for all the help with the bootloader, that part was solved, thanks!!!
Don't want to share SWAP? That is strange.....

You can add swap (partition) manually in Slackware and I believe the same with Suse too.
 
Old 10-27-2004, 11:42 AM   #5
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Sounds like SuSe does not want to play nice............

I have Slack 9.0 and 9.1 sharing a Swap file with 2 different and customized versions of LFS(linux from scratch)........SO Slack can and will share a swap file...........so SuSe must be the problem............
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 2000 Bootloader vs. Mandriva LILO Bootloader Dregnan Mandriva 7 12-03-2007 10:55 PM
How can I disable the grub bootloader and enable the lilo bootloader? abefroman Linux - General 1 08-06-2005 09:53 AM
I need create bootloader. How make bootloader? swipple Fedora - Installation 3 01-23-2005 01:22 PM
No Bootloader! JoshSmith41 Linux - Newbie 4 07-28-2003 04:24 AM
Bootloader Dumpsterm0uth Linux - General 6 05-26-2003 01:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration