-   Slackware (
-   -   Some Questions, Please Look. (

RefriedBean 06-24-2002 10:01 PM

Some Questions, Please Look.
Hey guys,
I just have a few questions to ask, if you don't mind.

1. VNC
So far, I have gotten vnc to work great, the java server thingie works and everything! There is just one thing thats not working; some apps, like xchat and xmms's fonts show up as little 'blocks'. I think this may have something to do with font paths, although I have added my entire default font path in the vncserver script.(You can obtain that path by typing 'xset -q' in a terminal in your normal X session)

2. GPM & X
Well, first of all, GPM works great when X is not running, and the mouse in X works great regardless of weather GPM is running or not. When I start X, and then go out again, GPM is stuck to the top line of the terminal, and behaves erratically when I touch the mouse. I use the imps2 driver for both. Any idea on how to make X and GPM behave like good neighbors? (Just by the way, I had this working before, before I upgraded to Slackware 8.1. But I forgot how I fixed it.

This is not essential, but a lot of apps seems to use it.
I followed Glut 3.7's README as best I could. But unfortunately its very badly written. Anyway, it compiled correctly, but now I don't know what files should go where .. In the ./lib/glut/ directory there is one file I think called, but when I move that file alone to /usr/local/lib, and try to link another app to it, it spits out a lot of 'Unresolved Symbols', so I guess thats not the only file I have to move to install this beast.

Any ideas? Any help would be greatly appreciated!

Oh, and by the way, as I mentioned before, I use Slackware 8.1


Aussie 06-24-2002 11:04 PM

There is a glut package for slackware 8.1 here , a local mirror might be better for you.
As for GPM, I don't use it because it seems to cause more problems in X than it solves in a terminal...and who needs a mouse in the terminal anyway :p.
I dont use VNC so I can't offer any suggestions there.

RefriedBean 06-25-2002 12:30 AM

Thanks for that link to the Glut Slackpack. :D

Aussie 06-25-2002 12:42 AM

Your welcome :)

jtshaw 06-26-2002 12:08 AM

I had a bunch of gpm issues with my computer in the past. I asked an engineer at NVidia (as I use the NVidia display drivers for linux) and he said it won't ever work right if you use the NVidia specific frame buffer, gpm, and the NVidia X drivers together. However, I use the vga or vesa frame buffer and the other two and they both work fine.

I don't know if this is your situation, but I saw similar mixups when switching back and forth between frame buffer terminals and x while running that setup. Of course mine went as far as locking the machine a couple of times. (well, not completely, sshing into it, killing gpm and killing x fixed it).

RefriedBean 06-26-2002 04:12 AM

Thanks for all your help guys!

Here is what I have done so far,

1. VNC still gives me little blocks, but I think I'll figure it out sooner or later,, probably just some font path I can't find.

2. For Now I decided to kill gpm completely, so it does not start up when I boot. By the way, I am using the VESA VGA framebuffer @ 1024x768x256. Most of the time I prefer having 4 or more terminals on the same screen anyway, so a bunch of Eterms in X does a great job.

3. The Glut Slackpack worked great!! It also showed me what files I should put where when I build it from source (just copy the root of glut to /usr/local/glut, and delete all the directories in the glut root except lib and include. THEN copy the to /usr/local/lib, and /usr/X11/lib, and run ldconfig.)


All times are GMT -5. The time now is 01:37 AM.