LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-17-2003, 02:25 PM   #1
rATIx
LQ Newbie
 
Registered: May 2003
Location: Finland
Distribution: Slackware 9.0
Posts: 3

Rep: Reputation: 0
Some problems with mouse wheel and keyboard


ok,I have some problems.

Problem #1: I cant use scandinavian letters and i have to type like if I had US keyboard so pressing - will make / ,my friend told me to configure XF86Config,well i edited it,restarted x and still doesnt work.My keyboard worked without problems before i reinstalled slackware :P

Problem #2: I cant use my mouse wheel.I searched the forum,found solution,edited XF86Config and it doesnt work.

Help meh :|

Last edited by rATIx; 05-17-2003 at 02:27 PM.
 
Old 05-17-2003, 06:28 PM   #2
Craigus
LQ Newbie
 
Registered: May 2003
Posts: 2

Rep: Reputation: 0
Did you edit XF86Config (wrong one) or XF86Config-4 ?

Can you post the contents here?

Also, if rc.gpm is present in /etc/rc.d, you'll have to delete or rename it (there are other ways to disable it as well).
 
Old 05-19-2003, 05:28 AM   #3
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
In your XF86Config file....

For Problem 1
Option "XkbRules" "xfree86"
Option "XkbModel" "pc101"
Option "XkbLayout" "??"

Replace "??" with your keyboard code... i don't know what it is for scandinavian... sv?

For Problem 2
Under your mouse section... add/modify these lines:

Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

So your mouse section should look something like:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "imps/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

Tell us how you're doing.
 
Old 05-20-2003, 12:01 PM   #4
rATIx
LQ Newbie
 
Registered: May 2003
Location: Finland
Distribution: Slackware 9.0
Posts: 3

Original Poster
Rep: Reputation: 0
Not working.Here the XF86Config from /etc/X11/

EDIT: Ah,I just showed XF86Config to my friend and the reason it didnt work was all those # in front of the options

Last edited by rATIx; 05-20-2003 at 01:00 PM.
 
Old 05-20-2003, 02:33 PM   #5
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 248

Rep: Reputation: 31
It is XF86Config that you want to edit. There is no XF86Config-4 in Slackware 9.0 because there is no XFree86 3.3.x in Slackware 9.0, so there is no need for two configuration files.

Looking at the XF86Config file that you posted, I would say that one problem is that you can't just tack the right settings on at the end for this file without even commenting out the old settings. My advice would be to go to the place where these devices are already configured and comment out any individual lines that are not what you want and typing the correct setting directly underneath the line it is replacing. What your configuration is doing the way it is written is setting up two new devices at the end named "keyboard" and "mouse," which are ignored because your configuration specifically tells XFree86 to use "Keyboard1" as the core keyboard (defined earlier) and "Mouse1" as the core pointer (also defined earlier). Also, as a side note, you must use imps/2 and not PS/2 as your protocol in order for a wheel to work.

Putting this together, you would do the following:
Find the place where it says

Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"

There is nothing that needs to be commented out, so you can just add immediately after this:

Option "XkbModel" "pc101"
Option "XkbLayout" "fi"

*I just realized that you have a line in your keyboard configuration for a Finnish keyboard layout already, so you could just uncomment that instead of adding another line. Also you have commented lines for the model as well. You should either uncomment one of the lines you have for "pc102," add the line above, or leave it at the default "105" setting, whichever is most appropriate for your keyboard.

Then find the place where it says:

Section "InputDevice"

#Identifier and Driver

Identifier "Mouse1"
Driver "mouse"

Add after this:

Option "ZAxisMapping" "4 5"

Then go down a few lines and uncomment the line that says:

# Option "Protocol" "imps/2"

by deleting the number sign (#). Then go down a few more lines to where it says:

Option "Protocol" "PS/2"

and comment that line out by adding a number sign at the beginning. You also might as well get rid of the stuff you added at the end, but be careful not to delete any of the section before it. If you're not sure where what you added starts, you can leave it all and it won't stop it from working. It will just insert 2 fictitious devices. Sorry if this is already solved. I have been typing in between work tasks while I was waiting for people and computers.

Last edited by Rodrin; 05-20-2003 at 02:54 PM.
 
Old 05-20-2003, 04:36 PM   #6
rATIx
LQ Newbie
 
Registered: May 2003
Location: Finland
Distribution: Slackware 9.0
Posts: 3

Original Poster
Rep: Reputation: 0
Yey,everything is working well now,thanks everyone
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KVM mouse wheel problems info mjake Linux - Hardware 1 06-02-2004 01:16 PM
Mouse problems - wheel doesn't work RobertoBech Mandriva 1 01-31-2004 06:32 AM
Mouse wheel problems in ASPLinux Adeas Linux - Newbie 1 11-17-2003 09:01 AM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 09:43 AM
Mouse Wheel Problems hstang Linux - General 4 03-24-2003 09:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration