LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-03-2009, 05:37 AM   #16
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2

Quote:
Originally Posted by rworkman View Post
LnxSlk: as poncez stated, this thread is a bit old for present-day -current problems.

Input devices should still work at a console.

Also, removing that fdi file is not the correct approach. Sooner or later, we'll get a new hal package into the tree, and this (or something similar) will be the contents of that fdi file:
http://connie.slackware.com/~rworkman/10-keymap.fdi.txt

Thanks rworkman, i edited the file as i need, with <merge key="input.xkb.layout" type="string">pt</merge>

everything works fine except my accent keys like: and so on.
 
Old 08-03-2009, 02:49 PM   #17
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
The new hal package is now part of -current, so that part is handled. Re the accents, I know that PiterPUNK said they work for him, so I'm not sure what's going on with your setup.
 
Old 08-03-2009, 07:55 PM   #18
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
Quote:
Originally Posted by rworkman View Post
The new hal package is now part of -current, so that part is handled. Re the accents, I know that PiterPUNK said they work for him, so I'm not sure what's going on with your setup.
The 10-keymap file is what you posted except for this part:

<!-- Edit (as needed) these four lines in the copied fdi file -->
<merge key="input.xkb.rules" type="string">base</merge>
<merge key="input.xkb.model" type="string">evdev</merge>
<merge key="input.xkb.layout" type="string">pt</merge>
<merge key="input.xkb.variant" type="string" />


And the xorg.conf

Section "Device"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile GM965/GL960 Integrated Graphics Controller"
BusID "PCI:0:2:0"
Option "DRI" "true"
Option "RenderAccel" "true"
Option "AccelMethod" "UXA"
EndSection


I still can't get the accent keys, i don't know what could be wrong

My locales:

LANG=pt_PT.utf8
LC_CTYPE="pt_PT.utf8"
LC_NUMERIC="pt_PT.utf8"
LC_TIME="pt_PT.utf8"
LC_COLLATE=C
LC_MONETARY="pt_PT.utf8"
LC_MESSAGES="pt_PT.utf8"
LC_PAPER="pt_PT.utf8"
LC_NAME="pt_PT.utf8"
LC_ADDRESS="pt_PT.utf8"
LC_TELEPHONE="pt_PT.utf8"
LC_MEASUREMENT="pt_PT.utf8"
LC_IDENTIFICATION="pt_PT.utf8"
LC_ALL=

When i press an accent key, it shouldn't print any character, only when i press the second, example, i get "o" instead ""
 
Old 08-04-2009, 09:20 PM   #19
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
Paste the output of "setxkbmap -print" here.
 
Old 08-06-2009, 03:40 PM   #20
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
bruno@deathstar:~$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+pt(nodeadkeys)+inet(evdev)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc104)" };
};
 
Old 08-07-2009, 02:26 PM   #21
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
PiterPUNK says the "nodeadkeys" is the problem - you don't want that.
 
Old 08-07-2009, 08:12 PM   #22
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
Quote:
Originally Posted by rworkman View Post
PiterPUNK says the "nodeadkeys" is the problem - you don't want that.
How do i set up my setxkbmap without the nodeadkeys ?
 
Old 08-07-2009, 08:31 PM   #23
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
Problem solved removing the nodeadkeys option:

setxkbmap -layout "pt" -variant "basic"

Thanks for everyone that helped me.
 
Old 08-07-2009, 08:44 PM   #24
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
and for the record, I *think* this would be the correct fdi contents:
Code:
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">pt</merge>
      <merge key="input.xkb.variant" type="string">basic</merge>
 
Old 08-08-2009, 10:13 AM   #25
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
Quote:
Originally Posted by rworkman View Post
and for the record, I *think* this would be the correct fdi contents:
Code:
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">pt</merge>
      <merge key="input.xkb.variant" type="string">basic</merge>

Those are the settings i have now, thanks all and happy slacking!
 
Old 08-09-2009, 12:40 PM   #26
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
New update guys, after reboot the keyboard still has the same issues (no accent keys), i can i make the change permanent? I already have

<!-- Edit (as needed) these four lines in the copied fdi file -->
<merge key="input.xkb.rules" type="string">base</merge>
<merge key="input.xkb.model" type="string">evdev</merge>
<merge key="input.xkb.layout" type="string">pt_PT</merge>
<merge key="input.xkb.variant" type="string">basic</merge>

as suggested, but still after each boot i have to type:

setxkbmap -layout "pt" -variant "basic"
 
Old 08-09-2009, 12:58 PM   #27
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
Then something in either kde or xfce is changing your keymap. I found that xfce's xkb plugin would do that if it's being used, but I don't know what part of kde to blame.
 
Old 08-09-2009, 04:14 PM   #28
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
Quote:
Originally Posted by rworkman View Post
Then something in either kde or xfce is changing your keymap. I found that xfce's xkb plugin would do that if it's being used, but I don't know what part of kde to blame.
I disabled the option in KDE to change or assign keyboard layouts, witch module is the one for xfce's xkb plugin? Maybe it's running on my pc..

Last edited by LnxSlck; 08-09-2009 at 04:17 PM.
 
Old 08-09-2009, 05:29 PM   #29
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
It's xfce4-xkb-plugin - it's not included with Slackware, so you don't accidentally have it installed :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugs with recent xorg server jazzor Slackware 1 11-15-2007 04:58 PM
Xorg dual head layout switch without X restart jcerruti Linux - Desktop 2 11-03-2006 09:48 AM
xorg.conf does not control keyboard layout foxy123 Linux - Software 2 07-23-2006 07:39 AM
recent dist-upgrade of xorg has killed my mouse (and thusly, xorg). Lokathor Debian 4 06-10-2006 04:52 AM
Xorg.conf, using en_GB keyboard layout kxHGB Linux - General 5 10-15-2004 03:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration