LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-15-2007, 07:21 PM   #1
rg3
Member
 
Registered: Jul 2007
Distribution: Fedora
Posts: 527

Rep: Reputation: Disabled
Lightbulb Solution to Xorg recent keyboard layout problem


After the recent Xorg upgrades in -current, if you were using a layout other than US you may have noticed it doesn't seem to be working. Removing the xf86-input-evdev package solves the problem, but you may want to have it installed for other devices. The correct solution is to remove the following file:

/usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi

I don't know if someone else did, but I just emailed the solution to PV. He may publish an upgrade to the hal package to fix the problem. In the mean time...

Edit: thread title mistake.
Edit 2: forgot to mention the updates were to -current.

Last edited by rg3; 11-15-2007 at 07:44 PM.
 
Old 11-16-2007, 04:00 AM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Your post prompted to me boot into current and try my keyboard (UK) under X.

It doesn't work correctly (the "none number pad" arrow keys are broken) - and your fix doesn't correct this unfortunately.

I don't boot to 'current' as often as I should for real testing as X is giving me problems anyway - although I do keep it up to date.

Looks like it's another X glitch to add to my list !!


Update - I removed the entire package xf86-input-evdev.tgz and it worked !!
Thanks a lot.

But - what implications will this have in other areas of my system ? Hope this won't break something else.
 
Old 11-16-2007, 06:39 AM   #3
KillerOfGiants
LQ Newbie
 
Registered: Feb 2004
Location: BG
Distribution: Slackware-current
Posts: 29

Rep: Reputation: 15
I've got the same problem.
But removing the xf86-input-evdev
killes my mouse support.It solves the problem though but i do want to use my mouse.
I hope PV release a fix soon.
 
Old 11-16-2007, 10:22 AM   #4
firebird
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 41

Rep: Reputation: 15
I have a Logitech Marble mouse that works nicely under slackware 12.0 with
mouse wheel emulation. My xorg.conf looks like this:
http://gentoo-wiki.com/HOWTO_Advance...h_Marble_Mouse

However, mouse wheel emulation stops working after I updated to -current.
I found mouse buttons are reported as 1,3,4,5 in xev. They were reported
as 1,3,8,9 previously.

Anyway, the problem is fixed after I removed xf86-input-evdev, mouse
wheel emulation works again. I'll check "10-x11-input.fdi" later.

Thank you very much, rg3, your suggestion are really helpful!
 
Old 11-16-2007, 10:37 AM   #5
firebird
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 41

Rep: Reputation: 15
I just confirmed that removing the following file (as suggested by rg3) can
also fix the mouse wheel emulation problem with my Logitech Marbel mouse:
/usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi

I re-installed "xf86-input-evdev" and removed the above file (of hal package),
mouse wheel emulation also works as expected.

Thanks again, rg3!
 
Old 11-16-2007, 02:24 PM   #6
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
Removing the fdi file just might cause more problems - in my case, the keyboard accepts *no* input at all. Refer to my post in this thread for what I think is a better fix at the moment: http://www.linuxquestions.org/questi...effect-599819/
 
Old 11-16-2007, 02:48 PM   #7
rg3
Member
 
Registered: Jul 2007
Distribution: Fedora
Posts: 527

Original Poster
Rep: Reputation: Disabled
Thanks for the info, rworkman!

So the status is that if you are using a non US layout you can remove the .fdi file, restart hal and it will work, but if you use a US layout it stops working completely? :|

It's a shitty situation. You either blacklist evdev or remove the xf86-input-evdev package (and everything that depends on evdev stops working) or you remove that file and more problems may appear...

In my case removing the file and restarting hal solved all the problems, I think... :S

Last edited by rg3; 11-16-2007 at 02:50 PM.
 
Old 11-17-2007, 04:20 AM   #8
rg3
Member
 
Registered: Jul 2007
Distribution: Fedora
Posts: 527

Original Poster
Rep: Reputation: Disabled
PV has released a fix disabling input hotplugging in X. I haven't tested the new packages yet, but I suppose all inconveniences should be fixed.
 
Old 11-18-2007, 08:48 AM   #9
firebird
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 41

Rep: Reputation: 15
I've already tested the latest -current fix for some time, it solved
the problem with my Legitech Marble mouse. Mouse wheel emulation and
button remapping now workes as expected.
 
Old 07-27-2009, 06:05 AM   #10
LnxSlck
Member
 
Registered: Mar 2005
Location: Portugal
Distribution: Slackware, Fedora
Posts: 38

Rep: Reputation: 2
Hello guys

Some update, i'm running -current and i use a pt (portugal) keyboard layout, i removed /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi
and guess what? No keyboard input at all, no mouse, now how will i get into my machine? Boot dvd and chroot?
Is there a fix to this keyboard layout thing? I've tried copy the fdi file /etc/hal/fdi/policy/ and still nothing... I don't know if i must remove evdev or make hal detect my keyboard layout.

Any ideas?
 
Old 07-27-2009, 06:26 AM   #11
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,051

Rep: Reputation: Disabled
this thread is about a specific problem of slackware current in november 2007, nearly two years ago, it surely isn't related to your problem.
to recover you probably have to reinstall hal package for your slackware version (get it first).
Code:
upgradepkg --reinstall hal-*.tgz
to have portugal keyboard layout you probably only have to add
Code:
Option     "XkbLayout" "pt"
to the inputdevice keyboard section of your /etc/X11/xorg.conf

Last edited by ponce; 07-27-2009 at 10:39 AM.
 
Old 07-27-2009, 11:41 AM   #12
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
LnxSlk: as poncez stated, this thread is a bit old for present-day -current problems.

Input devices should still work at a console.

Also, removing that fdi file is not the correct approach. Sooner or later, we'll get a new hal package into the tree, and this (or something similar) will be the contents of that fdi file:
http://connie.slackware.com/~rworkman/10-keymap.fdi.txt

Last edited by rworkman; 07-27-2009 at 11:42 AM.
 
Old 07-27-2009, 11:47 AM   #13
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,051

Rep: Reputation: Disabled
tnx robby for clarifing the hal thing, I missed that change
 
Old 07-27-2009, 03:02 PM   #14
byzkarl
LQ Newbie
 
Registered: Jul 2009
Distribution: Slackware, Ubuntu
Posts: 20

Rep: Reputation: 3
Hi.

I had Slackware -current clobber my dvorak layout in xorg.conf. I was able to solve it by editing the fdi file as noted here:

http://blog.jardinmagique.info/2009/...with-xorg.html

Perhaps there could be someway to make hal check the xorg.conf before it decides to make the us qwerty layout the default?
 
Old 07-27-2009, 07:01 PM   #15
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,543

Rep: Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206Reputation: 1206
@byzkarl: That's basically what I've got in the link above (on connie), and as I stated earlier, something like that will be in 13.0.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugs with recent xorg server jazzor Slackware 1 11-15-2007 04:58 PM
Xorg dual head layout switch without X restart jcerruti Linux - Desktop 2 11-03-2006 09:48 AM
xorg.conf does not control keyboard layout foxy123 Linux - Software 2 07-23-2006 07:39 AM
recent dist-upgrade of xorg has killed my mouse (and thusly, xorg). Lokathor Debian 4 06-10-2006 04:52 AM
Xorg.conf, using en_GB keyboard layout kxHGB Linux - General 5 10-15-2004 03:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration