LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Solution to Xorg recent keyboard layout problem (https://www.linuxquestions.org/questions/slackware-14/solution-to-xorg-recent-keyboard-layout-problem-599976/)

rg3 11-15-2007 07:21 PM

Solution to Xorg recent keyboard layout problem
 
After the recent Xorg upgrades in -current, if you were using a layout other than US you may have noticed it doesn't seem to be working. Removing the xf86-input-evdev package solves the problem, but you may want to have it installed for other devices. The correct solution is to remove the following file:

/usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi

I don't know if someone else did, but I just emailed the solution to PV. He may publish an upgrade to the hal package to fix the problem. In the mean time...

Edit: thread title mistake.
Edit 2: forgot to mention the updates were to -current.

bgeddy 11-16-2007 04:00 AM

Your post prompted to me boot into current and try my keyboard (UK) under X.

It doesn't work correctly (the "none number pad" arrow keys are broken) - and your fix doesn't correct this unfortunately.

I don't boot to 'current' as often as I should for real testing as X is giving me problems anyway - although I do keep it up to date.

Looks like it's another X glitch to add to my list !!


Update - I removed the entire package xf86-input-evdev.tgz and it worked !!
Thanks a lot.

But - what implications will this have in other areas of my system ? Hope this won't break something else.

KillerOfGiants 11-16-2007 06:39 AM

I've got the same problem.
But removing the xf86-input-evdev
killes my mouse support:(.It solves the problem though but i do want to use my mouse.
I hope PV release a fix soon.

firebird 11-16-2007 10:22 AM

I have a Logitech Marble mouse that works nicely under slackware 12.0 with
mouse wheel emulation. My xorg.conf looks like this:
http://gentoo-wiki.com/HOWTO_Advance...h_Marble_Mouse

However, mouse wheel emulation stops working after I updated to -current.
I found mouse buttons are reported as 1,3,4,5 in xev. They were reported
as 1,3,8,9 previously.

Anyway, the problem is fixed after I removed xf86-input-evdev, mouse
wheel emulation works again. I'll check "10-x11-input.fdi" later.

Thank you very much, rg3, your suggestion are really helpful!

firebird 11-16-2007 10:37 AM

I just confirmed that removing the following file (as suggested by rg3) can
also fix the mouse wheel emulation problem with my Logitech Marbel mouse:
/usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi

I re-installed "xf86-input-evdev" and removed the above file (of hal package),
mouse wheel emulation also works as expected.

Thanks again, rg3!

rworkman 11-16-2007 02:24 PM

Removing the fdi file just might cause more problems - in my case, the keyboard accepts *no* input at all. Refer to my post in this thread for what I think is a better fix at the moment: http://www.linuxquestions.org/questi...effect-599819/

rg3 11-16-2007 02:48 PM

Thanks for the info, rworkman!

So the status is that if you are using a non US layout you can remove the .fdi file, restart hal and it will work, but if you use a US layout it stops working completely? :|

It's a shitty situation. You either blacklist evdev or remove the xf86-input-evdev package (and everything that depends on evdev stops working) or you remove that file and more problems may appear...

In my case removing the file and restarting hal solved all the problems, I think... :S

rg3 11-17-2007 04:20 AM

PV has released a fix disabling input hotplugging in X. I haven't tested the new packages yet, but I suppose all inconveniences should be fixed.

firebird 11-18-2007 08:48 AM

I've already tested the latest -current fix for some time, it solved
the problem with my Legitech Marble mouse. Mouse wheel emulation and
button remapping now workes as expected.

LnxSlck 07-27-2009 06:05 AM

Hello guys

Some update, i'm running -current and i use a pt (portugal) keyboard layout, i removed /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi
and guess what? No keyboard input at all, no mouse, now how will i get into my machine? Boot dvd and chroot?
Is there a fix to this keyboard layout thing? I've tried copy the fdi file /etc/hal/fdi/policy/ and still nothing... I don't know if i must remove evdev or make hal detect my keyboard layout.

Any ideas?

ponce 07-27-2009 06:26 AM

this thread is about a specific problem of slackware current in november 2007, nearly two years ago, it surely isn't related to your problem.
to recover you probably have to reinstall hal package for your slackware version (get it first).
Code:

upgradepkg --reinstall hal-*.tgz
to have portugal keyboard layout you probably only have to add
Code:

Option    "XkbLayout" "pt"
to the inputdevice keyboard section of your /etc/X11/xorg.conf

rworkman 07-27-2009 11:41 AM

LnxSlk: as poncez stated, this thread is a bit old for present-day -current problems.

Input devices should still work at a console.

Also, removing that fdi file is not the correct approach. Sooner or later, we'll get a new hal package into the tree, and this (or something similar) will be the contents of that fdi file:
http://connie.slackware.com/~rworkman/10-keymap.fdi.txt

ponce 07-27-2009 11:47 AM

tnx robby for clarifing the hal thing, I missed that change :)

byzkarl 07-27-2009 03:02 PM

Hi.

I had Slackware -current clobber my dvorak layout in xorg.conf. I was able to solve it by editing the fdi file as noted here:

http://blog.jardinmagique.info/2009/...with-xorg.html

Perhaps there could be someway to make hal check the xorg.conf before it decides to make the us qwerty layout the default?

rworkman 07-27-2009 07:01 PM

@byzkarl: That's basically what I've got in the link above (on connie), and as I stated earlier, something like that will be in 13.0.


All times are GMT -5. The time now is 12:00 AM.