LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-18-2004, 06:23 AM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
smtp <> squirrelmail


Lo all, and happy St. Patrik's day btw =]

I'm having problems with Squirrelmail. After installing it, it asks for a username/password, which i have no idea about. Also, it says that uid/pass is the one(s) i use for my smtp protocol.

I'm not quite sure if i have a uid/pass there, or how to check.. I have Slack 9.1 (current) installed, and out of the box, my email server worked. All i did is update my DNS settings, and use pine as a client.

So i'm not sure if i'm confusing A with B, or if i have to configure something for smtp, or .. .well lets just say im confused here

I was wondering if anyone solved this problem, or has any idea on what i should be looking on, and where i should be looking at.

Thanks
-- A Happy Guinness 'n Marmite lovin' user.
 
Old 03-18-2004, 10:08 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 269Reputation: 269Reputation: 269
Re: smtp <> squirrelmail

Quote:
Originally posted by xushi
I'm having problems with Squirrelmail. After installing it, it asks for a username/password, which i have no idea about. Also, it says that uid/pass is the one(s) i use for my smtp protocol.
Okay a few things to check before proceeding:

Do you have these installed and currently running/working:

1. MTA, example: Sendmail, Postfix, qmail, etc?
2. IMAPD


Also when it asks for you username and password, that is a username and password of a given user on your system, except root. It won't allow root to login for security reasons which totally makes sense.

When you create a user on your system, they automatically should be setup to get mail, either locally or thru the MTA your running and configured properly for your particular domain and email server.

And sending you should really require no authentication unless you specified this in your configuration for your mail server.

Let us know..
 
Old 03-18-2004, 02:10 PM   #3
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Yes, i have the latest of both Sendmail, and IMAPD installed. I can send mail directly from sendmail, as well as pine.

I reconfigured Squirrelmail carefully reading the docs, and finally im one step closer.. Now it gives me an error saying, Error connecting to IMAP server: localhost.
111 : Connection refused.

I have port 143 open, however i can't telnet into it as other's recommended me to do so.
 
Old 03-18-2004, 03:33 PM   #4
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
A few extra things i might mention,

In SquirrelMail's config's general setting, i have assigned the method used for sending messages to 1. Sendmail (as opposed to the other choice, SMTP)

when i check my proccesses, i have sendmail running. As for imapd, it doesn't seem like it is. And when i type
imapd
it gives me a message

* OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS STARTTLS AUTH=LOGIN] xushi.co.uk IMAP4rev1 2003.339 at Thu, 18 Mar 2004 09:44:55 +0000 (GMT)

*Bad Null Cimmand.

This is most probably due to me being new to all this.. I don't know what im doing or not doing to be honest, and any suggestions will be very helpful.

Danka
 
Old 03-18-2004, 04:56 PM   #5
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
BAAAAAAAAH.....
ffs its always them really small things that hold you back...
Solved the problem..

imap wasn't running, all i had to do was
pico /etc/inetd.conf
and uncomment 2 lines
pop3 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/popa3d
imap2 stream tcp nowait root /usr/sbin/tcpd imapd
 
Old 04-01-2004, 03:49 PM   #6
dolay
LQ Newbie
 
Registered: Mar 2004
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by xushi
BAAAAAAAAH.....
ffs its always them really small things that hold you back...
Solved the problem..

imap wasn't running, all i had to do was
pico /etc/inetd.conf
and uncomment 2 lines
pop3 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/popa3d
imap2 stream tcp nowait root /usr/sbin/tcpd imapd
wOULD SOMEONE TOLD HOW TO UNCOMMENT VIA SHH?
I dont have any idea about that comment , i enter "pico /etc/inetd.conf" but then?
step by step?
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squirrelmail smtp authentication question craven Linux - Software 1 01-28-2013 11:43 PM
SMTP "open relay" and SMTP AUTH aikempshall Linux - Security 3 10-11-2006 08:19 AM
Squirrelmail help Child of Wonder Linux - Networking 8 01-11-2006 08:14 PM
Postfis SMTP forwarding and Incoming SMTP pheasand Linux - Software 0 04-27-2005 05:32 PM
SMTP and KMail and SMTP and Netscape Mail jazz... Linux - Newbie 5 10-11-2003 03:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration