LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-10-2019, 07:53 PM   #1
upnort
Senior Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 1,111

Rep: Reputation: Disabled
SMPlayer 19.5 Broken?


Anybody here using SMPlayer? For a few weeks now I am unable to watch youtube videos. A fresh profile does not help.

I suspect the built-in youtube-dl code. I can use the most recent version of youtube-dl to fetch the video and then SMPlayer plays the downloaded video.

Not yet looking for alternatives. Just want to know if others can play youtube videos with SMPlayer. The SMPlayer logs have not helped me, but I might be missing something obvious.

Thanks.

Slackware 64-bit 14.2, SMPlayer 19.5, MPlayer 1.2.1-5.3.0, youtube-dl 2019.09.01, mpv 0.26
 
Old 09-11-2019, 01:40 AM   #2
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 174

Rep: Reputation: 112Reputation: 112
Never tried using SMplayer for this previously (usually watch youtube videos in the browser) but couldn't resist investigate. Picked a youtube URL (https://www.youtube.com/watch?v=zAGVQLHvwOY), opened SMPlayer, Open > URL > OK, and the video started and ran just fine here.
Slackware64v-current, SMPlayer 19.5.0, MPlayer-20190717-9.1.0, youtube-dl-2019.09.01, no mpv package.
Different mplayer version (mine is from the official -current repo). Could that be the reason? Maybe you could try building a new mplayer from the latest source file version (1.4)?
 
Old 09-12-2019, 05:40 PM   #3
upnort
Senior Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 1,111

Original Poster
Rep: Reputation: Disabled
I looked into this again today. I am utterly clueless. I tried rebuilding libass and mplayer, tried newer versions, installed a newer version of mpv. If I start with a fresh smplayer profile, sometimes I can play yt videos, but then I can't play anything from the TV capture card. smplayer seems to default to mpv if installed, and that seems to play yt videos but not the capture card. mplayer will play from the capture card but won't play yt videos.

I don't know. Just classic WTF.
 
Old 09-12-2019, 05:59 PM   #4
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 1,808
Blog Entries: 3

Rep: Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898Reputation: 1898
upnort, everything I'm using is the same version as yours and it works. I can stream Youtube videos. You did install smtube, didn't you?

The only annoying thing is when it brings up the search option it forces me to use "Tonvid.com", which is crap. I can't search in it, only select videos. Mind you, I got a chance to watch the new Bille Ellish video. Looks like Satanism is making a comeback.
 
Old 09-12-2019, 08:22 PM   #5
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,230

Rep: Reputation: 390Reputation: 390Reputation: 390Reputation: 390
Quote:
Originally Posted by Lysander666 View Post
upnort, everything I'm using is the same version as yours and it works. I can stream Youtube videos. You did install smtube, didn't you?

The only annoying thing is when it brings up the search option it forces me to use "Tonvid.com", which is crap. I can't search in it, only select videos. Mind you, I got a chance to watch the new Bille Ellish video. Looks like Satanism is making a comeback.
I never install smtube, and videos are ok here.
 
Old 09-12-2019, 08:25 PM   #6
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,745

Rep: Reputation: Disabled
I'm not sure this is related, but you should grab a newer youtube-dl version.

https://github.com/ytdl-org/youtube-dl/issues/22367
 
Old 09-12-2019, 09:51 PM   #7
upnort
Senior Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 1,111

Original Poster
Rep: Reputation: Disabled
Thank you for the replies. This has me baffled.

I have smtube installed but rarely use. Typically I use smplayer when wanting to view a video from a web page link

I had youtube-dl 2019-09-01 installed but updated to 2019-09-12.

I restored all previous packages. I removed the mpv package to avoid any confusion with the backend smplayer should use.

I see this in the smplayer log:

Code:
MplayerProcess::parseLine: 'libavformat version 56.40.101 (internal)'
MplayerProcess::parseLine: 'Failed to open https://blahblah
Sometimes I also see this, but I think the message might be a red herring:

Code:
mplayer could not connect to socket
I could be missing something obvious, but smplayer simply no longer downloads. I can download manually and smplayer plays the local video with no hiccups.

Edit: I tried directly streaming a yt video with mpv. I see the same breakage. Just won't download. Yet youtube-dl works fine and mpv uses youtube-dl.

Last edited by upnort; 09-12-2019 at 11:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
smplayer not installed afaheem1988 Linux - Newbie 1 08-03-2008 08:38 AM
LXer: SMPlayer Review - One of the Most Powerful Video Players for Linux LXer Syndicated Linux News 0 07-01-2008 01:21 AM
smplayer 0.5.62 not installing rohanak Linux - Software 2 11-25-2007 09:39 AM
Smplayer Icons&Themes raylhm SUSE / openSUSE 0 08-29-2007 04:25 PM
LXer: SMPlayer - Nice Frontend for MPlayer LXer Syndicated Linux News 0 06-14-2007 01:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration