-   Slackware (
-   -   smokeping on slackware (

dh2k 06-15-2013 07:33 PM

smokeping on slackware
Hi forum,

I am creeping slowly into dependency hell with slack' trying to install smokeping.

it looks horribly like I may be forced to use another dist (Ubuntu?) so I can set up a smokeping server and a cgi web interface - any experience/help in getting slackware to support this is appreciated.

I have tried cpan to get modules installed too, to no avail.

Also smokeping homepage

checking checking for gnu make availablility... /usr/bin/gmake is GNU make
checking checking for perl module 'RRDs'... Ok
checking checking for perl module 'FCGI'... Failed
checking checking for perl module 'CGI'... Ok
checking checking for perl module 'CGI::Fast'... Failed
checking checking for perl module 'Config::Grammar'... Failed
checking checking for perl module 'Digest::HMAC_MD5'... Failed
checking checking for perl module 'LWP'... Ok

** Aborting Configure ******************************

  If you know where perl can find the missing modules, set
  the PERL5LIB environment variable accordingly.

  FIRST though, make sure that 'perl' starts the perl
  binary you want to use for SmokePing.

  Now you can install local copies of the missing modules
  by running

    ./setup/ /opt/smokeping/thirdparty

  The RRDs perl module is part of RRDtool. Either use the rrdtool
  package provided by your OS or install rrdtool from source.
  If you install from source, the RRDs module is located


Ser Olmy 06-16-2013 03:01 AM

This is not really a Slackware dependency; it's a Perl modules issue.

Installing the necessary Perl modules with CPAN should work:

~# perl -MCPAN -e shell
Run the above command as root. If you've never used CPAN before, you'll be guided through some configuration steps. The defaults should be fine. One you're done, use the install command to download and install the missing modules:

install FCGI
install CGI::Fast
install Config::Grammer
install Digest::HMAC_MD5

The above was tested and found to work on Slackware 14.0.

As for RRDTool, the main site is here. It's a (relatively) simple matter of downloading the source and running ./configure && make && make install. This should work (again, you will need to be root to perform the final install step):

cd /usr/src
wget -q -O - | tar xzv
cd rrdtool-1.4.8
./configure --prefix=/usr --sysconfdir=/etc && make && make install

(As RRDTool can be considered a shared component, I usually install directly to /usr. A good argument can be made for installing to /usr/local instead, in order to separate it from "native" Slackware components. Others prefer to create a subdirectory under /opt. In any case, just change the --prefix parameter to point to your directory of choice.)

Celyr 06-16-2013 08:59 AM

There is a slackbuild for rrdtool, also you can use sbopkg if you like.

dh2k 06-16-2013 09:12 AM

Thanks for the explain' RE: the difference of dependencies and perl modules. I have built and installed smokeping and now config'ing. Will mark as solved once I have cgi up and tested. Thanks.

dh2k 06-18-2013 08:55 AM

I have config'ed using smokeping homepage guide, then several others via google search etc;

I am getting a 403 forbidden when trying to browse to the url I have added to the apache alias (in this instance,

Any experience on this forum? - searches yield distribution specific threads on other forums but do not work when followed???

even as (web browser) root it fails with 403 forbidden?

Ser Olmy 06-18-2013 09:10 AM

The user starting the web browser is not relevant, as the HTTP request is not authenticated.

The web browser contacts the web server (apache), which in turn tries to access and serve the files from the relevant directory. Apache on Slackware runs as the "apache" user. Does this user have access to the Smokeping files?

dh2k 06-18-2013 10:30 AM

I have 'chown -R apache.apache /path/to/smokeping/data'
and 'chown -R apache.apache /opt/smokeping/'

restarted servers/daemons but still getting the 403

ponce 06-18-2013 12:19 PM

Is smokeping (I have never used it) a perl script using apache's mod_perl?
If yes, the latest mod_perl isn't compatible yet with httpd-2.4.x in slackware >= 14.0, supposing you're using that (we talked a little about it here in the forum), so you have to rebuild yourself httpd-2.2.x and then mod_perl.

dh2k 06-19-2013 11:20 AM

smokeping uses (fast)CGI (smokeping_cgi)for its' (SmokePing) webfrontend.

I'm following the config docs closely but I just cannot begin to understand why I am still getting the 403.

Has anyone manage to config and use smokeping on slack'?

dh2k 09-19-2013 03:41 AM

I have smokeping working; when I make time for it, I will post a quick reference guide, update to follow!

slacktroll 09-23-2014 09:14 AM

fix this -> LoadModule cgi_module lib/httpd/modules/

Alias /smokeping /opt/smokeping-2.6.9/htdocs
<Directory /opt/smokeping-2.6.9/htdocs>
Require all granted
AllowOverride none
Options Indexes FollowSymLinks ExecCGI
AddHandler cgi-script .cgi .fcgi
DirectoryIndex index.html smokeping.fcgi

chown -R apache /opt/smokeping-2.6.9/*

All times are GMT -5. The time now is 06:43 AM.