-   Slackware (
-   -   smbtree Segmentation Fault (Slackware64-Current) (

Jack128 04-03-2010 01:16 PM

smbtree Segmentation Fault (Slackware64-Current)

I run Slackware64-current, and I've tried the samba tools.
The daemon is running fine, everything works. (Tested with
ldap and sharing) Now I wanted to run smbtree, there I got
an Segmentation Fault.

Here is my smb.conf:

workgroup = NETZWERK
restrict anonymous = no
domain master = no
server signing = Auto
security = share
client ntlmv2 auth = no
netbios name = Jack
server string = Jack

And here is the error log of smbtree:

# smbtree
Enter root's password:
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
Segmentation Fault

Ps: I tried the "Server requested LANMAN password"-fix

Thanks for any help in advance.
Best Regards,

allend 04-04-2010 04:56 AM

My first comment is that share level security is best avoided. You are much better off using user level security.
If you create a user in Samba with client lanman auth disabled ( which is the default) then the LanMan hashes are not created in the password backend.
If you enable the client lanman auth, then you will need to delete and recreate the user so that the LanMan hashes are added to the password backend.
I also suggest that you do not turn off the ntlmv2 authorisation. Samba tries these hashes first, then falls back to trying the LanMan hashes if you have this enabled.
Are you sure that you need the LanMan hashes? They are only required for Windows98 or earlier as well as some old NAS devices.

All times are GMT -5. The time now is 11:48 AM.