LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-22-2004, 09:16 AM   #1
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
Cool small help for kernel 2.6.7


hello

i have just install kernel 2.6.7 from slackware testing cd2


follow instruction from read me and give

mkinitrd -c -k 2.6.7 -m reiserfs

everything oky but how can i add the vfat option i can't mount vfat now
 
Old 09-22-2004, 09:34 AM   #2
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
modprobe vfat

then try and mount it
 
Old 09-22-2004, 11:02 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
I don't mean to butt-in, but would that mean that you didn't
install kernel-modules-2.6.7-i486-2.tgz? If I'm not mistaken,
that kernel includes the support for vfat.
 
Old 09-22-2004, 11:08 PM   #4
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Original Poster
Rep: Reputation: 30
yes i have install

kernel-modules-2.6.7-i486-2.tgz

but i have give only

"mkinitrd -c -k 2.6.7 -m reiserfs" command


from read me
------------------------------------------------------------------------------------
Here's another example: Build an initrd image using Linux 2.6.7 kernel
modules for a system with an ext3 root partition on /dev/hdb3. Note
that you need both the jbd and ext3 modules to use ext3:

mkinitrd -c -k 2.6.7 -m jbd:ext3 -f ext3 -r /dev/hdb3
-----------------------------------------------------------------------------------

So what about vfat


no the modprobe vfat
is not enable vfat

but i really like the 2.6.7 fast seems to me
 
Old 09-22-2004, 11:25 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
Look in your kernel config file and see what you have here:

Code:
mingdao@james:~$ cat /usr/src/linux-2.6.7/.config | less
<snip, snip>
#
# DOS/FAT/NT Filesystems
#
CONFIG_FAT_FS=m
CONFIG_MSDOS_FS=m
CONFIG_VFAT_FS=m
CONFIG_NTFS_FS=m
# CONFIG_NTFS_DEBUG is not set
# CONFIG_NTFS_RW is not set
Before I issue "modprobe vfat" as root I see no vfat module:
Code:
root@james:/home/mingdao# lsmod   <-- (this stands for list modules)
Module                  Size  Used by
snd_pcm_oss            49064  0
snd_mixer_oss          17344  1 snd_pcm_oss
uhci_hcd               28944  0
ehci_hcd               24900  0
usbcore                98400  4 uhci_hcd,ehci_hcd
snd_via82xx            22596  1
snd_pcm                82376  3 snd_pcm_oss,snd_via82xx
snd_timer              21060  1 snd_pcm
snd_ac97_codec         65092  1 snd_via82xx
snd_page_alloc          8968  2 snd_via82xx,snd_pcm
snd_mpu401_uart         6144  1 snd_via82xx
snd_rawmidi            20324  1 snd_mpu401_uart
snd_seq_device          6536  1 snd_rawmidi
snd                    44068  10 snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7392  1 snd
nvidia               4817268  12
After I issue "modprobe vfat" as root I see the vfat module:
Code:
root@james:/home/mingdao# modprobe vfat
root@james:/home/mingdao# lsmod
Module                  Size  Used by
vfat                   11840  0     <-- there's the module you need
fat                    39744  1 vfat
snd_pcm_oss            49064  0
snd_mixer_oss          17344  1 snd_pcm_oss
uhci_hcd               28944  0
ehci_hcd               24900  0
usbcore                98400  4 uhci_hcd,ehci_hcd
snd_via82xx            22596  0
snd_pcm                82376  2 snd_pcm_oss,snd_via82xx
snd_timer              21060  1 snd_pcm
snd_ac97_codec         65092  1 snd_via82xx
snd_page_alloc          8968  2 snd_via82xx,snd_pcm
snd_mpu401_uart         6144  1 snd_via82xx
snd_rawmidi            20324  1 snd_mpu401_uart
snd_seq_device          6536  1 snd_rawmidi
snd                    44068  9 snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7392  1 snd
nvidia               4817268  12
 
Old 09-22-2004, 11:48 PM   #6
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Original Poster
Rep: Reputation: 30
ya it is working

the problem i was trying to give "mount /mnt/drives/c" it is in fstab so i usually use it

when i give "mount -t vfat /dev/hda5 /mnt/drives/c" then it mount

but i cant mount drives by click on th HDD i con in my deksptop

root@localhost:/home/salahuddin# mount /mnt/drives/c/
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems


heres my fstab (the /dev/hda5 resierfs mount normaly by the "mount /mnt/drives/lin" & also by clicking the HDD icon it is my back up dir)
--------------------------------------------------------------------------------
/dev/hda6 swap swap defaults 0 0
/dev/hda7 / reiserfs defaults 1 1
/dev/hda5 /mnt/drives/lin auto noauto,users 0 0
/dev/hda1 /mnt/drives/c vfat noauto,users,unmask=022 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,users 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0



thanx
 
Old 09-23-2004, 01:25 AM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
You should always post what you did that didn't work. And we
should have asked you, "How are you trying to mount the vfat
partition?"

From this line in your /etc/fstab entry ->
/dev/hda1 /mnt/drives/c vfat noauto,users,unmask=022 0 0
you should be able to mount that drive as a normal user. Issue
salahuddin@localhost:~$ mount /mnt/drives/c/
and see what happens. Also, you have users, but you left out
rw (read/write) or ro (read only) from the expression.

Have a look at how mine is setup on my dual boot comp:
Code:
/dev/hda5        swap             swap        defaults         0   0
/dev/hdc6        /                reiserfs    defaults         1   1
/dev/hdc1        /boot            reiserfs    defaults         1   2
/dev/hdc2        /home            reiserfs    defaults         1   2
/dev/hdc3        /usr             reiserfs    defaults         1   2
/dev/hdc5        /var             reiserfs    defaults         1   2
/dev/hdc7        /tmp             reiserfs    defaults         1   2
/dev/hdc8        /distro          reiserfs    defaults         1   2
/dev/hda1        /XP              ntfs        user,umask=1000,ro,auto      1   0
/dev/hda2        /PROGRAMS        ntfs        user,umask=1000,ro,auto      1   0
/dev/hda3        /DATA            vfat        user,umask=1000,rw,auto      1   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
###added these for usb devices
/dev/sda1        /mnt/sda1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdb1        /mnt/sdb1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdc1        /mnt/sdc1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdd1        /mnt/sdd1        vfat        user,umask=1000,rw,noauto 0 0
###added these for CD-RW & DVD+-RW
/dev/scd0        /mnt/cdrw        iso9660     user,umask=1000,rw,noauto 0 0
/dev/scd1        /mnt/dvd         iso9660     user,umask=1000,rw,noauto 0 0
All drives mount as user, and all are read/write except the NTFS drives. And
the hard drives are automounting. Just a suggestion of another method.

Edit: I don't know about icons on the desktop. Try right-clicking on them and
changing their properties.

Last edited by Bruce Hill; 09-23-2004 at 01:27 AM.
 
Old 09-23-2004, 01:25 AM   #8
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Original Poster
Rep: Reputation: 30
all prob solved after remove the unmask=022 option from fstab
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A small kernel error synapse Slackware 4 05-27-2004 03:10 PM
old pc, new kernel; small problem b0uncer Linux - General 3 04-24-2004 12:19 PM
small errors in kernel code (2.4.22) Robert0380 Linux - General 2 10-06-2003 09:15 AM
small problems with kernel wlfdgcrkz Linux - Software 4 06-06-2003 02:39 PM
can't get a small kernel muyo76 Linux - General 21 03-14-2003 09:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration