LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   small help for kernel 2.6.7 (https://www.linuxquestions.org/questions/slackware-14/small-help-for-kernel-2-6-7-a-233828/)

salahuddin_66 09-22-2004 10:16 AM

small help for kernel 2.6.7
 
hello

i have just install kernel 2.6.7 from slackware testing cd2


follow instruction from read me and give

mkinitrd -c -k 2.6.7 -m reiserfs

everything oky but how can i add the vfat option i can't mount vfat now

lupin_the_3rd 09-22-2004 10:34 AM

modprobe vfat

then try and mount it

Bruce Hill 09-22-2004 12:02 PM

I don't mean to butt-in, but would that mean that you didn't
install kernel-modules-2.6.7-i486-2.tgz? If I'm not mistaken,
that kernel includes the support for vfat.

salahuddin_66 09-23-2004 12:08 AM

yes i have install

kernel-modules-2.6.7-i486-2.tgz

but i have give only

"mkinitrd -c -k 2.6.7 -m reiserfs" command


from read me
------------------------------------------------------------------------------------
Here's another example: Build an initrd image using Linux 2.6.7 kernel
modules for a system with an ext3 root partition on /dev/hdb3. Note
that you need both the jbd and ext3 modules to use ext3:

mkinitrd -c -k 2.6.7 -m jbd:ext3 -f ext3 -r /dev/hdb3
-----------------------------------------------------------------------------------

So what about vfat


no the modprobe vfat
is not enable vfat :(

but i really like the 2.6.7 fast seems to me

Bruce Hill 09-23-2004 12:25 AM

Look in your kernel config file and see what you have here:

Code:

mingdao@james:~$ cat /usr/src/linux-2.6.7/.config | less
<snip, snip>
#
# DOS/FAT/NT Filesystems
#
CONFIG_FAT_FS=m
CONFIG_MSDOS_FS=m
CONFIG_VFAT_FS=m
CONFIG_NTFS_FS=m
# CONFIG_NTFS_DEBUG is not set
# CONFIG_NTFS_RW is not set

Before I issue "modprobe vfat" as root I see no vfat module:
Code:

root@james:/home/mingdao# lsmod  <-- (this stands for list modules)
Module                  Size  Used by
snd_pcm_oss            49064  0
snd_mixer_oss          17344  1 snd_pcm_oss
uhci_hcd              28944  0
ehci_hcd              24900  0
usbcore                98400  4 uhci_hcd,ehci_hcd
snd_via82xx            22596  1
snd_pcm                82376  3 snd_pcm_oss,snd_via82xx
snd_timer              21060  1 snd_pcm
snd_ac97_codec        65092  1 snd_via82xx
snd_page_alloc          8968  2 snd_via82xx,snd_pcm
snd_mpu401_uart        6144  1 snd_via82xx
snd_rawmidi            20324  1 snd_mpu401_uart
snd_seq_device          6536  1 snd_rawmidi
snd                    44068  10 snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              7392  1 snd
nvidia              4817268  12

After I issue "modprobe vfat" as root I see the vfat module:
Code:

root@james:/home/mingdao# modprobe vfat
root@james:/home/mingdao# lsmod
Module                  Size  Used by
vfat                  11840  0    <-- there's the module you need
fat                    39744  1 vfat
snd_pcm_oss            49064  0
snd_mixer_oss          17344  1 snd_pcm_oss
uhci_hcd              28944  0
ehci_hcd              24900  0
usbcore                98400  4 uhci_hcd,ehci_hcd
snd_via82xx            22596  0
snd_pcm                82376  2 snd_pcm_oss,snd_via82xx
snd_timer              21060  1 snd_pcm
snd_ac97_codec        65092  1 snd_via82xx
snd_page_alloc          8968  2 snd_via82xx,snd_pcm
snd_mpu401_uart        6144  1 snd_via82xx
snd_rawmidi            20324  1 snd_mpu401_uart
snd_seq_device          6536  1 snd_rawmidi
snd                    44068  9 snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              7392  1 snd
nvidia              4817268  12


salahuddin_66 09-23-2004 12:48 AM

ya it is working :)

the problem i was trying to give "mount /mnt/drives/c" it is in fstab so i usually use it

when i give "mount -t vfat /dev/hda5 /mnt/drives/c" then it mount

but i cant mount drives by click on th HDD i con in my deksptop

root@localhost:/home/salahuddin# mount /mnt/drives/c/
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems


heres my fstab (the /dev/hda5 resierfs mount normaly by the "mount /mnt/drives/lin" & also by clicking the HDD icon it is my back up dir)
--------------------------------------------------------------------------------
/dev/hda6 swap swap defaults 0 0
/dev/hda7 / reiserfs defaults 1 1
/dev/hda5 /mnt/drives/lin auto noauto,users 0 0
/dev/hda1 /mnt/drives/c vfat noauto,users,unmask=022 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,users 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0



thanx

Bruce Hill 09-23-2004 02:25 AM

You should always post what you did that didn't work. And we
should have asked you, "How are you trying to mount the vfat
partition?"

From this line in your /etc/fstab entry ->
/dev/hda1 /mnt/drives/c vfat noauto,users,unmask=022 0 0
you should be able to mount that drive as a normal user. Issue
salahuddin@localhost:~$ mount /mnt/drives/c/
and see what happens. Also, you have users, but you left out
rw (read/write) or ro (read only) from the expression.

Have a look at how mine is setup on my dual boot comp:
Code:

/dev/hda5        swap            swap        defaults        0  0
/dev/hdc6        /                reiserfs    defaults        1  1
/dev/hdc1        /boot            reiserfs    defaults        1  2
/dev/hdc2        /home            reiserfs    defaults        1  2
/dev/hdc3        /usr            reiserfs    defaults        1  2
/dev/hdc5        /var            reiserfs    defaults        1  2
/dev/hdc7        /tmp            reiserfs    defaults        1  2
/dev/hdc8        /distro          reiserfs    defaults        1  2
/dev/hda1        /XP              ntfs        user,umask=1000,ro,auto      1  0
/dev/hda2        /PROGRAMS        ntfs        user,umask=1000,ro,auto      1  0
/dev/hda3        /DATA            vfat        user,umask=1000,rw,auto      1  0
/dev/cdrom      /mnt/cdrom      iso9660    noauto,owner,ro  0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
###added these for usb devices
/dev/sda1        /mnt/sda1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdb1        /mnt/sdb1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdc1        /mnt/sdc1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdd1        /mnt/sdd1        vfat        user,umask=1000,rw,noauto 0 0
###added these for CD-RW & DVD+-RW
/dev/scd0        /mnt/cdrw        iso9660    user,umask=1000,rw,noauto 0 0
/dev/scd1        /mnt/dvd        iso9660    user,umask=1000,rw,noauto 0 0

All drives mount as user, and all are read/write except the NTFS drives. And
the hard drives are automounting. Just a suggestion of another method.

Edit: I don't know about icons on the desktop. Try right-clicking on them and
changing their properties.

salahuddin_66 09-23-2004 02:25 AM

all prob solved after remove the unmask=022 option from fstab :)


All times are GMT -5. The time now is 07:28 AM.