-   Slackware (
-   -   Small Bugs with KDE 3.3.2 (Slackware 10.1) ?? (

rajen 02-25-2005 11:54 AM

Small Bugs with KDE 3.3.2 (Slackware 10.1) ??

I just upgraded from Slackware 10.0 to 10.1. I encountered a few minor bugs with KDE 3.3.2. I am not sure though whether they are KDE specific or some build problems with Slackware.

First of all sound does not start in Full Duplex mode. When I try to enable "Full Duplex", I get a message like "arts server - Fatal error........will use the null device....... " something like that. In short, when I tried to enable Full Duplex sound I get this error and sound output stops completely. If I disable "Full Duplex", sound output is restored. Earlier with KDE 3.2.3, I had no such problem using Full duplex sound. I need it because I use Skype regularly. I also tried other options like trying to use Full Duplex with "root" login, but the same error, so problem like root access to some device, etc. is ruled out. I tried to use both the kernels (2.4.29 - default and the 2.6.10 - testing) with appropriate alsa-drivers. But the same result. BTW, I am using Intel 845 Motherboard with AC'97 sound (Analog Devices - 1981 chipset). I have no reason to think there is some kernel or alsa-driver problem, because I also tried using the old alsa-driver-1.0.5a_2.6.7-i486-1 and kernel 2.6.7 from Slackware 10.0, but had the same result. Can't figure out the problem.

Second problem (which actually is not so important, but still) is getting Full list of Screen savers. I mean I get a partial list of screen savers under "Appearance & Themes > Screen Saver" in Control Centre. The list from "xscreensaver" is missing. Only those screen savers with default KDE are available. After a bit of investigation, I found out that the problem is with and (/opt/kde/lib/kde3/). When I used these 2 files from old KDE 3.2.3, the screen saver list from "xscreensaver" is now available. This is not a big problem, but just thought I would mention it.

I haven't done any more experimentation, as I reverted back to good old KDE 3.2.3 and everything is working as smoothly as before.


Those who profess to favor freedom, and yet deprecate agitation, are
men who want rain without thunder and lightning. They want the ocean
without the roar of its many waters.
-- Frederick Douglass

datadriven 03-21-2005 07:58 PM

I think I remember this as being a permissions problem. Try:

chmod 666 /dev/dsp

All times are GMT -5. The time now is 10:34 AM.