LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-24-2017, 02:42 AM   #1
bilbod
Member
 
Registered: Mar 2003
Posts: 134

Rep: Reputation: 33
Sluggish libreoffice


I am using libreoffice from alien Bob's repo (5.3.3.2).

Calc is very sluggish compared to the (5.2.3.3) version from Gentoo on the same hardware and spreadsheets.

Opening a spread sheet with one column with 24 entries takes several seconds on Slackware but is instantaneous on Gentoo.

Also the Albany font is missing?

Can this be fixed?

Last edited by bilbod; 05-24-2017 at 07:06 PM.
 
Old 05-24-2017, 11:09 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: Slackware®
Posts: 13,388
Blog Entries: 31

Rep: Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568Reputation: 2568
Member response

Hi,

When you downloaded the package was the hash code checked(md5 at the download site) to verify the download was valid? Check the logs after launch of the application?

Hope this helps.
Have fun & enjoy!
 
Old 05-24-2017, 11:28 AM   #3
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 915
Blog Entries: 5

Rep: Reputation: 145Reputation: 145
I'm using LibreOffice on Slackware64 14.2 with KDE.

During a session, the first time I open LO (Calc or Writer), it does take some seconds (approx. 10-15 seconds). However, when I open it again (after exiting it) during the same session, it pops up quite rapidly (2-3 seconds). I guess it has to do with LO being kept in memory after the first launch.

I have this LO behaviour since a long time. I just upgraded to LO 5.3.3 from LO 5.2.6 using AlienBOB package and I didn't notice any change in this behaviour.

Do you see any improvement when you repeat launching/exiting LO during the same session in Slackware?

Maybe Gentoo pre-loads LO when opening a session. That would explain its instantaneous start.
 
Old 05-24-2017, 11:34 AM   #4
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,504

Rep: Reputation: 1117Reputation: 1117Reputation: 1117Reputation: 1117Reputation: 1117Reputation: 1117Reputation: 1117Reputation: 1117Reputation: 1117
Quote:
Originally Posted by gegechris99 View Post
I'm using LibreOffice on Slackware64 14.2 with KDE.

During a session, the first time I open LO (Calc or Writer), it does take some seconds (approx. 10-15 seconds). However, when I open it again (after exiting it) during the same session, it pops up quite rapidly (2-3 seconds). I guess it has to do with LO being kept in memory after the first launch.

I have this LO behaviour since a long time. I just upgraded to LO 5.3.3 from LO 5.2.6 using AlienBOB package and I didn't notice any change in this behaviour.

Do you see any improvement when you repeat launching/exiting LO during the same session in Slackware?

Maybe Gentoo pre-loads LO when opening a session. That would explain its instantaneous start.
That's not just LibreOffice. It's normal behavior for any app due to the kernel's disk cache usage (edit: not that I think you were saying it only happens with LibreOffice, but to clarify). It could be the difference, though, if the OP tested on Slackware with a new session but on Gentoo with memory for LibreOffice already cached. I somehow doubt Gentoo pre-opens LO to get it in the disk cache.

Last edited by montagdude; 05-24-2017 at 11:41 AM.
 
Old 05-24-2017, 02:08 PM   #5
bilbod
Member
 
Registered: Mar 2003
Posts: 134

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by onebuck View Post
When you downloaded the package was the hash code checked(md5 at the download site) to verify the download was valid? Check the logs after launch of the application?
I installed it with slackpkg (slackpkg+ plugin checks that automatically).

I saw nothing in the logs. I tried running it from a terminal to see if it gave any output and it didn't.

It doesn't appear to have a debug or verbose mode.

I removed the splash screen and used the quick start feature so it opens faster now.

It is still slow to open spreadsheets. It seems to take twice as long as the Gentoo version.
 
Old 05-24-2017, 04:01 PM   #6
bilbod
Member
 
Registered: Mar 2003
Posts: 134

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by montagdude View Post
That's not just LibreOffice. It's normal behavior for any app due to the kernel's disk cache usage (edit: not that I think you were saying it only happens with LibreOffice, but to clarify). It could be the difference, though, if the OP tested on Slackware with a new session but on Gentoo with memory for LibreOffice already cached. I somehow doubt Gentoo pre-opens LO to get it in the disk cache.
Gentoo has modified the code to make the program open faster. The alien Bob version has the LO logo splash visible for several seconds. The Gentoo branded LO has a Gentoo splash screen that is visible for less than a second before the program opens.

If I disable the splash screen on alien Bob's version, the program does open faster. You see a small black square instead of the LO logo and it stays on the screen for maybe a second.

The quick start feature preloads part of LO into ram when you start up and puts an icon in the system tray. I don't think Gentoo uses the quick start feature, at least there is no icon in the system tray and they don't normally do things 'behind your back'.

By turning off the splash screen and using the quick start feature, alien Bob's LO opens about as fast as the Gentoo LO.

There are 2 LO's on SBo. One is based on the official binary release from the LO developers and the other is compiled from source. I removed alien Bob's LO and installed the SBo binary version. The program opens very quickly, it loads spreadsheets very quickly and the sluggishness I felt using alien Bob's version is gone.

Problem solved.
 
1 members found this post helpful.
Old 05-25-2017, 07:42 PM   #7
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 720

Rep: Reputation: 142Reputation: 142
Scrolling thru many lines of a spreadsheet there is no hesitation with SBo version like there is with AlienBOB version, not a complaint just an observation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Libreoffice missing menus in XFCE4 alleyoopster Linux - Desktop 7 09-11-2015 05:35 AM
[SOLVED] LibreOffice is occasionally switching the font as I type Gregg Bell Linux - Newbie 4 07-29-2015 09:45 PM
LXer: Better font support in LibreOffice on Fedora LXer Syndicated Linux News 0 09-15-2014 01:50 PM
[SOLVED] LibreOffice SlackBuild (from SBO) Missing Files? tronayne Slackware 4 03-29-2013 12:50 PM
LibreOffice: saving file as odg and adjusting the font in Draw. JosephS Linux - Software 0 01-23-2012 09:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration