LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-13-2009, 08:57 AM   #1
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809
Blog Entries: 58

Rep: Reputation: Disabled
Slow bootup due to Appletalk daemons


Using Slackware64-current.
Do I need these daemons if I'm not communicating in any way with any Apple computers? Are they necessary for anything else? How do I exorcise them? There's an appletalk module loaded too, in the generic kernel. Is the right way to get rid of that to run:
modprobe -r appletalk?
 
Old 07-13-2009, 09:08 AM   #2
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
I don't think you need them, maybe just blacklist them in '/etc/modprobe.d/blacklist' and also make sure they aren't being loaded by any script in '/etc/rc.d', but I don't think they are. For example comment out the 'netatalk' part in rc.M and 'modprobe appletalk' in rc.modules or rc.modules-$(uname -r) if they exist.
 
Old 07-13-2009, 09:14 AM   #3
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809

Original Poster
Blog Entries: 58

Rep: Reputation: Disabled
Right, thanks. They're a nuisance, seem to double the bootup time.
 
Old 07-13-2009, 09:27 AM   #4
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64® Current
Posts: 1,038

Rep: Reputation: 126Reputation: 126
I just chmod a-x /etc/rc.d/rc.atalk
 
Old 07-13-2009, 09:29 AM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
It's true that from the default install you can usually cut the boot time in half by disabling startup scripts, modifying rc.M, maybe using the lilo compact option, and recompiling the kernel. When I install sw 13 I'll make note of what can be done and post a howto.

The last one I made is here, but is only known to be accurate for sw 12.0:
http://www.linuxquestions.org/questi...ml#post2921723
 
Old 07-13-2009, 09:37 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809

Original Poster
Blog Entries: 58

Rep: Reputation: Disabled
Yes, that's better! Commented out appletalk in rc.M, and blacklisted the bugger as well! Boots up a hell of a lot faster now.
 
Old 07-13-2009, 11:26 AM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: Slackware®
Posts: 13,463
Blog Entries: 32

Rep: Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655Reputation: 2655
Hi,

You should remember that you have the choice when you are installing to select the desired services. 'rc.atalk' is one of the services that should be disabled if you don't have a need for 'apple talk'.

You can always re-run pkgtool then choose scripts to run and then choose the desired option for the service(s). Or in this case just do a 'chmod' from the cli.
 
Old 07-13-2009, 11:38 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809

Original Poster
Blog Entries: 58

Rep: Reputation: Disabled
Yeah, that rc.atalk must have sneaked in under my radar when I was installing. Never had that activated on any previous releases.
 
Old 07-13-2009, 12:09 PM   #9
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
There's no rc.atalk for me, but I haven't upgraded to sw 13 yet.
 
Old 07-13-2009, 12:29 PM   #10
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
There's no rc.atalk for me, but I haven't upgraded to sw 13 yet.
Odd - this is part of the netatalk package which has been there for ages. It was there in Slackware 9.0 anyway.
 
Old 07-13-2009, 12:32 PM   #11
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809

Original Poster
Blog Entries: 58

Rep: Reputation: Disabled
It mustn't have been activated by default before.
 
Old 07-13-2009, 12:50 PM   #12
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
It mustn't have been activated by default before.
Yeah - I noticed on a recent VM install (think it was -current) that the appletalk stuff was coming up at boot up. I just thought I had inadvertently set this up in the setup script as I tend run setups on "autopilot" now. (Loosing my marbles a bit perhaps).
 
Old 07-13-2009, 01:07 PM   #13
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809

Original Poster
Blog Entries: 58

Rep: Reputation: Disabled
Me too, tend to take things for granted.
 
Old 07-14-2009, 05:03 AM   #14
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809

Original Poster
Blog Entries: 58

Rep: Reputation: Disabled
I will be disabling it during installation in future.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Application are very slow due to lack of Network connection winxandlinx Linux - Networking 2 02-18-2007 11:35 PM
10.1 - slow bootup 144419855310001 SUSE / openSUSE 3 04-02-2006 07:30 PM
Slow web browsing due to DNS... Help! DragonM15 Slackware 14 01-19-2006 12:47 PM
daemons starting on bootup papajohns AIX 4 08-04-2004 02:27 PM
Slow Bootup XPediTioN Slackware 9 07-01-2004 03:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration