-   Slackware (
-   -   Slim login manager in -Current (

piratesmack 03-04-2010 04:05 PM

Slim login manager in -Current
I had Slim working with the latest -Current updates, but that was with a package I built before updating.

I borked my system yesterday and had to do a fresh install. Now I can't get Slim working.

I tried running the Slim SlackBuild from, and it failed without giving any errors. I figured out that the problem was with this section:

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null

The strip commands were failing and caused the SlackBuild to exit, so I added '|| true' to them.

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null || true
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null || true

Not sure why this is needed in -Current and not 13, maybe because of Bash 4.1?

Anyway, now the package builds successfully, but Slim won't start.
My system just hangs at a black screen after 'Starting up X11 session manager...'

Has anybody been able to get Slim working in -Current?

linus72 03-04-2010 04:13 PM


I been having issues with my Slim stuff too

I got Slim from SBOpkg as you did
it boinked at startup and I had to get sysvinit-scripts from SalixOS (thanks gapan)
which adds a place for slim before gdm,etc in /etc/rc.d/rc.4

heres my rc.4


#! /bin/sh
# rc.4                This file is executed by init(8) when the system is being
#                initialized for run level 4 (XDM)
# Version:        @(#)/etc/rc.d/rc.4        2.00        02/17/93
# Author:        Fred N. van Kempen, <>
# At least 47% rewritten by:  Patrick J. Volkerding <>
# Modified for Salix by: George Vlahavas <vlahavas~at~gmail~dot~com>

# Tell the viewers what's going to happen (in red)...
echo -e "\033[01;31mStarting up X11 session manager...\033[00m"

# Try slim first
if [ -x /usr/bin/slim ]; then
  exec /usr/bin/slim

# Then try gdm
if [ -x /usr/bin/gdm ]; then
  exec /usr/bin/gdm -nodaemon

# Someone thought that gdm looked prettier in /usr/sbin,
# so look there, too:
if [ -x /usr/sbin/gdm ]; then
  exec /usr/sbin/gdm -nodaemon

# Not there?  OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
  exec /opt/kde/bin/kdm -nodaemon
elif [ -x /usr/bin/kdm ]; then
  exec /usr/bin/kdm -nodaemon

# If all you have is XDM, I guess it will have to do:
if [ -x /usr/bin/xdm ]; then
  exec /usr/bin/xdm -nodaemon
elif [ -x /usr/X11R6/bin/xdm ]; then
  exec /usr/X11R6/bin/xdm -nodaemon

# error
echo "Hey, you don't have GDM, slim, KDM or XDM installed.  Can't use runlevel 4"
echo "without one of those installed."
sleep 30

# All done.

mmm..and I think that solved it.

see here too

piratesmack 03-04-2010 04:42 PM

Thanks for the quick response.

So you have Slim working on the latest Slackware-Current with a package you built on the latest Current?

Because I already added something similar to my rc.4 and Slim fails to start. (black screen)


I see some libpng errors in /var/log/slim.log
I'll try rebuilding slim against libpng 1.4.0 and see if it fixes the problem.

amiga32 03-04-2010 05:02 PM

Yes definitely upgrade libpng. I don't use -current but I know libpng was recently fixed.

linus72 03-04-2010 05:04 PM


yes, I have Slim in Absolute-Live

and also in almost all my *buntu/debian/slack installs

the auto login as root or user is feature not found elseware

piratesmack 03-04-2010 05:32 PM

1 Attachment(s)
Compiling against libpng 1.4.0 didn't help.
Attached is my Slim.log

piratesmack 03-04-2010 06:20 PM

Not sure if this was a good idea, but I patched the Makefile to use /usr/include/libpng14 instead of /usr/include/libpng12 and now it works!

I just added "sed -i 's/png12/png14/g' Makefile" to the SlackBuild

niels.horn 03-04-2010 06:20 PM

Well, first of all, SlackBuilds are only tested on the stable version of Slackware, like 13.0, not on the -current version.
If you run -current, you are supposed to be able to change source code, mess around with bash scripts, etc. :)

But, I have SLiM running on -current, after applying the following patch to the png.c file that is included in the source:

--- slim-1.3.1_orig/png.c        2008-09-25 21:54:15.000000000 -0300
+++ slim-1.3.1/png.c        2010-03-04 21:05:17.894619498 -0300
@@ -21,7 +21,7 @@
 #include <stdio.h>
 #include <stdlib.h>
-#include <png.h>
+#include <libpng12/png.h>
 read_png(const char *filename, int *width, int *height, unsigned char **rgb,

No guarantees here, apply this at your own risk ;)

niels.horn 03-04-2010 06:23 PM

@piratesmack: We posted at the sabe time :)

Your patch uses the newer libpng, my patch uses the older header file.
Both ways it should work I guess.

I preferred to point at the older libpng, as SLiM was working with the older lib previously, so less chance of surprises!

piratesmack 03-04-2010 06:31 PM

Thanks for the patch, niels.horn.
Glad to have this working.

All times are GMT -5. The time now is 05:26 PM.