-   Slackware (
-   -   Slapt-get: no such file error. (

wolfslacker 11-26-2013 11:32 AM

Slapt-get: no such file error.
Well I have installed Slackware 14.1 32-bit and I'm trying to get slapt-get to install any patches. After I installed slapt-get, I get the following error whenever I do an update.
-su: /usr/sbin/slapt-get: No such file or directory
I did confirm that there exist a file called "slapt-get" at the above location and it is executible. Any help would be appreciated.

Didier Spaier 11-26-2013 11:59 AM

If it's binary, maybe it's a 64 bit executable instead of 32?

Try "file /usr/sbin/slapt-get" to make sure.

PS preferably use slackpkg instead of slapt-get for that purpose.

perbh 11-26-2013 12:36 PM

"No such file or directory" usually means one (or more) missing libraries ...
Try 'readelf -d /usr/sbin/slapt-get' ('readelf' from the 'man' himself)

perbh 11-26-2013 12:42 PM

"No such file or directory" usually means one (or more) missing libraries ...
Try 'readelf -d /usr/sbin/slapt-get' ('readelf' from the 'man' himself)

wolfslacker 11-26-2013 10:20 PM

Still not working.
Well I tried the 64-bit and got "cannot execute file" error so I resorted to installing the patches manually. After the patch installs, I can no longer bring up Firefox. It's late now and I've done 4 re-installs. I'll trying debugging tomorrow.

Didier Spaier 11-27-2013 12:54 AM

Of course 64 bit binaries won't work on a 32 bit Slackware. Why try that?

As perbh pointed out, you could miss some library, either because you didn't install a full Slackware (you should), or you didn't install some dependency of slapt-get.

Also, which patches? I'm not aware of any needed patch.

Which version of slapt-get do you have, where did you get it, how did you install it?

Again, if you want to use Slackware, you'll have to learn how it works and to use (exclusively, at least till you master it) tools included in it. Slapt-get is not among them for a reason.

To begin learning how Slackware works, type "mail" on a terminal as root and read the mail from Patrick Volkerding then visit

Or, if for some reason you want to use slapt-get, just install Salix instead of Slackware.

dwblas 11-27-2013 10:59 AM

I've been using slapt-get on 14.1 with no problems. First try
upgradepkg --install-new
and if that doesn't help then download the slapt-get txz file and use installpkg to reinstall it.

wolfslacker 11-28-2013 01:19 PM

Thanks for your help. I forgot about slackpkg which solved everything. Also, re-installing Slackware in the late of night wasn't helpful.

All times are GMT -5. The time now is 04:22 AM.